We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 31902
    • 342 Posts
    Thank you for your response, Susan. I'll look into that.
      • 36551
      • 416 Posts
      I'm getting errors connecting to extras as well from two different host environments. Both have been working. I went to the extras page directly to download the package manually, and got a 503 error after clicking on the download button for the package. A few minutes later I tried again and was able to download the package to my computer. I uploaded to the server and installed so I'm good to go. Still can't connect via package manager on either site.

      Thought someone should know.
        • 3749
        • 24,544 Posts
        Terry, FYI - You probably know this, but typically you won't get notification of available updates or the ability to update via PM on packages you upload manually.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 36551
          • 416 Posts
          Bob

          I did not know that. I suppose I should uninstall and reinstall it.

          Good to know.

          Thanks.
            • 3749
            • 24,544 Posts
            It depends on what's in the provider column in the Package Manager grid. If it still says modx.com (and it may since you installed it before), you're OK. If it's blank, you won't get any notifications of available upgrades.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 22827
              • 129 Posts
              I am getting a 404 back from http://rest.modx.com/extras

              So I am not blocked, but the server is reporting the extras page is not there. From two different source networks.

              Anyone else seeing this?

                • 22827
                • 129 Posts
                Hmm, scratch that, the server was using opendns for DNS and was messing up the DNS query
                  • 49431
                  • 3 Posts
                  Hello.
                  My MODX returns the same message:

                  An error occurred while connecting to the Provider: MODX received a blank response from the provider. Please double check your service URL and make sure the provider is a valid provider.

                  and the log's error message:
                  [2014-11-25 09:56:00] (ERROR @ /modx1-test/connectors/index.php) Could not connect to provider at: http://rest.modx.com/extras/


                  Are there special requirements for PHP or Operation System to work Download Extras function?
                  Why the MODX said "everything is OK" during the installation process?
                  Please help. I do not understand why it doesn't work.

                  MODX Revolution 2.3.2-pl (traditional)
                  MySQL 5.1.37
                  PHP Version 5.3.10
                  cURL support enabled
                    • 27708 MODX Staff
                    • 2,502 Posts
                    Quote from: asidorov72 at Nov 25, 2014, 04:47 AM
                    Hello.
                    Are there special requirements for PHP or Operation System to work Download Extras function?
                    Not beyond cURL working or fopen. Sometimes the response from the server can take some time and this may cause the source server to time out.
                      Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. Blog ✦ Twitter ✦ LinkedIn ✦ GitHub