We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 19872
    • 1,078 Posts


    Quote from: ibuildermiles at Feb 28, 2013, 12:49 AM
    I have just installed MODX Revolution 2.2.6-pl (traditional)and after logging in, I get only text menus.. (see attached image.)

    I have tried to follow the above instructions,
    login to phpMyAdmin > browse table 'modx_system_settings'

    and there is no fields named compress_css nor compress_js.

    Can not set them to 9 if they do not exist.. see 2nd attached image. I have deleted the /core/cashe/ folder, it is now empty.

    Any thoughts?


    How did everything turn out? Did you get it working?
      • 12603
      • 13 Posts
      Quote from: mmcgee at Feb 28, 2013, 06:53 AM


      Quote from: ibuildermiles at Feb 28, 2013, 12:49 AM
      I have just installed MODX Revolution 2.2.6-pl (traditional)and after logging in, I get only text menus.. (see attached image.)

      I have tried to follow the above instructions,
      login to phpMyAdmin > browse table 'modx_system_settings'

      and there is no fields named compress_css nor compress_js.

      Can not set them to 9 if they do not exist.. see 2nd attached image. I have deleted the /core/cashe/ folder, it is now empty.

      Any thoughts?


      How did everything turn out? Did you get it working?

      I did actually thank you, however now I am having just massive issues with being timed out every time I load a page, save, or anything I do.. and I mean in seconds... if I click of view Elements i get "Access Denied" even though I am logged in as the root admin
        • 19872
        • 1,078 Posts
        Quote from: ibuildermiles at Feb 28, 2013, 07:13 AM
        Quote from: mmcgee at Feb 28, 2013, 06:53 AM


        Quote from: ibuildermiles at Feb 28, 2013, 12:49 AM
        I have just installed MODX Revolution 2.2.6-pl (traditional)and after logging in, I get only text menus.. (see attached image.)

        I have tried to follow the above instructions,
        login to phpMyAdmin > browse table 'modx_system_settings'

        and there is no fields named compress_css nor compress_js.

        Can not set them to 9 if they do not exist.. see 2nd attached image. I have deleted the /core/cashe/ folder, it is now empty.

        Any thoughts?


        How did everything turn out? Did you get it working?

        I did actually thank you, however now I am having just massive issues with being timed out every time I load a page, save, or anything I do.. and I mean in seconds... if I click of view Elements i get "Access Denied" even though I am logged in as the root admin

        Sorry to hear that. Bob or others may be able to shed more light. It sounds like there may be some permission issues. Did everything PASS when you did original installation? Did you upload the MODx zip and uncompress on the server?

        Bob or other will be able to provide better assistance. But if you decide to just try a new installation, I will say that there may be a few folders that you will not be able to delete from the server—no matter how you set the permissions. In each instance, I just call the host support and ask them to remove them.
          • 12603
          • 13 Posts
          Quote from: mmcgee at Feb 28, 2013, 07:32 AM
          Quote from: ibuildermiles at Feb 28, 2013, 07:13 AM
          Quote from: mmcgee at Feb 28, 2013, 06:53 AM


          Quote from: ibuildermiles at Feb 28, 2013, 12:49 AM
          I have just installed MODX Revolution 2.2.6-pl (traditional)and after logging in, I get only text menus.. (see attached image.)

          I have tried to follow the above instructions,
          login to phpMyAdmin > browse table 'modx_system_settings'

          and there is no fields named compress_css nor compress_js.

          Can not set them to 9 if they do not exist.. see 2nd attached image. I have deleted the /core/cashe/ folder, it is now empty.

          Any thoughts?


          How did everything turn out? Did you get it working?

          I did actually thank you, however now I am having just massive issues with being timed out every time I load a page, save, or anything I do.. and I mean in seconds... if I click of view Elements i get "Access Denied" even though I am logged in as the root admin

          Sorry to hear that. Bob or others may be able to shed more light. It sounds like there may be some permission issues. Did everything PASS when you did original installation? Did you upload the MODx zip and uncompress on the server?

          Bob or other will be able to provide better assistance. But if you decide to just try a new installation, I will say that there may be a few folders that you will not be able to delete from the server—no matter how you set the permissions. In each instance, I just call the host support and ask them to remove them.

          yes the installation was smooth, all green lights everything passed. I uploaded the extracted files to the web server, and everything seems installed, even added some packages (tho this was a chore with being timed out all the time, but packages did install) It just seems a session issue, I am looking into cookie storage and going to try to move cookies to my own folder buried in the site and change the session_save_path
            • 19872
            • 1,078 Posts
            "I uploaded the extracted files to the web server,"

            I recommend uploading the zip and then extracting on the server, using the host ftp manager utility to extract or uncompress the zip. Then run the installer. Whenever I have extracted on my own computer and then uploaded, I have spent countless hours troubleshooting permission issues with various files and folder.
              • 3749
              • 24,544 Posts
              See this: http://bobsguides.com/modx-upgrade-faq.html. It's about upgrading, but the part about transferring the files applies to new installs as well.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 12603
                • 13 Posts
                I fixed this issue, just moved my site to godaddy ultimate hosting.. problem solved.
                  • 11681
                  • 98 Posts
                  Mysterious late-version Revo problems solved temporarily by invalidating (via deleting) the cache folder and permanently by switching to a new hosting service?

                  Could we be encountering the same problem? It's only human to see ones problem as a variation of a problem that someone else has reported. I may be guilty of that by pointing you at this post:

                  https://forums.modx.com/thread/83823/help-error-after-upgrading-modx-rev-from-2-2-6-pl-to-2-2-7-pl-syntax-error-internal-server-error?page=2#dis-post-463394

                  The hosting service does seem to make a difference, but it should not. One service might be slower than another, but all should produce the same results. I believe there is an underlying problem here worthy of the core development team.
                    I looked just like that in 1964.
                    • 10208 ☆ A M B ☆
                    • 1,780 Posts
                    I had a site last fall that I had to do this same thing with. Constant session logouts, issues with php.ini being overwritten, php being downgraded, and the grand poohbah of them all was the fact that the main box at the shared server was being changed randomly every few weeks, which messed up MODX's config paths even though they were correct for that site. The root paths are used by package management somehow, and I think this session issue also had something to do with it.

                    I moved the site to my server, (Hostgator at that time) and all the issues went away. Having a server set up for MODX is a fine thing indeed. Not every hosting company is equal in that respect.

                    Try SkyToaster. They love MODX, there's no question about suitability and the support is next to none. MODX support even.
                      Frogabog- MODX Websites in Portland Oregon
                      "Do yourself a favor and get a copy of "MODX - The Official Guide" by Bob Ray. Read it.
                      Having server issues? These guys have MODX Hosting perfected - SkyToaster