We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 6038
    • 228 Posts
    Quote from: nomark at Feb 21, 2013, 11:52 PM
    Christian, do you have the dashboard or the dashboard widget installed?

    I've installed 'Google Analytics Dashboard Widget' v1.0.1, added settings in the system_settings analytics namespace, and then edited my default dashboard to include the widget. My manager theme is default.
    When I first visit the dashboard, I see the 'Google Analytics' panel, with 'click here to authenticate through Google' link.
    When google asks me to Allow access and redirects me, I get the 500 error.

    I've attached a screenshot of my settings - do they look right?
      • 33987 ☆ A M B ☆
      • 197 Posts
      I'm a bit lost here. That's the correct widget... The settings shouldn't be changed by yourself by the way. All should be handled when authenticating. Have you tried removing all settings and re-authenticating?
        Sterc Internet & Marketing | MODX Founding Partner | Chairman of the MODX Advisory Board

        In need of a MODX consult? Try our MODX Developers Experts!
        • 6038
        • 228 Posts
        Yes, I only tried manually entering settings once it failed initially - I thought perhaps this was an extra step you had to make.

        Have completely removed package, re-installed and tried re-authenticating but its always the same: after allowing google to authenticate, the redirection to the manager page results in the 500 error. Any subsequent visits to the manager welcome page also result in 500 errors, all other pages in the manager work as expected.

        After a bit more poking around - it seems to be related to the analytics_sessionToken
        I notice in the settings the session token begins typically like: 1/KBI2###
        In the querystring, the encoded forward slash seems to be the cause of the 500 error - because if I replace it with some random characters, then I get actually get a message back saying 'Error Authenticating with Google'

        If I delete the session token from my system settings, the manager welcome page will return to loading normally

        Any ideas?!
          • 33987 ☆ A M B ☆
          • 197 Posts
          Hmm, sounds like a real bug wink I'll pass it on to one of our developers. Might take a couple of days, because it's a busy week.
            Sterc Internet & Marketing | MODX Founding Partner | Chairman of the MODX Advisory Board

            In need of a MODX consult? Try our MODX Developers Experts!
            • 42046
            • 436 Posts
            I had a similar problem setting this up and despite specifying everything correctly in the system settings I got errors until I went to the 'Settings' tab on the analytics dashboard widget and selected the already specified profile from the 'Site profile:' drop down. After that it worked fine.
              • 6038
              • 228 Posts
              Hmm, I don't have a 'Site profile' dropdown in my widget's settings, or the system settings...
                • 42046
                • 436 Posts
                Here's what mine look like:
                  • 6038
                  • 228 Posts
                  Ah, ok - that makes it clearer - you are talking about the interface of the widget, I was looking at the generic widget settings.
                  My problem is I can't get authenticate with google without the widget causing a 500 server error.
                    • 42046
                    • 436 Posts
                    I can't remember getting a 500 error but I do remember getting an error when I entered http://www.whatever.com into the analysics_sitename variable in the system setting like on your screen grab. It only worked after I logged into analytics and went back to the dashboard and selected the 'Google Analytics Profile whatever.com' from the drop down. Notice how both my screen grabs state 'Google Analytics Profile whatever.com' rather than 'http://www.whatever.com'
                      • 18367
                      • 834 Posts
                      Hi maybe I'm missing the obvious but how do you even install this widget?

                      I've downloaded it thru Package management, but other than that there are no instructions on what to do next.

                      And I can't see anything in the backend that look like install or configuration options.

                      What exactly do you have to do to make it appear?

                      Thanks
                        Content Creator and Copywriter