-
☆ A M B ☆
- 197 Posts
I'm a bit lost here. That's the correct widget... The settings shouldn't be changed by yourself by the way. All should be handled when authenticating. Have you tried removing all settings and re-authenticating?
Yes, I only tried manually entering settings once it failed initially - I thought perhaps this was an extra step you had to make.
Have completely removed package, re-installed and tried re-authenticating but its always the same: after allowing google to authenticate, the redirection to the manager page results in the 500 error. Any subsequent visits to the manager welcome page also result in 500 errors, all other pages in the manager work as expected.
After a bit more poking around - it seems to be related to the analytics_sessionToken
I notice in the settings the session token begins typically like: 1/KBI2###
In the querystring, the encoded forward slash seems to be the cause of the 500 error - because if I replace it with some random characters, then I get actually get a message back saying 'Error Authenticating with Google'
If I delete the session token from my system settings, the manager welcome page will return to loading normally
Any ideas?!
-
☆ A M B ☆
- 197 Posts
Hmm, sounds like a real bug

I'll pass it on to one of our developers. Might take a couple of days, because it's a busy week.
I had a similar problem setting this up and despite specifying everything correctly in the system settings I got errors until I went to the 'Settings' tab on the analytics dashboard widget and selected the already specified profile from the 'Site profile:' drop down. After that it worked fine.
Hmm, I don't have a 'Site profile' dropdown in my widget's settings, or the system settings...
Here's what mine look like:
Ah, ok - that makes it clearer - you are talking about the interface of the widget, I was looking at the generic widget settings.
My problem is I can't get authenticate with google without the widget causing a 500 server error.
Hi maybe I'm missing the obvious but how do you even install this widget?
I've downloaded it thru Package management, but other than that there are no instructions on what to do next.
And I can't see anything in the backend that look like install or configuration options.
What exactly do you have to do to make it appear?
Thanks
Content Creator and Copywriter