I made a fresh installs of different versions of MODX: 2.2.2, 2.2.1, 2.1.5, 2.3.0 dev from git and everywhere there is no resource tree and the links in the topmenu point to blank pages.
I tried setting compress_js to 0 in database and cleaned cache directory and browser cache after that. Still javascript errors in the manager as seen in the attached screenshot.
Please help and/or fix this.
My environment:
Ubuntu 12.04
PHP 5.3.10 with Suhosin Patch 0.9.10
Apache/2.2.22 (Ubuntu)
MySQL Client Version 5.5.22
Well I've come to find my re-run setup was only a temporary fix. I did figure out a work around you might try although this does not "fix" the issue.
When you go to your website login using www.yourdomain.com/manager. Make sure to put in the www, if you're already using www then try leaving it out. This works for me on a site I was having the same problem with after upgrading from 2.1 to 2.2.
I did some searching around and could not find out why this works which would reveal the issue and how to actually fix it. But at least it allows you to work in manager again.
MODX...the Zen of CMS
"Bight off more than you can chew and keep right on chewing."
Any other advice? I still can´t get it to work.
I never found a solution for this as such. We found it was a problem with the server setup - what exactly I don't know. We were using a shared host with a cpanel, and the server people eventually switched us to something else and it worked straight away.
Not a massive amount of help I know - wish I could be more useful. I've definitely had a lot more problems installing MODx revo then I ever did with evolution but it always seems to come down to the server setup. Used evolution for 2.5 years and never had any problems installing. Since using Revo for 6 months I've had about 3-4 instances of it not installing or migrating correctly and it leaving me stumped.
Still, Revo is way better before me despite it's little quirks.
I've done quite a few new installs, migrations, and upgrades with Revo and had very few problems. When I strayed from BobRay's guide however I did run into some snags now and then. Here's the two guides he made for installation and upgrading that I adhere to these days:
http://bobsguides.com/modx-installation-faq.html
http://bobsguides.com/modx-upgrade-faq.html
In the first link Bob does address blank manager pages and what may be causing them.
MODX...the Zen of CMS
"Bight off more than you can chew and keep right on chewing."
it might be caused by apache running with different rights than ftp user
check if you can delete all files trough ftp
if you get 'access denied' while trying to delete some files, you will probably need to find another host
i cannot believe how many unsolvable bugs and errors disappears when you move site somewhere else ;>
It´s working now. Uninstalled every PHP5 package and did a fresh installation of PHP 5.3.1
Now my resource tree shows up and everything works fine. I think it had something to do with suhosin?!