We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 38285
    • 17 Posts
    P.S - I've tried all things suggested in this forum post and in this one:

    https://forums.modx.com/thread/?thread=74672&page=2

    and no joy.
      • 39824
      • 6 Posts
      I made a fresh installs of different versions of MODX: 2.2.2, 2.2.1, 2.1.5, 2.3.0 dev from git and everywhere there is no resource tree and the links in the topmenu point to blank pages.
      I tried setting compress_js to 0 in database and cleaned cache directory and browser cache after that. Still javascript errors in the manager as seen in the attached screenshot.

      Please help and/or fix this.

      My environment:
      Ubuntu 12.04
      PHP 5.3.10 with Suhosin Patch 0.9.10
      Apache/2.2.22 (Ubuntu)
      MySQL Client Version 5.5.22
        • 39333
        • 151 Posts
        Well I've come to find my re-run setup was only a temporary fix. I did figure out a work around you might try although this does not "fix" the issue.

        When you go to your website login using www.yourdomain.com/manager. Make sure to put in the www, if you're already using www then try leaving it out. This works for me on a site I was having the same problem with after upgrading from 2.1 to 2.2.

        I did some searching around and could not find out why this works which would reveal the issue and how to actually fix it. But at least it allows you to work in manager again.
          MODX...the Zen of CMS
          "Bight off more than you can chew and keep right on chewing."
          • 39824
          • 6 Posts
          Too bad i only have a local webserver in our local network. It isn´t on the internet so no www for me sad
            • 39824
            • 6 Posts
            Any other advice? I still can´t get it to work.
              • 38285
              • 17 Posts
              I never found a solution for this as such. We found it was a problem with the server setup - what exactly I don't know. We were using a shared host with a cpanel, and the server people eventually switched us to something else and it worked straight away.

              Not a massive amount of help I know - wish I could be more useful. I've definitely had a lot more problems installing MODx revo then I ever did with evolution but it always seems to come down to the server setup. Used evolution for 2.5 years and never had any problems installing. Since using Revo for 6 months I've had about 3-4 instances of it not installing or migrating correctly and it leaving me stumped.

              Still, Revo is way better before me despite it's little quirks.
                • 39333
                • 151 Posts
                I've done quite a few new installs, migrations, and upgrades with Revo and had very few problems. When I strayed from BobRay's guide however I did run into some snags now and then. Here's the two guides he made for installation and upgrading that I adhere to these days:

                http://bobsguides.com/modx-installation-faq.html
                http://bobsguides.com/modx-upgrade-faq.html

                In the first link Bob does address blank manager pages and what may be causing them.
                  MODX...the Zen of CMS
                  "Bight off more than you can chew and keep right on chewing."
                  • 39824
                  • 6 Posts
                  Tried all suggestions from Bob´s guides "I get a blank page after the install. What's wrong?" but still no resource tree and empty pages.

                  Tried a new installation and the installer finishes without errors. But when i look into the core/cache/log folder there is a log with the following errors:

                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not copy /var/www/henworx/modx/core/packages/core/modContext/4639ec34ad71b663100fcbbdf1a4f655/0/ to /var/www/henworx/modx/index.php
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not copy /var/www/henworx/modx/core/packages/core/modContext/4639ec34ad71b663100fcbbdf1a4f655/1/ to /var/www/henworx/modx/ht.access
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not copy /var/www/henworx/modx/core/packages/core/modContext/095afbdb7948ea7e51c515b2e584b450/0/ to /var/www/henworx/modx/manager/assets
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not copy /var/www/henworx/modx/core/packages/core/modContext/095afbdb7948ea7e51c515b2e584b450/1/ to /var/www/henworx/modx/manager/controllers
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not copy /var/www/henworx/modx/core/packages/core/modContext/095afbdb7948ea7e51c515b2e584b450/2/ to /var/www/henworx/modx/manager/templates
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not copy /var/www/henworx/modx/core/packages/core/modContext/095afbdb7948ea7e51c515b2e584b450/3/ to /var/www/henworx/modx/manager/min
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not copy /var/www/henworx/modx/core/packages/core/modContext/095afbdb7948ea7e51c515b2e584b450/4/ to /var/www/henworx/modx/manager/ht.access
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not copy /var/www/henworx/modx/core/packages/core/modContext/095afbdb7948ea7e51c515b2e584b450/5/ to /var/www/henworx/modx/manager/cache.manifest.php
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not copy /var/www/henworx/modx/core/packages/core/modContext/095afbdb7948ea7e51c515b2e584b450/6/ to /var/www/henworx/modx/manager/index.php
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/02128ee6cf440f7eea87d3705669f6a4/ to /var/www/henworx/modx/connectors/
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/28eeb05f5f0c8471c298cfe081c447b7/ to /var/www/henworx/modx/connectors/
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/309fcbb3c317a59e7cba35048a100ca5/ to /var/www/henworx/modx/connectors/
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/3a9b7dd91ebbcdd62eb2ff684a15d958/ to /var/www/henworx/modx/connectors/
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/3878ed5478621bb75826665c30064c9a/ to /var/www/henworx/modx/connectors/
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/33ab9c7624538fa8791c20910b52f7f3/ to /var/www/henworx/modx/connectors/
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/5fe9de647807321f5b3dad09aa970087/ to /var/www/henworx/modx/connectors/
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/9bf06e649b9dd14c6e9b17a0a50d8df8/ to /var/www/henworx/modx/connectors/
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/e50021f1ceda6d6da660ac418e486844/ to /var/www/henworx/modx/connectors/
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/d22007ca42f0f37acf757d1763210583/ to /var/www/henworx/modx/connectors/
                  [2012-05-24 16:12:42] (ERROR @ /henworx/modx/setup/index.php) Could not install files from /var/www/henworx/modx/core/packages/core/xPDOFileVehicle/b02a4b17cb43ab756fc21d5823d1cb25/ to /var/www/henworx/modx/connectors/
                  


                  I set all permissions to 775 (same with 777) BEFORE installation so it can´t be a permission problem, right?

                  Please help, i have no more ideas. Maybe if i downgrade PHP to 5.2? [ed. note: jmartsch last edited this post 14 years, 4 months ago.]
                    • 25839
                    • 23 Posts
                    it might be caused by apache running with different rights than ftp user

                    check if you can delete all files trough ftp
                    if you get 'access denied' while trying to delete some files, you will probably need to find another host

                    i cannot believe how many unsolvable bugs and errors disappears when you move site somewhere else ;>
                      • 39824
                      • 6 Posts
                      It´s working now. Uninstalled every PHP5 package and did a fresh installation of PHP 5.3.1
                      Now my resource tree shows up and everything works fine. I think it had something to do with suhosin?!