We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 15308
    • 25 Posts
    No I don't have that widget installed.

    Here's the first lines of the setup logs :
    [2012-01-05 16:08:07] (ERROR @ /setup/index.php) xPDOVehicle resolver failed: type php (D:/xampp/htdocs/e-mhotep4/core/packages/core/modDashboardWidget/043f411291b20759288ad11934f25c7d.resolve.dashboardwidgets.resolver)
    [2012-01-05 16:08:07] (ERROR @ /setup/index.php) Could not resolve vehicle for object of class modDashboardWidget; criteria: Array
    (
    [name] => w_configcheck
    ) [ed. note: kamalito last edited this post 14 years, 8 months ago.]
      • 38004
      • 96 Posts
      Hi,

      I have just upgraded to Revo 2.2 RC2, but when I log into the manager I don't have a document tree, and although I still have the manager menu, I can't open any of the menu items.
        • 28215
        • 4,149 Posts
        - Do you have any other plugins or Extras installed?
        - Did you turn off compress_js and compress_css, and then empty the core/cache/ directory?
        - Are you using suhosin?
        - Do you have anything in your core/cache/logs/error.log file?
        - Anything else we should know?
          shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
          • 37912
          • 12 Posts
          I was experiencing this issue too. It was on a fresh install of 2.2.pl2. I had to go into my database, and manually set compress_css and compress_js to 0. Then, I had to manually clear my cache.

          I have attached a screenshot of the JS errors I was getting before I tried the work around.

          Thanks, guys. Hope this gets resolved soon!
            • 15308
            • 25 Posts
            Quote from: splittingred at Jan 05, 2012, 09:31 AM

            - Did you turn off compress_js and compress_css, and then empty the core/cache/ directory?
            I followed those steps and it solves my problem. Thank you.
              • 23571
              • 223 Posts
              Had the same issue and this solution worked for me as well. You will find these in modx_system_settings btw.
                • 28215
                • 4,149 Posts
                Can all of you experiencing this issue provide environment information in this ticket? http://bugs.modx.com/issues/6509

                (Including your setup - shared hosting, virtual directory, etc)
                  shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                  • 22303 MODX Staff
                  • 10,725 Posts
                  If we identify another source of the issue, then let's open a ticket for it. I would prefer to keep this discussion here until some additional cause is identified, besides those already resolved in #6590 and other closed tickets.

                  To help, please provide information about the following at the very least in this thread:

                  • Your $_SERVER['DOCUMENT_ROOT']
                  • Your MODX_MANAGER_PATH and MODX_MANAGER_URL
                  • Your Suhosin settings
                    • 37912
                    • 12 Posts
                    $_SERVER['DOCUMENT_ROOT'] = C:/Users/tony/Documents/Websites/22.idb.dev/public_html
                    MODX_MANAGER_PATH = C:/Users/tony/Documents/Websites/22.idb.dev/public_html/manager/
                    MODX_MANAGER_URL = /manager/

                    I'm fairly certain I'm not using Suhosin.
                      • 22303 MODX Staff
                      • 10,725 Posts
                      Quote from: tony.wilsman at Jan 06, 2012, 09:17 AM
                      $_SERVER['DOCUMENT_ROOT'] = C:/Users/tony/Documents/Websites/22.idb.dev/public_html
                      MODX_MANAGER_PATH = C:/Users/tony/Documents/Websites/22.idb.dev/public_html/manager/
                      MODX_MANAGER_URL = /manager/

                      I'm fairly certain I'm not using Suhosin.
                      That should work fine. Something else is causing your problem, but I do not have a clue what it could be if not suhosin or some other restrictive php setting (open_basedir or safe_mode?). Can you put this in a php file in your document root and see what it returns?

                      <?php
                      echo realpath($_SERVER['DOCUMENT_ROOT']);
                      
                      [ed. note: opengeek last edited this post 14 years, 8 months ago.]