We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 14125
    • 62 Posts
    OK I will but first, How do I clear cache manually? Or login as superuser?

    Thanks
      • 39705
      • 0 Posts
      I had the same problems as this.. the JS solutions didn't work and various other caching things failed too. Try the option below before starting again.

      In your core/config file I had: $modx_base_url= ' '; (note the empty string)

      I put this in and all is fine! :$modx_base_url= '/'; (note the forward slash)

      only took 12 hours to find it lol.

      Hope this helps
        • 14125
        • 62 Posts
        When I deleted my cache manually it worked fine.

        What an ordeal.
          • 40750
          • 2 Posts
          I had the same issue of blank pages in the manager. Setting compress_js=0 and compress_css=0, and then emptying the core/cache/ directory fixed it for me.

          Using MODx 2.2.4-pl (traditional).
            • 37246
            • 128 Posts
            +1 for webmgr3abn- THANKS

            Quote from: webmgr3abn at Aug 07, 2012, 03:42 PM
            I had the same issue of blank pages in the manager. Setting compress_js=0 and compress_css=0, and then emptying the core/cache/ directory fixed it for me.

            Using MODx 2.2.4-pl (traditional).
              I LOVE MODX! | greyskymedia.com
              • 40985
              • 7 Posts
              Thanks for everybody for the nice tips. Anyway, i'm still having this issue, and i'v been spending hours and hours to get things working again.

              I'v been trying really every suggestion what i found from this thread, still no luck. Manager says "undefined" and no resource tree, nothing works... Quickest fixes, setting compress_js and compress_css to 0 and clearing cache manually had no effect. Trying also running setup again, doing fress install for modx + the packages needed and importing my data from mysql backups, no luck. Really tried every suggestion what i found, no luck...

              Using MODx 2.2.4-pl (traditional). And have a lot of packages installed, i used them on my develompent untill the manager just stopped working.

              List of installed packages:

              ./ getpage-1.2.3-pl/
              ../ getresourcefield-1.0.3-pl/
              analyticsdashboard-1.0.0-pl/
              archivist-1.2.3-pl/ getresources-1.5.0-pl/
              googlemapstv-1.0-rc3/
              articles-1.6.2-pl/ googlesitemap-1.3.1-pl/
              if-1.1-pl/
              autofiximagesize-1.0.1-pl/
              breadcrumbs-1.1.0-pl/ phpthumbof-1.4.0-pl/
              core/
              core.transport.zip
              firstchildredirect-2.3.1-pl/ quip-2.3.1-pl/
              siblingnav-1.0.0-pl/
              formit-2.1.1-pl/

              formitbuilder-1.3.2-pl/ taglister-1.1.7-pl/
              tinymce-4.3.2-pl/
              gallery-1.5.2-pl/ tinymce-4.3.3-pl/
              tinymce-4.3.3-pl.transport.zip
              getfeed-1.0.0-rc1/ wayfinder-2.3.3-pl/


              When i started this project, everything was fine about 4 weeks, and i get things developed quite fast. Now i am stucked on this, and this is really really frustrating.

              The front end website runs fine, but i cannot contine my development untill the manager is working, as obvious..

              Any ideas, please?

              Ps. I posted this also here: http://tracker.modx.com/issues/6509

              Ps Ps. This is my first Revolution project, I'v been using Evolution with no problems for years...
                • 40985
                • 7 Posts
                Some additional information from Firefox error console:

                Timestamp: 08/25/2012 10:26:57 AM
                Error: ReferenceError: _ is not defined
                Source File: http://wwwdev.XXX/manager/assets/modext/widgets/system/modx.tree.directory.js
                Line: 618

                Timestamp: 08/25/2012 10:26:58 AM
                Error: ReferenceError: _ is not defined
                Source File: http://wwwdev.XXXXX/manager/assets/modext/core/modx.localization.js
                Line: 5

                Timestamp: 08/25/2012 10:26:58 AM
                Error: TypeError: MODx.user is undefined
                Source File: http://XXXXX/manager/assets/modext/core/modx.js
                Line: 815

                Timestamp: 08/25/2012 10:26:58 AM
                Error: ReferenceError: _ is not defined
                Source File: http://wwwdev.xxxx/manager/assets/modext/widgets/security/modx.grid.user.recent.resource.js
                Line: 12
                  • 40985
                  • 7 Posts
                  http://tracker.modx.com/issues/8457

                  I opened this, because the another issued was not related to the lates stable release MODx 2.2.4-pl and was also closed.

                  Any help woud be really really appreciated!! Sorry for my long postings..
                    • 37246
                    • 128 Posts
                    Grey Sky Media Reply #69, 14 years ago
                    Do you see the expand link to open the resource tree at all? If so, open it, then refresh... just a shot in the dark, but give it a go.
                      I LOVE MODX! | greyskymedia.com
                      • 36604
                      • 268 Posts
                      I'm getting same issues all the week on a new project hosted on OVH.

                      Manager is randomly running, each 4 or 5 actions in t I get the blank screen, sometime the undefined. the only cure is a manual cache delete (ssh) but I have to play this game a dozen of time/hour.

                      the site is no more stable neither. Sometime blank page, some times partial with error on php class from basic modx files (read from cache). (An for sure some of those file were corrupted.

                      I setup a GAllery slideshow, ask to create thumbnails (the slides, with a link to popup the real large image), so phpthumb operates. I see thumbs genrated in Gallery/cahe folder but not in front or absolutly randomly (from none to all, but more often none).

                      Entering the direct link to thumb such as :
                      assets/components/gallery/connector.php?action=web/phpthumb&w=694&h=303&zc=1&far=C&q=90&src=%2Fassets%2Fgallery%2F2%2F4.jpg

                      works fine.

                      And a new issue right now: My css is not read correctly. Seams to use an old version of style I just don't know where it comes from!!