We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 27751
    • 45 Posts
    I can’t get the Wizard to work. It installed correctly on my FreeBSD VPS running:
    MODx .95
    PHP Version 5.2.1
    Apache/2.2.4 (Unix)
    MySQL 5.0.27

    I set assets/modules/wizard to 777, and since it was owned by www:www I changed to user:www figuring that might help, but still it does not recognize any modules. I am testing with the SkinGraft module included in the samples directory and this is what the Wizard reports:

    Evaluation of your resource.
    This does not appear to be a valid MODx Resource Wizard package.

    I am a beginner so I am sure there is something I am doing wrong.

    Brian
      Dedicated CENTOS 5.5 x86_64 standard WHM 11.28.64
      Apache/2.2.17 | PHP/5.2.15
      MySQL Version 5.0.91 | MODx Revolution
      • 3321
      • 4 Posts
      Quote from: Dr. at Apr 22, 2007, 08:58 PM

      sorry, I forgot to document this, but it has come up many times before in this thread. I don’t mind repeating it because it is important.

      the folder "/assets/modules/wizard" and all it’s sub directories MUST have permissions set to 0777. Setting the permissions on these folders to 0755 may work in some cases, but most folks find that 0777 works best.

      You are getting the errors above because PHP (running as "nobody" or "www") does not have permission to write or move files to those directories.

      -sD-
      Dr. Scotty Delicious, Scientist.

      Sorry, fotgot to mention that I did try 777 and 755. I was an admin at dragonflycms.org and I know all about people needing to read a thread and repeating stuff a thousand times. wink

      It never did install correctly. I had to put wizard into the correct dir. Does this module work with 0.9.6-RC?

      I’m gonna go back thru this thread and see if I missed anything...

        • 27751
        • 45 Posts
        I don’t know what all the buzz is about. The Resource Wizard doesn’t work at all. All resources end in the same message:

        "Evaluation of your resource.
        This does not appear to be a valid MODx Resource Wizard package."

        I gave it two stars because I believe it used to work, or that it does work for some people. Also the installer worked great. That is worth a half a star.

        I appreciate Sotty Delicious and I don’t mean to Dis him, but I am new and it stinks to get bogged down with stuff that just doesn’t work when I am trying to learn the ropes. Stars and comments are the evaluation I look for before installing, so I hope to save someone else the headache.

        -SmileyBri
          Dedicated CENTOS 5.5 x86_64 standard WHM 11.28.64
          Apache/2.2.17 | PHP/5.2.15
          MySQL Version 5.0.91 | MODx Revolution
          • 19638
          • 39 Posts
          When a try to install the new ressource wizard i have the following errors :

          FAILURE: Could not copy pclzip.lib.php to your server. Please make sure your web root has write permissions.

          FAILURE: Could not copy wizard.modxpkg.zip to your server. Please make sure your web root has write permissions.

          Obviously i have a write permission problem to install the Wizard but the script did not tel witch directory have permission problem ?

          So, whre are suppose to be copied pclzip.lib.php wizard.modxpkg.zip ?


          Alternaly:
          - "Delete resource wizard" only delete the mrw.php he did not chek for previous version of the Wizard
          - "Manual install" show a link to donwload , i suppose a zip package but clicink on the link only delete mrp.php
            • 27889
            • 415 Posts
            Same problem here I think the package is wrong, there is only mrw.php in the zip, nor pclzip.lib.php or wizard.modxpkg.zip file. Can we have the correct one please ?
              MODx Sites & Prestations: http://dp-site.fr [Last MODx Site]
              MODx Repository: [HOME] [MetaTagsExtra] / Current Dev: [xFDM]
              • 27751
              • 45 Posts
              Scotty Delicious has moved on to another CMS and has not been moderating the MODx forums. I hope that some other developers will update his many contributions to MODx. If not, they will likely have to be removed from the repository altogether since many do not function in the current versions of MODx.
                Dedicated CENTOS 5.5 x86_64 standard WHM 11.28.64
                Apache/2.2.17 | PHP/5.2.15
                MySQL Version 5.0.91 | MODx Revolution
                • 10313
                • 375 Posts
                Quote from: Soda at Jun 08, 2007, 08:15 AM

                Same problem here I think the package is wrong, there is only mrw.php in the zip, nor pclzip.lib.php or wizard.modxpkg.zip file. Can we have the correct one please ?

                HI. The download package is just one file mrw.php. Upload it to your main modx directory and then adress ist via www.yoursite.com/mrw.php
                This will download some files and install the Resource Wizard automatically.

                Martin
                  • 27889
                  • 415 Posts
                  Thanks, now it works fine, don’t forget to allow root write permissions. embarrassed

                  Edit: AWESOME Tools ! Bravo Scotty!

                  Somebody knows how to make a package with more than one ressource like two chunks and one snippets ? even by hands.
                    MODx Sites & Prestations: http://dp-site.fr [Last MODx Site]
                    MODx Repository: [HOME] [MetaTagsExtra] / Current Dev: [xFDM]
                    • 7995
                    • 1 Posts
                    I’m hoping someone can help me. I have MODxCMS setup on my OpenSuse 10.2 web server, running PHP 5.2.0 and MySQL 5.0.26.

                    I’m trying to install MODx Resource Wizard v2.1.0, and it fails with the following message: "FAILURE: Could not copy wizard.modxpkg.zip to your server. Please make sure your web root has write permissions." I have the latest MRW.PHP from http://piratemachine.org/downloads.html

                    I have changed permissions to the whole HTDOCS folder to 0777, including all subfolders and files. I can see the file "pclzip.lib.php" has been downloaded to the same folder as MRW.PHP which is in the root of my MODx install.

                    I’d really like to get this installed, as it looks great! Hopefully someone still monitors this thread.
                      • 6531
                      • 154 Posts
                      Not working for me: when I run mrw.php, I get:

                      Warning: main(): URL file-access is disabled in the server configuration in /home/hybridtv/public_html/v2/mrw.php on line 491

                      Warning: main(http://scottydelicious.com/MODx/mrw_version.inc): failed to open stream: no suitable wrapper could be found in /home/hybridtv/public_html/v2/mrw.php on line 491

                      Warning: main(): Failed opening ’http://scottydelicious.com/MODx/mrw_version.inc’ for inclusion (include_path=’’) in /home/hybridtv/public_html/v2/mrw.php on line 491