We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28042 ☆ A M B ☆
    • 24,524 Posts
    @Andreas: That error has nothing to do with your database; the error is returned when the .zip file isn’t getting moved from the system temp upload area to the /assets/modules/skingraft/uploads folder for unzipping and processing.
      Studying MODX in the desert - http://sottwell.com
      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
      Join the Slack Community - http://modx.org
      • 26435
      • 1,193 Posts
      Quote from: sottwell at Oct 27, 2006, 01:27 PM

      @Andreas: That error has nothing to do with your database; the error is returned when the .zip file isn’t getting moved from the system temp upload area to the /assets/modules/skingraft/uploads folder for unzipping and processing.

      I am not at home to examine my code, but There is also a very basic check in there to make sure that the file is mimetype application/zip.  If the file uploaded does not have the extension ".zip" or the browser fails to identify it as "application/zip" then the upload will also fail and the error mentioned will be returned.  This really doens’t need to be in the code as it is easy enough to fake the browser into believing anything is a zip file if you name it with .zip, plus there is  check to make sure it is a skingraft template right after this check where it looks for the "skin.php" file, so I will just get rid of the "check MimeType" code.

      Anyway, check to make sure the file you are trying to upload is a zip archive (and that it still has the extension ".zip" attached to the end) and not something else like a folder or the skin.php file. That would return the error, if the file is not a zip!

      -sD-
        Husband, Father, Brother, Son, Programmer, Atheist, Nurse, Friend, Lover, Fighter.
        All of the above... in no specific order.


        I send pointless little messages
        • 1527
        • 8 Posts

        Anyway, check to make sure the file you are trying to upload is a zip archive (and that it still has the extension ".zip" attached to the end) and not something else like a folder or the skin.php file. That would return the error, if the file is not a zip!

        -sD-

        Yep, it is a zip file. I even unziped and ziped it again - prob. No errors.
        Still can’t upload - it has to be something simple I am missing. It must have to do with modx/skingraft because I can upload zip files via the server.

        Andreas
          • 25663 MODX Staff
          • 12,272 Posts
          Can you upload files via the normal file manager?
            Ryan Thrash, MODX Co-Founder
            Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
            • 1527
            • 8 Posts
            Quote from: rthrash at Oct 27, 2006, 03:11 PM

            Can you upload files via the normal file manager?


            Yep.
            Hmm, I just tried to upload one of the template.zip files with file manager and it did not work (internal error).
            Never tried that before, all other files in modx (>250 so far) are images/.xls/.doc/.pdf - no problem at all with uploading.

            So I guess I will check my php.ini?

            Thanks, making progress now,
            Andreas
              • 26435
              • 1,193 Posts
              It would be very helpful for the development of this module if you wouln’t mind reporting back your findings. Is this on a local testing server, or a remote server? who is the web host (is remote).

              hmm I just read that you could not upload a .zip template package through the manager. Can you upload other .zip files in the manager? Most curious indeed. I think you are on the right track investigating php.ini.

              good luck, thanks for the feedback, please keep me posted.

              -sd-
              Dr. Scotty Delicious, Scientist.
                Husband, Father, Brother, Son, Programmer, Atheist, Nurse, Friend, Lover, Fighter.
                All of the above... in no specific order.


                I send pointless little messages
                • 1527
                • 8 Posts
                Ryan, Scotty, Susan,

                looks like a modxcms issue.
                I can upload zip files w/o problem to my remote OpenBSD server in cmsmadesimple. Can not upload any zip file to modxcms either with skingraft or file manager.

                Installed modxcms for testing on my kids computer (debian) at home, same problem with zip files. So it is not my server configuration.

                Running modxcms 0.95beta5, OpenBSD 4.0, php5, mysql5 remote.
                Same stuff but ubuntu 6.10 on the kids computer at home.

                Same error on both boxes, and as I said no prob uploading zip files to remote server with cmsmadesimple.

                zip is enabled as one of the uploadable file types in manager.

                Hope this is of help,
                Andreas
                  • 26435
                  • 1,193 Posts
                  Quote from: Andreas at Oct 28, 2006, 08:45 AM

                  Ryan, Scotty, Susan,

                  looks like a modxcms issue.
                  I can upload zip files w/o problem to my remote OpenBSD server in cmsmadesimple. Can not upload any zip file to modxcms either with skingraft or file manager.

                  Installed modxcms for testing on my kids computer (debian) at home, same problem with zip files. So it is not my server configuration.

                  Running modxcms 0.95beta5, OpenBSD 4.0, php5, mysql5 remote.
                  Same stuff but ubuntu 6.10 on the kids computer at home.

                  Same error on both boxes, and as I said no prob uploading zip files to remote server with cmsmadesimple.

                  zip is enabled as one of the uploadable file types in manager.

                  Hope this is of help,
                  Andreas
                  Andreas,
                  This is very confusing to me. What version of MODx are you using? I have 3 test servers running (why? becuase I am a geek! laugh ). One at home is my everyday laptop, running Mac OS X 10.4.8 and the MAMP, one is at home on my linux file server running a standard install of Kubuntu 6.10, and the third is a series of subdomains on my remote webserver hosted by site5.com. Each testing location for me has an installation of a fairly recent download from the public SVN, a default 0.9.2.1, and a default 0.9.1 (for historical purposes lol). I tried to recreate your error on all nine of these setups and was unable to get the failure that you reported. It looks like it is not a modxcms issue, but perhaps something with your download or install of our cms. I guess if it wouldn’t hurt too much data, trying to reinstall MODx may be worth a try. There is a database export in the manager if you need to back up any documents that you created.

                  -sD-
                  Dr. Scotty Delicious, Scientist.
                    Husband, Father, Brother, Son, Programmer, Atheist, Nurse, Friend, Lover, Fighter.
                    All of the above... in no specific order.


                    I send pointless little messages
                    • 1527
                    • 8 Posts
                    Scotty,
                    as mentioned in my previous post wink, I am using 0.95beta5 on ubuntu 6.10 and openbsd 4.0. Same error. May be it is that particular modxcms version. I will try 0.92 or a a more recent svn later.

                    Andreas


                    Just tried in 0.92 - same error.

                    >>>

                    SkinGraft
                    Installing selected template.

                    Warning: move_uploaded_file(/var/www/modx/assets/modules/skingraft/uploads/AutumnBounty.SkinGraft.package.zip) [function.move-uploaded-file]: failed to open stream: No such file or directory in /var/www/modx/manager/processors/execute_module.processor.php(103) : eval()’d code on line 225

                    Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move ’/tmp/phpeyQZCj’ to ’/var/www/modx/assets/modules/skingraft/uploads/AutumnBounty.SkinGraft.package.zip’ in /var/www/modx/manager/processors/execute_module.processor.php(103) : eval()’d code on line 225

                    This does not appear to be a valid SkinGraft template zip file.

                    Please go back and try a valid SkinGraft template.
                      • 30017
                      • 1 Posts
                      I seem to be having the same problem as Andreas.

                      The problem has to do with permissions.

                      I am uploading the zip files to a centos 4.4 operating system.
                      Using apache 2.0.52

                      When the file is uploaded the the /assets/modules/skingraft/uploads which has file permissions set to 777 the owner and group are apache/apache and as such the files can not be unzipped.

                      Hope this information helps.

                      Richard