Quote from: OpenGeek at Jan 30, 2011, 01:36 PM
If you lose the db connection and the the page is not yet cached, then that explains it. Not sure there is much you can do, though you might try use cache_db to reduce the strain on your not-so-reliable database.
That is, at with me, not the problem, because the startpage was cached and not edited (my customer was on vacation). It somehow just blanked.
Quote from: OpenGeek at Jan 30, 2011, 01:36 PM
Also, you really should NOT use the same Resource for error_page/unauthorized_page as you do for site_start.
OK, that’s a good point to start. Since MODX shippes with all these pages set to id=1 the user might think that this is intended and not such a bad idea at all, because you can avoid an error page and just make a fresh beginning at the startpage.
Is creating a weblink-page as an error-page OK? Would give the same result (no error page, just a fresh start) and avoid the cache problem.
Quote from: OpenGeek at Jan 30, 2011, 01:36 PM
Otherwise, nothing here convinces me this is anything but hosting issues.
Maybe, maybe not. Switching a long and good hosting relationship because of MODX makes it hard to convince people of it’s benefits. Finding the cause of the problem should either way be the most important thing. Then one can decide was is to be don to keep MODX in the play.
Quote from: OpenGeek at Jan 30, 2011, 01:36 PM
What about permissions? Is anyone using any access controls (Resource Group, Element Categories, etc.) in the web Context (or other front-end Contexts) that might be affecting how their site_start is being cached when accessed by certain users?
Simple out of the box. Admin+1 User with identical rights.
Quote from: OpenGeek at Jan 30, 2011, 01:36 PM
Any PHP (or MODX) error log trapping errors when this is occurring?
I will monitor that.
The realy funny thing is that THIS make a HUGE difference when the startpage has blanked:
A) http://www.mymodxsite.com/index.php?id=1
B) http://www.mymodxsite.com/index.php?id=1.0
Calling A just brings the blank startpage, whereas B displays the page PERFECTLY. Funny: A+B work perfect on any other id than 1, causing identical outputs with no flaws. Any idea why that may be so?
I am just setting up a test-site running on the same webpack my most affected customer is using. Just another folder. With a support-ticket I will give you full access to the manager. In the meantime I will try to fire a bunch of wgets to make a little stress on the site. Hopefully it will blank at some point. We gotta take that BUG down! ;-)
Thanks for taking care!!!
Oliver