We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 6228
    • 249 Posts
    Quote from: rthrash at Jan 31, 2011, 08:17 AM

    Quote from: mindeffects at Jan 31, 2011, 04:49 AM

    Quote from: OpenGeek at Jan 30, 2011, 01:36 PM

    Otherwise, nothing here convinces me this is anything but hosting issues.
    Maybe, maybe not. Switching a long and good hosting relationship because of MODX makes it hard to convince people of it’s benefits. Finding the cause of the problem should either way be the most important thing. Then one can decide was is to be don to keep MODX in the play.

    By the same token you might weigh the costs of a hosting partner that doesn’t have any issues vs. one that costs you hours of time and uncertainty every month because of some obscure configuration parameter. Revo taxes a lot more of PHP than most apps due to xPDO and other things it’s doing compared to may of the old procedural scripts of old that just use a small subset of the PHP API.

    But I would suspect that many users, including myself, have Revo sites that run flawlessly save for this one rare, albeit very serious issue. I think for business’ sake it would be far more prudent to tag it as an ’issue under investigation’ rather than dismiss it as a hosting problem.

    To me, at least, it sounds like a problem that might be triggered by concurrent requests, or some other timing-related issue. Because it is so rare, I don’t believe it is a MODx setting or a PHP configuration issue. If I can find the time (so busy, aargh), I will set up crons on two servers to issue concurrent requests on a test Revo site. We’ll see what happens.
      lo9on.com

      MODx Evolution/Revolution | Remote Desktop Training | Development
      • 3749
      • 24,544 Posts
      Quote from: cyclissmo at Jan 31, 2011, 11:18 AM

      To me, at least, it sounds like a problem that might be triggered by concurrent requests, or some other timing-related issue. Because it is so rare, I don’t believe it is a MODx setting or a PHP configuration issue. If I can find the time (so busy, aargh), I will set up crons on two servers to issue concurrent requests on a test Revo site. We’ll see what happens.

      That would be great.

      For problems like this, the core developers often aren’t in a position to investigate them unless the symptoms point to a particular piece of code because they can’t reproduce the problem on their platforms.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 19604 ☆ A M B ☆
        • 179 Posts
        Quote from: BobRay at Jan 31, 2011, 01:07 PM

        For problems like this, the core developers often aren’t in a position to investigate them unless the symptoms point to a particular piece of code because they can’t reproduce the problem on their platforms.

        YEEEEEEEEESSSSSSSSSSSSS!!! I have found a pattern! And: A quick work around which is SOOOOOO simple!!!

        First, let’s have a look at the webservers logfiles (I deleted some columns):
        IP		DATE / TIME		REQUEST				ERROR	SIZE	DOMAIN
        95.108.151.244	[18/Nov/2010:03:53:14	GET /robots.txt HTTP/1.1	404	5700	my-modx-domain.de
        95.108.151.244	[18/Nov/2010:03:53:14	GET /robots.txt HTTP/1.1	404	5704	www.my-modx-domain.de
        95.108.151.244	[18/Nov/2010:03:53:16	GET / HTTP/1.1			200	435	my-modx-domain.de
        95.108.151.244	[18/Nov/2010:03:53:16	GET / HTTP/1.1			200	435	www.my-modx-domain.de
        

        or here
        IP		DATE / TIME		REQUEST				ERROR	SIZE	DOMAIN
        95.108.150.235	[08/Dec/2010:06:42:15	GET /robots.txt HTTP/1.1	404	5703	www.my-modx-domain.de
        95.108.150.235	[08/Dec/2010:06:42:15	GET /robots.txt HTTP/1.1	404	5699	my-modx-domain.de
        95.108.150.235	[08/Dec/2010:06:42:19	GET / HTTP/1.1			200	435	my-modx-domain.de
        95.108.150.235	[08/Dec/2010:06:42:20	GET / HTTP/1.1			200	435	www.my-modx-domain.de
        

        or here
        IP		DATE / TIME		REQUEST				ERROR	SIZE	DOMAIN
        208.115.111.250	[29/Jan/2011:19:11:31	GET /robots.txt HTTP/1.1	404	9782	my-modx-domain2.com
        208.115.111.250	[29/Jan/2011:19:11:31	GET /robots.txt HTTP/1.1	404	9786	www.my-modx-domain2.com
        64.34.218.178	[29/Jan/2011:19:21:04	GET / HTTP/1.1			200	399	my-modx-domain2.com
        64.34.218.178	[29/Jan/2011:19:21:05	GET / HTTP/1.1			200	399	www.my-modx-domain2.com
        

        any many more times. Allways with the same pattern:
        An external website (a crawler) tries to get the "/robots.txt" which is not part of the standard MODx installation and gets an error 404. This happens at the SAME TIME for the domain WITH and WITHOUT the WWW. Since the error page is by default the id 1 the crawler is redirected to the start page where something in the cache goes wrong. The size of the resulting data drops from about 5600 bytes (or about 9700) to about 400 bytes: The request delivers only the header without any data. From now on every visitor of the startpage gets the "blank white screen of death".

        A first step to avoid that problem would be the creation of the "/robots.txt". Crawler finds file, crawler is happy, everybody is happy! (Perhaps "/robots.txt" could be included in the future MODx releases?!)

        Second, using a different error page than the start page should also work but I dont know if then the error page gets blanked if the "/robots.txt" is requested at the same time at two places (with and without the "www"). Still the default id 1 for all those "special" pages can cause trouble in some cases (as seen above).

        Finaly: Perhaps the MODx caching algorithm can be modified to be prepared for these rare (crawler) situations. That would make MODx even more robust and the user can decide if he wants an "/robots.txt" or if his error page is identical with the start page (Which many customers like A LOT since "they make error free products and there are no erros on their website". I asked and they told me.).

        Hope this helps
        Oliver
          MINDEFFECTS – DESIGN for PRINT, WEB and MEDIA
          http://twitter.com/mindeffects · http://www.facebook.com/mindeffects · http://www.youtube.com/mindeffects/ · skype://mindeffects_oliver
          • 6228
          • 249 Posts
          Great job, Oliver. Your research helped me isolate the point of failure in my site:

          [18/Jan/2011:16:14:12 +0000] "GET /robots.txt HTTP/1.1" 500 5 "-" "Mozilla/5.0 (compatible; YandexBot/3.0; MirrorDetector; +http://yandex.com/bots)"
          [18/Jan/2011:16:14:12 +0000] "GET /robots.txt HTTP/1.1" 500 5 "-" "Mozilla/5.0 (compatible; YandexBot/3.0; MirrorDetector; +http://yandex.com/bots)"
          [18/Jan/2011:16:14:13 +0000] "GET / HTTP/1.1" 200 11685 "-" "Mozilla/5.0 (compatible; YandexBot/3.0; MirrorDetector; +http://yandex.com/bots)"
          [18/Jan/2011:16:14:13 +0000] "GET / HTTP/1.1" 200 11681 "-" "Mozilla/5.0 (compatible; YandexBot/3.0; MirrorDetector; +http://yandex.com/bots)"
          [18/Jan/2011:16:14:14 +0000] "GET / HTTP/1.1" 500 5 "-" "Mozilla/5.0 (compatible; YandexBot/3.0; MirrorDetector; +http://yandex.com/bots)"
          [18/Jan/2011:16:14:15 +0000] "GET / HTTP/1.1" 500 5 "-" "Mozilla/5.0 (compatible; YandexBot/3.0; MirrorDetector; +http://yandex.com/bots)"


          It looks like you nailed it. I will apply your ridiculously complex solution to my sites until a permanent fix becomes available. wink cool
            lo9on.com

            MODx Evolution/Revolution | Remote Desktop Training | Development
            • 3749
            • 24,544 Posts
            @mindeffects: Great work. cool

            Could you report all that at http://bugs.modxcme.com so it won’t fall through the cracks?

            It looks like the home page in the cache is corrupted somehow (though I don’t see exactly how). Since it is both the home page and the error page (a bad practice, BTW, for this very reason) it keeps redirecting to itself over and over. If a client wants a redirect to the home page on "page not found," one solution is to duplicate the home page and make the duplicate the error page.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 19604 ☆ A M B ☆
              • 179 Posts
              Quote from: BobRay at Feb 01, 2011, 04:53 PM

              @mindeffects: Great work. cool
              THANKS!!! I AM SOOOO HAPPY TO HAVE FOUND A SOLUTION!!! NO MORE ANGRY CALLS!!!

              Quote from: BobRay at Feb 01, 2011, 04:53 PM

              Could you report all that at http://bugs.modxcme.com so it won’t fall through the cracks?
              There already is a bug report for that topic: #3111. I just added the above to it.

              Quote from: BobRay at Feb 01, 2011, 04:53 PM

              It looks like the home page in the cache is corrupted somehow (though I don’t see exactly how). Since it is both the home page and the error page (a bad practice, BTW, for this very reason) it keeps redirecting to itself over and over. If a client wants a redirect to the home page on "page not found," one solution is to duplicate the home page and make the duplicate the error page.
              Why is it redirecting to itself? What errors are there that lead to the error page? Isn’t the start page to only save thing of the website, found at the root of the domain? Maybe I am not getting the whole picture.
                MINDEFFECTS – DESIGN for PRINT, WEB and MEDIA
                http://twitter.com/mindeffects · http://www.facebook.com/mindeffects · http://www.youtube.com/mindeffects/ · skype://mindeffects_oliver
                • 3749
                • 24,544 Posts
                The "error page" is the "page not found" page. Say it’s your home page and you accidentally protect it with an ACL entry while messing with permissions. In Revolution, pages you’re not authorized to see disappear and result in a "page not found" error. On a request for that page, MODx redirects the user to your "error page," which is not found, so it redirects to your error page, which is not found, and so on, round and round.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 19604 ☆ A M B ☆
                  • 179 Posts
                  Quote from: BobRay at Feb 02, 2011, 10:15 AM

                  The "error page" is the "page not found" page. Say it’s your home page and you accidentally protect it with an ACL entry while messing with permissions. In Revolution, pages you’re not authorized to see disappear and result in a "page not found" error. On a request for that page, MODx redirects the user to your "error page," which is not found, so it redirects to your error page, which is not found, and so on, round and round.
                  OK, thanks for bringing me up to speed. So, until I don’t play around with ACLs (which I do not do too often), authorization or unpublish the start page, maybe I "could in these rare cases" use a weblink to bring my visitors back to a well defined point: the start page. In all other cases I will keep in mind, that I don’t create infinity loops by any reason.
                  I used my "strange-error-handling-thing" on this website http://the-tree.pandorafilm.de/, just presenting some pages. Would I get your OK for that?
                    MINDEFFECTS – DESIGN for PRINT, WEB and MEDIA
                    http://twitter.com/mindeffects · http://www.facebook.com/mindeffects · http://www.youtube.com/mindeffects/ · skype://mindeffects_oliver
                    • 3749
                    • 24,544 Posts
                    You don’t need my OK for anything. wink

                    Now that you understand what the potential risks are, you can make your own decision. smiley
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                      • 19604 ☆ A M B ☆
                      • 179 Posts
                      Another blank screen. Damn. My idea: "domain.com" and "www.domain.com" should not lead to the same page. The cahche dislikes that. I changed my ".htacces" to redirect (301) all "http://domain.com" to "http://www.domain.com". Hopefuly that helps. My head is close to being chopped off...
                        MINDEFFECTS – DESIGN for PRINT, WEB and MEDIA
                        http://twitter.com/mindeffects · http://www.facebook.com/mindeffects · http://www.youtube.com/mindeffects/ · skype://mindeffects_oliver