We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28000 ☆ A M B ☆
    • 397 Posts
    Until now, the only response has been to rollback to version 2.0.3. I will try this, but cannot believe that other people are not having the same problem...Maybe someone else can post here if they are having this same issue.
      Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
      • 3749
      • 24,544 Posts
      Try editing the filemanager_path System Setting and leaving it completely empty. I had a similar problem and it turned out that MODx was prepending the base_url to whatever I put in filemanager_path, which usually led to an invalid path.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 28000 ☆ A M B ☆
        • 397 Posts
        I did try that, thanks. Unfortunately, the problem only occurs after I install the Gallery Tool for Revo and seems to not be affected by that setting. Therefore, I believe it is a Gallery bug. I have tried it on 3 different servers (fresh intall / Gallery Tool install) and the error occurs on all three servers.
          Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
          • 28000 ☆ A M B ☆
          • 397 Posts
          UPDATE.

          So, I now installed a clean install of 2.0.3, and then just to test (without installing the gallery tool), I uploaded the image folder that is giving me the problem to the assets folder via Dreamweaver FTP. I then went to the folder in the file manager, clicked in a subfolder inside of this image folder, and I got the same error "Please specify a valid directory." I apologize if I misled you all by saying that the Gallery Tool was the problem. Could there be a strange permissions problem going on with the folder? So now I have a case whereby the gallery tool is not installed and the error occurs. Now I think it is either a server configuration or MODx Bug. Can anyone help me here?
            Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
            • 28000 ☆ A M B ☆
            • 397 Posts
            I looked in the error log and found this:

            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not copy /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/modContext/fca1736af87ce8276aa6a5682926b7a4/0/ to index.php
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not copy /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/modContext/fca1736af87ce8276aa6a5682926b7a4/1/ to ht.access
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not copy /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/modContext/f1af6d537dc2de2edd14ccf325264e21/0/ to assets
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not copy /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/modContext/f1af6d537dc2de2edd14ccf325264e21/1/ to controllers
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not copy /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/modContext/f1af6d537dc2de2edd14ccf325264e21/2/ to templates
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not copy /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/modContext/f1af6d537dc2de2edd14ccf325264e21/3/ to ht.access
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not copy /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/modContext/f1af6d537dc2de2edd14ccf325264e21/4/ to index.php
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not install files from /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/xPDOFileVehicle/e80c871cf42f7f2c609f704a19951c80/ to
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not install files from /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/xPDOFileVehicle/4b1440d72170e80bfb165537f532d83f/ to
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not install files from /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/xPDOFileVehicle/917c6155d8ab1cf2a57bdd85df99609d/ to
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not install files from /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/xPDOFileVehicle/4f5312fbbcf7e66ddf1601f8519af219/ to
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not install files from /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/xPDOFileVehicle/5b3ee0bd88f4aa3f53adf866b7f9da74/ to
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not install files from /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/xPDOFileVehicle/cf279eb7d339271de543f5c4d18ba9c6/ to
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not install files from /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/xPDOFileVehicle/32bb2779fc23179a257d4480fb2b9aab/ to
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not install files from /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/xPDOFileVehicle/06b874e121ec2aaff0a96a594525211c/ to
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not install files from /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/xPDOFileVehicle/e5790183b5a6563244d7fb5b866e9e1a/ to
            [2010-11-08 10:10:41] (ERROR @ /modx2.0.3/setup/index.php) Could not install files from /homepages/24/d13413542/htdocs/new_web/modx2.0.0/modx2.0.3/core/packages/core/xPDOFileVehicle/387d108a8dfd4445edefcb7eaf3b1957/ to
              Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
              • 28000 ☆ A M B ☆
              • 397 Posts
              I deleted the image folder in question, and started to create it again this time using the file manager. I created under assets, the folder "objektbilder". Then inside of this folder, I created the subfolder "Haimhausen_Hauptstr46". After I did this and tried to access the new subfolder, it gave me again the same error - even though I created the folder using the file manager and not with Dreamweaver.
              Again, Gallery is not yet installed.
                Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
                • 28000 ☆ A M B ☆
                • 397 Posts
                Just did again another install of modx 2.0.4pl2 on another webhost - Hosteurope. Again, fresh install, installation went fine. Went to file manager, created the subfolder "objektbilder", then created a subfolder under "objektbilder" called "test" and that worked fine, but then created a real folder that I need called "Haimhausen_Hauptstr46" in the folder "objektbilder", and again the same error is shown. Now, I have reported this Bug, but is there no one else that could do this simple test and tell me if it works for them? I am losing it.

                So the folder structure is assets->objektbilder->Haimhausen_Hauptstr46
                  Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
                  • 22303 MODX Staff
                  • 10,725 Posts
                  Your problem is trying to manage files with two different user accounts on your server. You need to either manage the files and folders with the file manager (where the PHP process will own the directories/files) OR manage them with your FTP user account. Once you create them using one approach, you will not have permission to manage them from the other without manipulating user/group ownership and setting appropriate write permissions.
                    • 28000 ☆ A M B ☆
                    • 397 Posts
                    In IE8, it lists a javascript error:


                    Details zum Fehler auf der Webseite

                    Benutzer-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; FunWebProducts; GTB6.5; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C)
                    Zeitstempel: Mon, 8 Nov 2010 14:53:06 UTC


                    Meldung: Unbekannter Fehler.
                    Zeile: 7
                    Zeichen: 8675
                    Code: 0
                    URI: http://kreativnetz-beta.com/modx/manager/assets/ext3/adapter/ext/ext-base.js

                    and I am posting a screenshot of Firebug told me in FF. Maybe this will help someone. Seems to be an error originating in the ext-base.js, Line 7
                      Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
                      • 22303 MODX Staff
                      • 10,725 Posts
                      The folder in question appears to be named with a - vs. an _, but it seems to want to change it to an _ ??