-
☆ A M B ☆
- 397 Posts
I have upgraded two installs now to MODx 2.04 and since then I get the following error "Please specify a valid directory" when I try to use the navigation tree. The problem seems to come and go. Sometimes after deleted cache and restarting Firefox, it will work and I will be able to creat a folder and upload an image, but then suddenly it disappears again and I get the error. Because it is happening to two separate installations, I figure that it must be a bug.
Both Sites are running with the following server specs:
mysql 5.0.91-log
php 5.2.14
I have some angry clients because they can no longer update their files on the server. I would appreciate some assistance.
Thanks
Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
Did you set filemanager_path or filemanager_url (or rb_base_dir/rb_base_url) to anything?
Do you have any custom access policies?
Any errors in core/cache/logs/error.log?
shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect |
github |
splittingred.com
-
☆ A M B ☆
- 397 Posts
Hey, I am so glad you responded so fast...
NO, both sites have default installations. I did not manually adjust the paths. And there are no errors in the log...I wish I could help you more. Thought maybe it would be some sort of permissions problem. With an ftp client, I can see the files, but MODx intermittently can see the folders...
Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
-
☆ A M B ☆
- 397 Posts
It only happens to a certain folder under the assets folder that was created with modx. I attempted to delete the folder with fireFTP and it could see the folder, but said it did not exist, so I couldn’t delete it. Then I finally used Dreamweaver to remotely delete it. For some reason Dreamweaver could successfully delete it. So I thought it may be some weird permissions problem. So I again created the same folder structure under assets/ and thought all was well. From two separate admin accounts I played with the folders and uploaded images and I thought I had fixed it. But then all of sudden I got the same error again. Now it consistently gives me the error...also when accessing from different computers on different networks.
???
Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
-
☆ A M B ☆
- 397 Posts
So, now I attempted the same trial and error attempts of making folders and seeing if the error occurs on a website I have on a different server and I can’t seem to get the error...at least not yet. So maybe there is some incompatibility with the server that is running the two sites in question?
Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
Was there anything unusual about the names of the problem folders?
How were they created?
-
☆ A M B ☆
- 397 Posts
The folder name is "objektbilder" and inside of this folder were names of real estates. some of them had Umlauts which could have caused some sort of issue. But after I deleted all the folders with dreamweaver, I recreated the folders without umlauts and the problem persisted. Also on the second website, I just used folder names like "test", "test1", "test2" and the problem happened.
One commonality is that both websites are on the same server setup. It is a large German hosting provider called 1&1. The other commonality, is that after the initial installation and development, we repointed the domains to the dev folder, so that it does not show up in the URL. I changed the config file like this:
Originally the domain was pointed to the folder new_web on the server
$modx_connectors_path= ’/homepages/24/d13413542/htdocs/new_web/modx2.0.0/connectors/’;
$modx_connectors_url= ’/modx2.0.0/connectors/’;
Then I changed all url paths like this:
$modx_connectors_path= ’/homepages/24/d13413542/htdocs/new_web/modx2.0.0/connectors/’;
$modx_connectors_url= ’/connectors/’;
Since we did not really change the path, I did not change the work space path in the database.
Maybe this helps?
Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
-
☆ A M B ☆
- 397 Posts
Is there a way to increase the log level / set debugging??
Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
-
☆ A M B ☆
- 397 Posts
Here is a screenshot of the file manager and an instance where it sees images, but does not really registers them??? with fireFTP there were accessible.
Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
I had a similar issue and had to set a filemanager_path and filemanager_url in system settings... my case the path with yourrootfolder/assets/ and url was assets/ then refreshed the page this seems to work.
But I have lost package management