We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28042 ☆ A M B ☆
    • 24,524 Posts
    Have you tried going into the database in the system_settings table and changing the compress_js and compress_css to 0?
      Studying MODX in the desert - http://sottwell.com
      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
      Join the Slack Community - http://modx.org
      • 45915
      • 8 Posts
      Did you find a solution???
      I'm dying to find a solution for this problem.
      Looks like Modx.user is undefined in fact, despite I logged in.

      Revo 2.2.10 standard on php 5.3.27 - Host OVH linux shared hosting - Mysql 5.1.61

      Quote from: zurie at Aug 17, 2010, 02:21 AM
      Ok, I started my own thread because I am experiencing a blank manager but its different in some ways and hopefully with enough info I provide we can find a solution.

      To start. the installer checks out OK. I have 64MB of ram allocated to PHP on my server, PHP 5.x etc etc... all my directories are writable, I have tried both 0777/0666 and 0755/0644 with the same results...

      So i finish installing and I go directly to manager's login.

      in firefox I get these 2 errors immediately after logging in:

       
      MODx.perm is undefined
      [Break on this error] Ext.apply(Ext,{isFirebug:(window.conso....changeMenu=MODx.LayoutMgr.changeMenu;
      modx.l...-min.js (line 1)
      
      MODx.user is undefined
      [Break on this error] MODx.page.Welcome=function(A){A=A||{};...MODx.helpWindow.show(Ext.getBody());};
      welcome-min.js (line 1)
      


      needless to say, I am still logged in at this point. So I see the main menu and all the items.

      now, if i click a menu item, I get this...

      http://www.mydomain.com/manager/?a=70
      


      where it takes my domain and adds a ?a= whatever URL i click... inside that page I see absolutely nothing...

      if i go back to the manager and try and logout, I get a popup window and it says "Do you wish to logout?"

      I click OK and firebug reports:

      POST http://www.mydomain.com/manager/undefinedsecurity/logout.php
      POST http://www.mydomain.com/manager/undefinedsecurity/logout.php
      	
      404 Not Found
      		95ms	
      ext-base.js (line 7)
      syntax error



      I check SFTP and I don't have any folder named "undefinedsecurity"

      also my .htaccess is off at the moment (ht.access) until I can get the manager and pages to work.


      if i go in and change my /core/config.inc.php from writable to read only, after I am already inside the Manager window, and hit refresh.. BOOM! completely white window... yet the strange thing is I can see ALL of the source code when I view the blank window's source!

      obviously, from the logout not working, the pages not navigating, the 2 errors, the missing logout page, and etc there is something terribly wrong with how my files are installing? I own the server so I can go into WHM and change things as needed or get back to you with versions, or config settings, or whatever you need me to do to help solve this one...

      Thanks!
        • 36649
        • 77 Posts
        Hello,

        I had the same problem - logging in MODX manager with the main admin user just returned "Undefined" below the navigation bar and no navigational actions or clicks were working. It's with modx revo 2.2.10-pl. In Firebug I got JS error "MODx.user is undefined".

        Clearing cache of browser and deleting files in core/cache didn't help. The problem first occured some days before to another user logging in from elsewhere (also admin, but no main) - and I couldn't believe or help, as at that moment I couldn't replicate the error on my machine. Thought it's a browser issue.

        But then today, after changing or editing _nothing_, I got this with my main user on my own machine.

        Fortunately I could login with the other admin account (which wasn't working from elsewhere some days before). Then from within manager I did Site -> clear MODX cache, Security -> flush sessions and reload user rights. After that the main admin also worked again.

        Maybe this helps somebody, though I didn't find the reason for this behaviour. Seems MODX has a life of its own.
          • 45915
          • 8 Posts
          I've fixed issue I had on this post: https://forums.modx.com/thread/87724/probl-me-connexion-manager . It was hosting provider specific server issue that was solved by changing DNS. Server hosting was providing CDN services not compatible with MODx manager. Post is in french.
            • 36649
            • 77 Posts
            Quote from: myangga at Jan 22, 2014, 02:10 PM
            I've fixed issue I had on this post: https://forums.modx.com/thread/87724/probl-me-connexion-manager . It was hosting provider specific server issue that was solved by changing DNS. Server hosting was providing CDN services not compatible with MODx manager. Post is in french.

            Très interessant, merci beaucoup!
              • 47678
              • 1 Posts
              When I type in www.mydomain/manager/ the screen is also blank. I haven't installed anything here (to my knowledge), a webdesigner did all the work. The "manager" section used to be accessible, although since then I have reformatted the computer and shifted some files to google cloud, but the webdesigner never did anything on the computer at our end.

              Thanks for any help!

              Henry
                • 28042 ☆ A M B ☆
                • 24,524 Posts
                What version of MODX? Where is the site hosted?
                  Studying MODX in the desert - http://sottwell.com
                  Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                  Join the Slack Community - http://modx.org
                  • 47630
                  • 56 Posts
                  Quote from: ztztss at Aug 24, 2012, 06:47 PM
                  I've found a workaround. It's entering admin area only through WWW.site.com/manager
                  Always with WWW. if I enter without www. I have problems with 401 error on accessiing lang.js.php and everything else described here.
                  It must be due to extense tweaking of mgr context and access permissions which where done by my programmer.

                  After implementing friendly urls I had this issue whereby I starting getting a blank manager page.

                  I try the above solution & it solved the issue.

                  I just added www. in front of the manager url & the manager started functioning again.
                    • 29201
                    • 239 Posts
                    I'm running into the same issue.

                    I'm running HTTPS on a Bluehost shared server. The manager was fully functional several months ago.

                    I'm running 2.2.10-pl and I've cleared the core cache and ensured that the web host has not changed the path on the server. I've also cleared browser cache and tried changing the database values for compress_css and compress_js.

                    I can't flush permissions or perform any action from the MODx manager as the menu is disabled.

                    Here is a screenshot: http://grab.by/DKEe



                    [ed. note: taiyo1578 last edited this post 11 years, 8 months ago.]
                      • 29201
                      • 239 Posts
                      I was able to get this fixed up by upgrading to 2.3.2 via Bobby Ray's quick guide here: http://bobsguides.com/modx-upgrade-faq.html.