We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 33657
    • 128 Posts
    Ok, I started my own thread because I am experiencing a blank manager but its different in some ways and hopefully with enough info I provide we can find a solution.

    To start. the installer checks out OK. I have 64MB of ram allocated to PHP on my server, PHP 5.x etc etc... all my directories are writable, I have tried both 0777/0666 and 0755/0644 with the same results...

    So i finish installing and I go directly to manager’s login.

    in firefox I get these 2 errors immediately after logging in:

     
    MODx.perm is undefined
    [Break on this error] Ext.apply(Ext,{isFirebug:(window.conso....changeMenu=MODx.LayoutMgr.changeMenu;
    modx.l...-min.js (line 1)
    
    MODx.user is undefined
    [Break on this error] MODx.page.Welcome=function(A){A=A||{};...MODx.helpWindow.show(Ext.getBody());};
    welcome-min.js (line 1)
    


    needless to say, I am still logged in at this point. So I see the main menu and all the items.

    now, if i click a menu item, I get this...

    http://www.mydomain.com/manager/?a=70
    


    where it takes my domain and adds a ?a= whatever URL i click... inside that page I see absolutely nothing...

    if i go back to the manager and try and logout, I get a popup window and it says "Do you wish to logout?"

    I click OK and firebug reports:

    POST http://www.mydomain.com/manager/undefinedsecurity/logout.php
    POST http://www.mydomain.com/manager/undefinedsecurity/logout.php
    	
    404 Not Found
    		95ms	
    ext-base.js (line 7)
    syntax error



    I check SFTP and I don’t have any folder named "undefinedsecurity"

    also my .htaccess is off at the moment (ht.access) until I can get the manager and pages to work.


    if i go in and change my /core/config.inc.php from writable to read only, after I am already inside the Manager window, and hit refresh.. BOOM! completely white window... yet the strange thing is I can see ALL of the source code when I view the blank window’s source!

    obviously, from the logout not working, the pages not navigating, the 2 errors, the missing logout page, and etc there is something terribly wrong with how my files are installing? I own the server so I can go into WHM and change things as needed or get back to you with versions, or config settings, or whatever you need me to do to help solve this one...

    Thanks!
      • 27708 MODX Staff
      • 2,502 Posts
      These are total guesses but I’d think of a couple things. mod_security may be installed on your server or you are missing or have corrupted files.

      Make sure you also let us know the following from the new post screen:

      If you’re posting about a bug, please state all of your Environment information in your post: Version of MODx, Traditional or Advanced distribution (for Revo), Server OS, Server Version, PHP Version, MySQL Version (client and server), is pdo_mysql installed, your Browser type and version, if you are using any opcode caching such as eAccelerator, APC, winCache, xCache, etc; any relevant errors in core/cache/logs/error.log, and any other environment data we should know.
        Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. Blog ✦ Twitter ✦ LinkedIn ✦ GitHub
        • 33657
        • 128 Posts
        ok #1

        mod_security is installed on my server. Should I open a .htaccess file and put in

        SecFilterEngine Off


        #2 I am running:

        MySQL version 5.1.48
        PDO_mySQL is installed
        Apache version 2.2.14
        PHP version 5.2.12
        I have 64MB ram allocated to PHP
        ModX Revolution 2.0.0-pl



        • Checking PHP for zlib dependency: OK!
        • Checking for SimpleXML: OK!
        • Checking PHP version: OK! Running: 5.2.12
        • Checking MySQL server version: OK! Running: 5.1.48
        • Checking MySQL client version: OK! Running: 5.1.48
        • Checking if memory limit is set to at least 24M: OK! Set to 64M
        • Checking if sessions are properly configured: OK!
        • Checking if core/cache directory exists: OK!
        • Checking if core/cache directory is writable: OK!
        • Checking if core/export directory exists: OK!
        • Checking if core/export directory is writable: OK!
        • Checking if core/packages directory exists: OK!
        • Checking if core/packages directory is writable: OK!
        • Checking if core/config/config.inc.php exists and is writable: OK!
        • Creating connection to the database: OK!



        adding either

        SecFilterEngine Off

        or
        SecFilterScanPOST Off


        throws a error 500 on my server...

          • 33657
          • 128 Posts
          I try the latest build on SVN and I get

          Checking if /home/cortez/public_html/ directory is writable: Failed!

          its impossible to make it any more writable than 0777

          how can i bypass this besides just running the non advanced version? i wanted to try the latest SVN build to see if that fixes anything I am having issues with
            • 28215
            • 4,149 Posts
            MODx doesn’t use SVN for development anymore; we use Git. Please see:

            http://rtfm.modx.com/display/revolution20/Git+Installation
              shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
              • 33657
              • 128 Posts
              installed the LATEST git build... built it, the works... same exact problems...

              I can login one time. NO menus can be navigated.. I just get blank pages for any future page I try and naviagate too.. I get a few javascript errors that just don’t seem right...

              eventually if i close the browser and reopen it, i get a totally blank page.


              how can I check the other pre-requisites, the cache, and other features that need to be installed on my server...


              should i even be using Revolution??? i had modx Evolution installed and it works fine... why does revolution have issues when evo was golden? wink
                • 28215
                • 4,149 Posts
                Revolution works fine on properly configured servers.

                - Have you fully read Troubleshooting Installation, including trying the PDO test script there?
                - Are you using any opcode caching, such as eAccelerator, xCache, APC, etc?
                - Are you running safe_mode?
                - Any errors in core/cache/logs/error.log?
                - Anything else relevant we should know?
                  shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
                  • 33657
                  • 128 Posts
                  as far as i know, everything checks out.

                  I can successfully login one time. any time I goto a menu item like "System Settings" in Modx Manager, I am presented with a white page with a link that goes to www.mydomain.com/manager/?a=70

                  I also have 3 javascript errors that seem like they are breaking my site... I think the javascript errors are the issue... you can’t have a working site with these errors...

                  MODx.perm is undefined
                  [Break on this error] Ext.apply(Ext,{isFirebug:(window.conso....changeMenu=MODx.LayoutMgr.changeMenu;
                  
                  



                  MODx.user is undefined
                  [Break on this error] MODx.page.Welcome=function(A){A=A||{};...MODx.helpWindow.show(Ext.getBody());};



                  and when i try and log out...

                  syntax error
                  [Break on this error] (<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">\n
                  ext-all.js (line 7)


                  the last error is breaking on the "!" in (<!DOCTYPE



                  also!!!! Is there a LeftBar???? in Manager.. because I don’t see any leftbar.. I see Modx Revolution bar on the top with home / site / security / etc...

                  Logout on the far right side.. and content below.. but absolutely no left bar... just wondering if maybe thats suppose to be there too?

                    • 33657
                    • 128 Posts
                    so its confirmed my manager does NOT have the left bar... can’t logout... can’t do anything...

                    so I know I have mod_security... am I basically not able to run Revo 2.0?

                    This is a shared server with hundreds of sites on it, I can’t compromise security for others just to make one site happy...

                    everytime I go into my .htaccess and turn mod security off for my modx 2.0 revo site I get error 500 on the whole domain running it... only when its off does it load up but its severely broken...

                    this site has a demo on it and it works perfectly... nothing like mine..
                    http://revolution-2.trymodx.com/manager/

                    i wish I could get this working sad really wanted to start using revo 2.0 on all future sites


                    I created a custom account for one of the devs but he never logged in or did anything to try it out so i removed it.. if anyone with alot of modx experience wants to have a cpanel account with a fake domain so they can attempt to install I would be happy to let em try, but I think its more of a server setting than being able to extract, chmod and install files....
                      • 33644
                      • 14 Posts
                      Same Error the very same symptoms. Modx revo 2.2.0 on Hostgator.
                      Errors are random, but seem to be dependant on the browser and the exact manager login being used [ed. note: ztztss last edited this post 14 years, 1 month ago.]