On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I use code for full toolbar configuration from here (define it in modx revo backend settings):
    [
    	{ "name": "document", groups: [ "mode", "document", "doctools" ], items: [ "Source" ] },
    	{ "name": "clipboard", groups: [ "clipboard", "undo" ], items: [ "Cut", "Copy", "Paste", "PasteText", "PasteFromWord", "-", "Undo", "Redo" ] },
    	"/",
    	{ "name": "basicstyles", groups: [ "basicstyles", "cleanup" ], items: [ "Bold", "Italic", "Underline", "Strike", "Subscript", "Superscript", "-", "RemoveFormat" ] },
    	{ "name": "paragraph", groups: [ "list", "indent", "blocks", "align" ], items: [ "NumberedList", "BulletedList", "-", "Outdent", "Indent", "-", "Blockquote" ] },
    	{ "name": "links", items: [ "Link", "Unlink", "Anchor" ] },
    	{ "name": "insert", items: [ "Image", "Table", "HorizontalRule", "SpecialChar" ] },
    	"/",
    	{ "name": "styles", items: [ "Styles", "Format" ] },
    	{ "name": "tools", items: [ "Maximize" ] },
    	{ "name": "others", items: [ "-" ] },
    	{ "name": "about", items: [ "About" ] }
    ]
    


    After this is done toolbar stays in the same standard config and after page refresh my backend is broken - nothing is shown in the right pane.

    I have revo 2.2.6 and ckeditor, and ajaxmanager plugins installed.
    • You have to double-quote your keys:
      [
          { "name": "document", "groups": [ "mode", "document", "doctools" ], "items": [ "Source" ] },
      	{ "name": "clipboard", "groups": [ "clipboard", "undo" ], "items": [ "Cut", "Copy", "Paste", "PasteText", "PasteFromWord", "-", "Undo", "Redo" ] },
      	"/",
      	{ "name": "basicstyles", "groups": [ "basicstyles", "cleanup" ], "items": [ "Bold", "Italic", "Underline", "Strike", "Subscript", "Superscript", "-", "RemoveFormat" ] },
      	{ "name": "paragraph", "groups": [ "list", "indent", "blocks", "align" ], "items": [ "NumberedList", "BulletedList", "-", "Outdent", "Indent", "-", "Blockquote" ] },
      	{ "name": "links", "items": [ "Link", "Unlink", "Anchor" ] },
      	{ "name": "insert", "items": [ "Image", "Table", "HorizontalRule", "SpecialChar" ] },
      	"/",
      	{ "name": "styles", "items": [ "Styles", "Format" ] },
      	{ "name": "tools", "items": [ "Maximize" ] },
      	{ "name": "others", "items": [ "-" ] },
      	{ "name": "about", "items": [ "About" ] }
      ]

      This is required by JSON specification.
      • danya_postfactum,

        Thanks, and do you know how i can recover my broken backend? I suspect your AjaxManager, because i had issues with it in the past, though i was uninstalling it properly before deleting.

        In those cases i reuploaded Modx package replacing all files except config files, then i ran setup/ and ran "upgrade". After this backend was fixed.
        But now these same steps do not fix backend. [ed. note: ultraviolet last edited this post 6 years, 5 months ago.]
        • If you have Element Tree working, try to disable CKEditor and clear MODx Cache. Otherwise, you have to manually edit \core\cache\system_settings\config.cache.php and fix or clear broken ckeditor.toolbar setting.
          • Quote from: danya_postfactum at Feb 14, 2013, 10:10 AM
            If you have Element Tree working, try to disable CKEditor and clear MODx Cache. Otherwise, you have to manually edit \core\cache\system_settings\config.cache.php and fix or clear broken ckeditor.toolbar setting.
            Thanks! Disabling CKEditor worked! I then unistalled it, reinstalled AjaxManager, then installed CKEditor again.
            • What should i define in backend settings of Modx in order to have full toolbar?

              Can't find relevant info on ckeditor.com . I found only this - but it is not full toolbar configuration there.

              Strange enough, sometimes CKEditor installs with full toolbar config, same as in this example.
              But after some time it switches to standard toolbar configuration somewhy.
              Other times i tried to install Ckeditor goes with standard toolbar config by default.
              • Quote from: ultraviolet at Feb 15, 2013, 01:12 PM
                What should i define in backend settings of Modx in order to have full toolbar?
                I found that clearing completely "ckeditor.toolbar" textfield in Ckeditor settings of Modx backend will render full toolbar.
                • Critical Bug in Extension: CKEditor

                  When you install CKEditor when you already have TinyMCE installed.. and after that Uninstall CKEDITOR..
                  Both editors won't work anymore
                  • Critical Bug in Extension: CKEditor

                    When you install CKEditor when you already have TinyMCE installed.. and after that Uninstall CKEDITOR..
                    Both editors won't work anymore
                    • After installing CKEditor 1.1.0 on MODx Revo 2.2.6pl, I can insert a table, and I can edit the full table properties, but the contextual menu items for editing Row, Column or Cell are missing.

                      Any ideas?