We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 27942
    • 14 Posts
    Hi thanks for your hint. Tried to check system-settings via admin-toolbar -> again CODE 200 OK! Whatever i try to do!
    With phpMyAdmin can't find any DB entries like "compress_css" and "compress_js". No chance to do anything. However the Website is still running. Found several posts with the same issue. One mentioned a fix: ""Fix checking if connectors are included by a defined constant instead of a get_included_files() check. #11748"" / Where can i get this Fix. I'm not very experienced with MODX.
    Cheers Roland [ed. note: solenthaler last edited this post 10 years ago.]
      • 25201
      • 94 Posts
      Connect to your database via phpmyadmin or something and look for table modx_system_settings it has the two records compress_css and compress_js. Change the values to 0.
        • 25201
        • 94 Posts
          • 30269
          • 119 Posts
          Also upgraded today to fresh 2.3.1-pl from 2.2.1 and now getting
          "Code: 200 OK {"success":false,"message":"Processor not found: getlist","total":0,"data":[],"object":[]}"


          When I try to edit a Page, Chunk, Snippet and TV. Strangly error does not show when I try to edit Template.

          How to solve this? I upgraded all addons. [ed. note: Tom last edited this post 9 years, 11 months ago.]
            • 30269
            • 119 Posts
            Ok, after Saving a page by clicking through the error messages, the error is gone. Now all seems to work ok.
              • 22427
              • 793 Posts
              Quote from: rnd at Jul 19, 2014, 04:23 PM
              To get that dreaded Code 200 OK fixed; make sure class_map is selected in the permissions.
              Lost hours today fiddling with the ACLs to find the reason for this 200 OK error message. Finally I found this post which helped me out.

              Can someone explain what this class_map permission is doing and why activating it avoids this error?
                • 38539
                • 18 Posts
                I just ran into a similar issue while trying to give a client access to the user management. Every time a user profile was selected I received the msg:

                Code: 200 OK
                {"success":false,"message":"Permission denied!","total":0,"data":[],"object":[]}


                I had to do a very comprehensive debugging here, enable/disable every possible parameter in the ACL. The final solution was to enable "To edit or view Namespaces."-permission.

                Also some other really odd permissions had to be granted to get things working. I am not sure if this has something to do with the new backend design in MODx 2.3.x but as far as I am concerned the ACL is super complicated and the relation between a permission and the goal that you trying to achieve is always really abstract. I love MODx because it is super flexibel but this is something that was always really obscure and I think it got even worse in 2.3 [ed. note: mojorisin last edited this post 9 years, 10 months ago.]
                  • 30269
                  • 119 Posts
                  Talking about complication of permissions, roles and so on: That is for us the show-stopper after using Modx since.. almost the beginning. It is so complicated that you need not be just IT expert but MODx expert to get it going... and then even often it fails.

                  I think two things need to be done: 1-kick the guy who made that stuff and/or take away his pot;) 2-develop some kind of "permission agent" that resets everything to default for IT experts that are not trained for years in this matter
                    • 40385
                    • 75 Posts
                    +1 on this issue. Something needs to be done in an upcoming release. I always felt like spinning the wheel of fortune to get something working with the ACL.
                      • 12410
                      • 353 Posts
                      Quote from: rnd at Jul 19, 2014, 04:23 PM
                      Susan was right, it were the permissions. (I have also answered this on a related thread.)

                      To get that dreaded Code 200 OK fixed; make sure class_map is selected in the permissions.
                      To get log out back, make sure menu_user is selected in the permissions.

                      Be sure to Manage > Flush Your Permissions as not always new settings will be instantiated.

                      I tried this fix on revo 2.31 + 2.3.2 and still get the error just when editing resources made with the Articles extra for non admin users only. I flushed permissions and emptied cache. Same website in Revo 2.2.14 performs fine. No error
                      Any ideas?
                      Thanks [ed. note: howster last edited this post 9 years, 8 months ago.]