We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 35715
    • 59 Posts
    Jason - not sure on that one. I would say could definitely be the case when I personally am working - presumably having the manager open and a resource open in another Safari tab counts?

    But I think its less likely for some of my clients. Unless if I do it it then breaks it for anyone else after me (at a different location?) until sessions are forced to flush...
      • 9102 ☆ A M B ☆
      • 318 Posts
      Quote from: opengeek at Oct 03, 2013, 07:59 AM
      Can those of you experiencing this confirm or deny that this occurs when you are viewing a Resource in the front-end within the same browser session as using the Manager? I stepped through this with someone experiencing the problem yesterday, and turning off sessions in the front-end Context( s ) or viewing the front-end in an incognito window prevented the problem from reoccurring.

      It's possible. I do normally work with both open, and I suspect others do as well. I'll try avoiding that for a while and see if it prevents the problem from recurring.

      I'm certain that the problem does not occur every time you try to save a resource with a front-end tab open in the same browser, there have been plenty of cases where the problem has not occurred under these circumstances.

      But I don't remember a specific instance where the problem occurred and there was definitely not another tab open with to the front end of the site.
        • 35715
        • 59 Posts
        Just logged into a site and before I could alter any resource I got the Access Denied message. So I had to flush sessions to continue.

        So, from a freshly flushed sessions start I tried to force the above to happen - but to no avail. Unless I'm misunderstanding the scenario. So might the issue be time based? As I only went through a routine for about 10 minutes?
          • 35715
          • 59 Posts
          Guys, is there anything here we can do to help recreate the issue? One of my main sites has just access denied me twice in the space of an hour. First login denied me so I had to flush sessions so logged in again, completed my changes and logged out correctly. 20 minutes later, logged in and denied again forcing yet another session flush. I'm at a loss without any errors in the logs anywhere but keen to help get this rectified. I've already supplied the site in question as a modxcloud snapshot to support but still the issue cannot be recreated. So unless its because I'm on dirty old ADSL wherever I go, I'm at a complete loss.
            • 22303 MODX Staff
            • 10,725 Posts
            Phil W:

            Have you customized any of the session handling/configuration in your install? Did you turn off the database session handling by chance?
              • 35715
              • 59 Posts
              Quote from: opengeek at Oct 11, 2013, 07:48 AM
              Phil W:

              Have you customized any of the session handling/configuration in your install? Did you turn off the database session handling by chance?

              Sorry but no - I'm nowhere near clever enough to change anything in that side of things. Sorry.
                • 73
                • 37 Posts
                Hi, I am also getting this problem with a MODX Revolution 2.2.9-pl (traditional) Installation.

                The server environment is cPanel/WHM on GNU/Linux.
                Software installed is PHP 5.3.10 and MySQL 5.1.61.
                Packages installed are FormIt, Gallery, getPage, getResourceField, getResources, phpThumbOf, TinyMCE, UltimateParent and Wayfinder.

                No errors in Error Log and no session customization has been made.

                If there is anything else I can do to help identify the issue please let me know? This connectors stuff is a bit above me and I am reluctant to implement any hacks that may compromise security.
                  • 36613
                  • 328 Posts
                  The only solution is to now use modx 2.2.7 . Recent versions have this bug.
                    • 73
                    • 37 Posts
                    Oh shame, I just upgraded to 2.2.10.
                    I have the older v.2.2.7 files – is the downgrade process the same as the upgrade process?

                      • 36613
                      • 328 Posts
                      I do not think you should do the downgrade.
                      You could try to solve the problem temporarily so:
                      https://forums.modx.com/thread/85173/after-upgrade-to-2-2-8-problem-access-denied-on-save?page=6#dis-post-476634