same here: upgrade from 2.2.4 to 2.2.5 a couple of days ago and no policy to chose when trying to assign user group to a fresh created media source. no error logs, no js errors...
yes, just tried that in the dev env with 2.2.4. (yes was traditional : original): there i could chose between 2 policies when trying to assign even though that my tester has still unlimited access to the file system but that is due to wrong settings at the moment.
Hi, I did an upgrade from 2.2.0 to 2.2.5 but noticed I was still logged in as user on another computer. So I logged out and ran setup on the first machine. Anyway, same happened to me, the dropdown for the "Policy" in the "add user group" to "media source" was empty and I could not save. I remembered the user being logged on before upgrade, so I emptied cache and flushed all sessions and ran setup again. And things were as they should have been. I can now choose a policy. Hope it helps others...
-
MODX Staff
- 10,725 Posts
Odd, running setup should not be affected by user logins, but I will definitely follow-up on your observations here. This may finally be the key to unlock this problem...thanks for your input.
Quote from: opengeek at Nov 21, 2012, 08:17 PMOdd, running setup should not be affected by user logins, but I will definitely follow-up on your observations here. This may finally be the key to unlock this problem...thanks for your input.
There is one upgrade in that sequence that saves the user record. I think it's the one that modifies the password hash method. That upgrade will crash if certain plugins are installed, though I don't see how it could mess with Policies or Media Sources, unless primary_group is involved somehow.
I just wanted to confirm I have the same problem and noticed the same errors while upgrading. Hopefully there will be a temporary work around until this is addressed.
-
MODX Staff
- 10,725 Posts
@ScottP I suppose the temporary workaround is to run upgrade again until we can absolutely identify the source of this problem.
@starzzz If you logout of the manager before running 2.2.6 upgrade the first time, does this still occur and generate those errors?