We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 4955
    • 32 Posts
    same here: upgrade from 2.2.4 to 2.2.5 a couple of days ago and no policy to chose when trying to assign user group to a fresh created media source. no error logs, no js errors...
      • 22303 MODX Staff
      • 10,725 Posts
      Quote from: charismeki at Nov 13, 2012, 09:20 AM
      same here: upgrade from 2.2.4 to 2.2.5 a couple of days ago and no policy to chose when trying to assign user group to a fresh created media source. no error logs, no js errors...
      You could choose them in 2.2.4 before you upgraded? Was 2.2.4 the original version you installed or was it upgraded from a previous version?
        • 4955
        • 32 Posts
        yes, just tried that in the dev env with 2.2.4. (yes was traditional : original): there i could chose between 2 policies when trying to assign even though that my tester has still unlimited access to the file system but that is due to wrong settings at the moment.
          • 10076
          • 1,024 Posts
          Hi, I did an upgrade from 2.2.0 to 2.2.5 but noticed I was still logged in as user on another computer. So I logged out and ran setup on the first machine. Anyway, same happened to me, the dropdown for the "Policy" in the "add user group" to "media source" was empty and I could not save. I remembered the user being logged on before upgrade, so I emptied cache and flushed all sessions and ran setup again. And things were as they should have been. I can now choose a policy. Hope it helps others...
            • 22303 MODX Staff
            • 10,725 Posts
            Odd, running setup should not be affected by user logins, but I will definitely follow-up on your observations here. This may finally be the key to unlock this problem...thanks for your input.
              • 3749
              • 24,544 Posts
              Quote from: opengeek at Nov 21, 2012, 08:17 PM
              Odd, running setup should not be affected by user logins, but I will definitely follow-up on your observations here. This may finally be the key to unlock this problem...thanks for your input.

              There is one upgrade in that sequence that saves the user record. I think it's the one that modifies the password hash method. That upgrade will crash if certain plugins are installed, though I don't see how it could mess with Policies or Media Sources, unless primary_group is involved somehow.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 40541
                • 85 Posts
                Posting that I have this exact same issue, currently running on 2.2.4-pl. This is a fairly new installation and have run this version from the start. I have one additional user created that I wanted to assign the media source to. Happy to share any information you want or give you access to the website.

                Perhaps it would be worth upgrading to 2.2.5-pl?

                Cheers.

                NOTE: Noticed the same problem in another thread which is referenced here https://forums.modx.com/thread/79992/media-source-access-policies-templates-missing [ed. note: mflammia last edited this post 13 years, 9 months ago.]
                  • 42301
                  • 2 Posts
                  I reproduced the issue easily. In 3 steps:

                  1. Install 2.2.5 pl
                  2. Login (not very important, I think)
                  3. Upgrade to 2.2.6 pl

                  That's it. No extras installed or resources created. After that Media Source Admin policy becomes empty.

                  But I found a way to fix the issue: just run upgrade process again. From 2.2.6 to 2.2.6. After that the policy is recovered.

                  Here are errors from log during upgrdade from 2.2.5 to 2.2.6

                  [2012-12-09 19:43:44] (ERROR @ /setup/index.php) Error 42S22 executing statement: 
                  Array
                  (
                      [0] => 42S22
                      [1] => 1054
                      [2] => Unknown column 'modAccessPermission.policy' in 'where clause'
                  )
                  
                  [2012-12-09 19:43:44] (ERROR @ /setup/index.php) Error 42S22 executing statement: 
                  Array
                  (
                      [0] => 42S22
                      [1] => 1054
                      [2] => Unknown column 'modAccessPermission.policy' in 'where clause'
                  )

                  [ed. note: starzzz last edited this post 13 years, 9 months ago.]
                    • 26430
                    • 8 Posts
                    I just wanted to confirm I have the same problem and noticed the same errors while upgrading. Hopefully there will be a temporary work around until this is addressed.
                      • 22303 MODX Staff
                      • 10,725 Posts
                      @ScottP I suppose the temporary workaround is to run upgrade again until we can absolutely identify the source of this problem.

                      @starzzz If you logout of the manager before running 2.2.6 upgrade the first time, does this still occur and generate those errors?