Issue comes up when trying to restrict access to the Filesystem section of the File Tree. I.e. Tools > Media Sources > then update Filesystem media source > Add User Group.
User Group and Minimum Role options are visible on drop downs. Nothing can be selected under Policy and settings cannot be saved.
Running Revo 2.2.4-pl (traditional) upgraded from fresh install of 2.2.3 approx two weeks ago.
Have reported this as a bug #8157
Does anyone else have this problem? It's almost two months since my initial post above and I don't have a solution...
-
MODX Staff
- 10,725 Posts
I have attempted to reproduce this but am unable to in the latest release-2.2 branch in git. Did you change any of the MODX-installed Policies before upgrading? Do you have any errors in the logs or are you seeing any Javascript errors on the page?
I don't recall changing any of the MODX-installed Policies. However I have added several policies of my own.
Error log pasted below:
[2012-06-19 12:09:57] (ERROR @ /connectors/element/propertyset.php) Error caching lexicon topic lexicon/en/core/element
[2012-06-19 16:10:21] (ERROR @ /connectors/resource/index.php) Error caching lexicon topic lexicon/en/core/resource
[2012-06-19 17:00:34] (ERROR @ /connectors/system/settings.php) Error caching action map mgr/actions
[2012-06-21 13:20:22] (ERROR @ /connectors/lang.js.php) Error caching lexicon topic lexicon/en/core/resource
[2012-06-22 14:18:20] (ERROR @ /connectors/security/user.php) Could not get table class for class: modAccess
[2012-06-22 14:18:20] (ERROR @ /connectors/security/user.php) Could not get table name for class: modAccess
[2012-06-22 14:18:20] (ERROR @ /connectors/security/user.php) Error 42000 executing statement:
Array
(
[0] => 42000
[1] => 1064
[2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AS `modAccess` WHERE `modAccess`.`principal` = 2' at line 1
)
[2012-06-22 14:28:47] (ERROR @ /connectors/security/user.php) modUserProfile: Attempt to set NOT NULL field internalKey to NULL
[2012-06-22 14:28:53] (ERROR @ /connectors/security/user.php) Could not get table class for class: modAccess
[2012-06-22 14:28:53] (ERROR @ /connectors/security/user.php) Could not get table name for class: modAccess
[2012-06-22 14:28:53] (ERROR @ /connectors/security/user.php) Error 42000 executing statement:
Array
(
[0] => 42000
[1] => 1064
[2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AS `modAccess` WHERE `modAccess`.`principal` = 4' at line 1
)
[2012-06-22 14:47:36] (ERROR @ /connectors/workspace/packages.php) Error caching lexicon topic lexicon/en/core/default
[2012-06-22 16:10:58] (ERROR @ /connectors/element/tv/renders.php) Error caching lexicon topic lexicon/en/core/tv_input_types
[2012-06-23 16:48:21] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-23 16:48:21] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-23 16:48:21] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-23 16:48:21] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-23 17:18:33] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-23 17:18:33] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-23 17:18:33] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-23 17:18:33] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-26 07:36:36] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-26 07:36:36] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-26 07:36:36] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-26 07:36:36] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-26 20:50:19] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-26 20:50:19] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-26 20:50:19] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-26 20:50:19] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-27 07:47:10] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-27 07:47:10] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-27 07:47:10] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-27 07:47:10] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-06-29 15:32:31] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-02 09:29:32] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) Could not load class: unknown from mysql.unknown.
[2012-07-04 15:33:06] (ERROR @ /connectors/system/log.php) unknown::load() is not a valid static method.
[2012-07-09 16:16:16] (ERROR @ /connectors/element/propertyset.php) Error caching lexicon topic lexicon/en/core/default
Try turning off the compress_js and compress_css System Settings and clearing the site cache.
You could also have a missing or corrupted file in your install, especially if you used FTP to transfer the files individually.
------------------------------------------------------------------------------------------
PLEASE, PLEASE specify the version of MODX you are using.
MODX info for everyone:
http://bobsguides.com/modx.html
Hi Bob, I've tried your suggestion but no joy.
I'm also having exactly the same problem on another site, also running 2.2.4-pl (traditional)
Screen shot attached showing inaccesible Policy drop-down. Nothing happens when this is clicked – no options are available.
-
☆ A M B ☆
- 1,780 Posts
use the media source user policy template to create a new media source administrator policy. Check all 7 policies. The user should only have 4 checked iirc.
Alas, this doesn't change the behavior. Still no policy to select.
One observation though: The standard Media Source admin policy is empty, as well als the Media Source admin template it is based upon.
I manually created a new template and an policy based on this template, but without the desired effect in the Media Source manager.