お世話になります、kuwaです。
書籍MODxでつくる最強のCMSサイトを参考にXAMPPを利用しローカル環境でMODxをインストールしました。
フレンドリーURLを有効にするにあたり管理画面での設定(P55)、mod_rewrite.soの#を削除(P61)、
/XAMPP/htdocs/htaccessの一部を(htaccessファイルは前に . を付けて保存できないので .txtで保存)
RewriteEngine On
RewriteBase /MODx
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA,NC]
に変更したのですがフレンドリーURLが使えていないようで、又、/localhostでデモサイトでメニューのBlogなどに移動しても404エラーとなります。
他の方の書き込みやサイトを参考にしてみたのですが理解できずに困っています。
どうぞ、アドバイスを頂けないでしょうか よろしくお願いいたします。
取り急ぎ、名前の変更方法を。
方法その1 : コマンドプロンプトで改名
> rename htaccess.txt .htaccess
方法その2 : コマンドプロンプトでリダイレクト
> type htaccess.txt > .htaccess
custarさん早速のお返事ありがとうございます
上記方法でHTACCESS ファイルが出来上がりました。htdocs/,manager/に元にあったhtaccess.txtと入れ替えて
localhostでサイトにアクセスしたのですがError500が出るようになってしまいました。
よろしければ引き続きのフォローよろしくお願いいたします。
最も基本的な部分が設定されていないのではないかと思われます。
apache が rewrite を使えるようになっているかどうか。
httpd.conf の該当が所を変更し、rewrite を有効にしてください。
custerさんkenさんお返事ありがとうございます。
C:\xampp/htdocs/htaccessをフォルダからデスクトップに移動させてlocalhostにアクセスするとトップ画面が表示できましたので、まず記述間違いを探してみたいとおもいます。
ディレクトリ構造はC:¥XAMPP/htdocsにDOMx本体解凍後のmodx-0.9.5内のファイルをすべてコピーしました。
C:\xampp/htdocs/htaccessに
php_flag register_globals off
Options None
<FilesMatch "^\.ht"> (\は¥となっている)
Order allow,deny
RewriteEngine On
RewriteBase /MODx
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA,NC] を追加し
C:\xampp/htdocs/manager/htaccessの内容は RewriteEngine Off 一行のみの記述です
C:\xampp/apache/conf/httpd.confは LoadModule rewrite_module modules/mod_rewrite.soの#を外してあります。
ログと権限についても基本的な部分が理解出来ていない為、皆様への返答も的を外したりで申し訳ありません。