Quote from: JorgenM at Nov 03, 2008, 08:25 AM
Thanks for the advice - unfortunately the SAFE MODE prevents me from using the MaxiGallery management in any way - also if I just try to resynch, I get the same error message.
I think the conclusion is that I wont be able to use ModX / MaxiGallery for the project.
Still I don’t understand why you couldn’t use MaxiGallery in SAFE MODE environment.. I haven’t seen any error message from you, it’s pretty hard to just guess what’s the problem. If the problem is with apache / ftp user accounts being different and user permissions, then you can configure maxigallery to use the FTP functions to upload pictures.
"He can have a lollipop any time he wants to. That's what it means to be a programmer."
Yes, that’s the error I thought it would be.. You just need to setup maxigallery to use the FTP functions. See MaxiGallery wiki page and the snippet parameters that have "ftp" in them.
"He can have a lollipop any time he wants to. That's what it means to be a programmer."
Anything more on this thread?
It was a good read but without a real ending. Did the OP give up or did he find something that worked?
I am also looking for an easy gallery system that plays nicley with jQuery...
Max
What more information do you need?
The error that is described above happens because the PHP user does not have rights to move the uploaded files to the destination folder.
That is usually the case when host uses SAFE_MODE to help with their server security. The "fix" for this is to use the ftp commands in MaxiGallery to upload pictures. It means that when a picture is uploaded in maxigallery, the script will take a FTP connection to the server with defined ftp user account and transfer the file via that connection.
"He can have a lollipop any time he wants to. That's what it means to be a programmer."
Well, I was just curious if it worked for the OP (only 11 posts I see...)