We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 26435
    • 1,193 Posts
    I think the directive you want for php5 is:
    allow_url_include = true

    It is off by default as you can see here:
    http://us2.php.net/manual/en/ini.php

    -sD-
    Dr. Scotty Delicious, Scientist.
      Husband, Father, Brother, Son, Programmer, Atheist, Nurse, Friend, Lover, Fighter.
      All of the above... in no specific order.


      I send pointless little messages
      • 14779
      • 256 Posts
      Warning: include_once() [function.include-once]: URL file-access is disabled in the server configuration in /homepages/16/d163069289/htdocs/mayonnaise/mrw.php on line 491
      
      Warning: include_once(http://scottydelicious.com/MODx/mrw_version.inc) [function.include-once]: failed to open stream: no suitable wrapper could be found in /homepages/16/d163069289/htdocs/mayonnaise/mrw.php on line 491
      
      Warning: include_once() [function.include]: Failed opening 'http://scottydelicious.com/MODx/mrw_version.inc' for inclusion (include_path='.:/usr/local/lib/php5') in /homepages/16/d163069289/htdocs/mayonnaise/mrw.php on line 491


      So what does this error need?

      The allow_url_include directive or the allow_url_fopen directive?

        PM me to find out how you can get a FREE ipad 2!
        • 26435
        • 1,193 Posts
        allow_url_fopen is on by default in the php.ini for php5
        This allows php scripts to open remote files.

        MRW 2.1.0 "INCLUDEs" a file from a remote server to get parameters and variables from it.

        fopen let’s you open a file to see it’s contents. including a file in php takes the variables in the included file as if they were the scripts own variables. in order to include these variables from a remote script, your php installation must first be able to include remote files.

        this is set in the allow_url_include directive. As I said before, it is off in the default php.ini. You can look that up in the link I provided to see what else is on or off by default.

        to use this installer, you must have allow_url_include set to true.

        This is a php/ your server issue, not something with MODx or the script.

        allow_url_fopen is ON by default, but I don’t know how relevant it is to this situation. The directive you must have on is the allow_url_include directive.

        This is not an issue with php4 by the way.

        -sD-
        Dr. Scotty Delicious, Scientist.
          Husband, Father, Brother, Son, Programmer, Atheist, Nurse, Friend, Lover, Fighter.
          All of the above... in no specific order.


          I send pointless little messages
          • 14779
          • 256 Posts
          OK. The bottom line is, I need to get allow_url_include working for my site.

          The link here:
          http://de3.php.net/manual/en/ini.php#ini.list
          has this listing for allow_url_include:

          Name Default Changeable Changelog
          allow_url_include "0" PHP_INI_SYSTEM Available since PHP 5.2.0.

          and phpinfo() from the MODX manager reveals:

          allow_url_include Off

          So this is appears to be a host issue.
            PM me to find out how you can get a FREE ipad 2!
            • 14779
            • 256 Posts
            OK, My host confirmed that they will not turn it on. Is it possible to manually install it?
              PM me to find out how you can get a FREE ipad 2!
              • 23258
              • 6 Posts
              Hi @ all !

              I need some help....I RECIEVE SOME ERROR MESSAGE !!!!! sad

              When i try to install some templates with SkinGraph....and i recieve this error message :

              Warning: move_uploaded_file(/hsphere/local/home/xxxx/xxxx.ws/assets/modules/skingraft/tmp/Black_and_Blue_Template_1.zip): failed to open stream: Permission denied in /hsphere/local/home/xxxx/xxxx.ws/assets/modules/skingraft/sg.inc.php on line 349
              
              Warning: move_uploaded_file(): Unable to move '/tmp/phpLPiUuq' to '/hsphere/local/home/xxxx/xxxx.ws/assets/modules/skingraft/tmp/Black_and_Blue_Template_1.zip' in /hsphere/local/home/xxxx/xxxx.ws/assets/modules/skingraft/sg.inc.php on line 349
              There was an error. The file was not uploaded. Check the folder CHMOD.



              AND.... When i try to install some packages with MODx Resource Wizard, i recieve this message ERROR :

               Evaluation of your resource.
              
              Warning: move_uploaded_file(/hsphere/local/home//xxxx/xxxx.ws/assets/modules/wizard/eval/bbcode_plugin.modxpkg.zip): failed to open stream: Permission denied in /hsphere/local/home//xxxx/xxxx.ws/assets/modules/wizard/wizard.class.php on line 120
              
              Warning: move_uploaded_file(): Unable to move '/tmp/phpk5LqqH' to '/hsphere/local/home/xxxx/xxxx.ws/assets/modules/wizard/eval/bbcode_plugin.modxpkg.zip' in /hsphere/local/home//xxxx/xxxx.ws/assets/modules/wizard/wizard.class.php on line 120
              The MODx Resource Wizard package could not be uploaded to the server.
              


              Many thanks for your help smiley

              Philou83
                • 7923
                • 4,213 Posts
                So, have you checked the folder permissions like the error message says?


                  "He can have a lollipop any time he wants to. That's what it means to be a programmer."
                  • 23258
                  • 6 Posts
                  Witch permission must i set to :

                  - Folders
                  - Files

                  ???


                  Best Regards smiley
                    • 28042 ☆ A M B ☆
                    • 24,524 Posts
                    assets/modules/skingraft/tmp must be set to 777.
                      Studying MODX in the desert - http://sottwell.com
                      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                      Join the Slack Community - http://modx.org
                      • 23258
                      • 6 Posts
                      Thanks for your help smiley

                      Trouble = FIX

                      Soluce : A lot of folders has to been CHMOD to 777

                      :)