We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 19257
    • 141 Posts
    Quote from: OpenGeek at Mar 04, 2008, 06:59 PM

    You’re server does not allow inclusion of foreign content via URL, as the error describes. This is something you’ll need to take up with your hosting provider; or you might be able to try another news feed component like FeedX. It might use a different method to read the feed that does work on your server.

    @OpenGeek - Thanks alot for your help, I’m gonna check out FeedX.


    I find the error strange, I’m running it on a shared Godaddy server which has worked pretty well for me, I’ve been able to use rss news feeds like this on Joomla and other cms on their servers without a problem..

    Thanks again for your help.
      • 8847
      • 19 Posts
      My host servive dissabled URL file access.
      How can NewsParserX works without it?
      Thanks
        • 22303 MODX Staff
        • 10,725 Posts
        You can’t; get a better host or try some other RSS reader add-ons like FeedX, though I imagine you will have exactly the same problem with those.
          • 13736
          • 345 Posts
          Could you update the instructions in the download page to include descriptions of what all this

          |xq|feed|xe|rss|xa|limit|xe|10

          means?

            • 13736
            • 345 Posts
            Quote from: miamisurf at Mar 04, 2008, 07:31 PM

            Quote from: OpenGeek at Mar 04, 2008, 06:59 PM

            You’re server does not allow inclusion of foreign content via URL, as the error describes. This is something you’ll need to take up with your hosting provider; or you might be able to try another news feed component like FeedX. It might use a different method to read the feed that does work on your server.

            @OpenGeek - Thanks alot for your help, I’m gonna check out FeedX.


            I find the error strange, I’m running it on a shared Godaddy server which has worked pretty well for me, I’ve been able to use rss news feeds like this on Joomla and other cms on their servers without a problem..

            Thanks again for your help.

            I just started having the same problem on 1&1. The feed worked fine for months and now I get that error page saying "URL file-access is disabled in the server configuration". I wonder if it has to do with an upgrade to recent versions of Apache, PHP, etc.

              • 25080
              • 175 Posts
              I try to install this snippet, but after saving the snippet, i have this code :

              Warning: Unknown(assets/snippets/newsparserx/newsparserx.inc.php): failed to open stream: Aucun fichier ou r�pertoire de ce type in /home.10.27/bpracing/www/manager/includes/document.parser.class.inc.php(769) : eval()'d code on line 80
              
              Warning: (null)() [function.include]: Failed opening 'assets/snippets/newsparserx/newsparserx.inc.php' for inclusion (include_path='/home.10.27/bpracing/www/manager/includes/') in /home.10.27/bpracing/www/manager/includes/document.parser.class.inc.php(769) : eval()'d code on line 80
              
              Fatal error: Cannot instantiate non-existent class: rss_feed in /home.10.27/bpracing/www/manager/includes/document.parser.class.inc.php(769) : eval()'d code on line 82


              What’s the problem ? :/
                • 28042 ☆ A M B ☆
                • 24,524 Posts
                Is the file "newsparserx.inc.php" in the assets/snippets/newsparserx directory? Did you upload the newsparserx folder?
                  Studying MODX in the desert - http://sottwell.com
                  Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                  Join the Slack Community - http://modx.org
                  • 25080
                  • 175 Posts
                  Yes of course...


                  edit : without comment, it work smiley


                  And is it possible de give a "class" to "div" whitch are generated ? for css customisation.

                  I have a bug...
                  When description is on "true", some title link aren’t generated.
                  there is
                  '>
                  before the title.

                  is there something to do ?
                    • 25080
                    • 175 Posts
                    no support today for this snippet ?
                      • 19257
                      • 141 Posts
                      wow I’m such a goofball, after many months I got this snippet to work on a Godaddy shared hosting site by modifying the second row of the php.ini in my root folder. Whoo hoo! grin