Quote from: anita at Dec 28, 2010, 11:12 AM
I tried putting the following lines in the php.ini:
extension=pdo.so
extension=pdo_mysql.so
The error message disappeared, but I only got a blank page.
Thank you for your help!
Modx Rev 2.0.6(traditional)
Hi,
My hosting currently has magic_quotes on, so I tried shutting them off as a test. I wanted to do some preparation in advance for the next version of PHP, which will have magic_quotes off by default. I put the command into that folder’s php.ini, and got the same "Fatal error: Class ’PDO’ not found..."
I used Anita’s solution above, and unlike her case, it fixed it all immediately! (I had also seen the idea for that two-liner on a Drupal forum post for the same type of error)
What was most confusing is that "phpinfo" was showing that PDO was enabled! But apparently you have to explicitly turn it on, so to speak. So maybe server admins are only doing half of the procedure, and then thinking that they’re done with PDO. Anecdotally, I’d guess that they’re not all that familiar with PDO yet.
As my host said, in my case I could have also turned magic_quotes back on to alleviate it, even after the PHP upgrade, but that seemed kind of lame.
Cheers, Dave