We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 25979
    • 178 Posts
    Hi,

    I have my site run revo. I am building client panel so I decided to create new context - panel - new subdomain panel.domain.tld. I added site_start (130), base_url (/), http_host (panel.domain.tld), site_url (http://panel.domain.tld/),updated the context, created subdomain - panel - copied index.php, .htaccess, and config.core.php into panel folder. I edited index.php and initialized panel context in place of web one. I also edited path to /core/ in config.core.php to full path (/home/user/domain.tld/public_html/core/)

    When I am entering subdomain with html file it works just fine. But when I try to use modx I get 503 error. I got nothing in my logs except error in revo error log:
    (ERROR @ /connectors/context/index.php) modManagerLog: Attempt to set NOT NULL field item to NULL

    And as I checked it now, I get the error when adding context or deleting one.


    Does anyone know why it could be? I have another testing site build upon one of revo rc’s and have there contexts working just fine. Don’t know why here it doesn’t want to run sad

    Regards,

    Mike

    I use: MODx Revolution 2.0.0-pl rev7212

    apache 2.2.14
    php 2.2.14
    pcre 8.00
    curl 7.19.16
    mysql 5.1.40
      //Why use windows since there is a door?//
      • 3749
      • 24,544 Posts
      There are four config.core.php files (the one /setup/includes is only used during Setup)) -- did you get them all?

      § MODx root directory
      § /manager/
      § /connectors/
      § /setup/includes/


        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 25979
        • 178 Posts
        I copied only one from the root of modx dir.

        Isn’t it enough?

        It was workin’ like that on rc.

        I’ll try copying them all then...
          //Why use windows since there is a door?//
          • 25979
          • 178 Posts
          And it didn’t change anything. I think it is not the problem. I think the problem is there where this error comes from. But it says me nothing sad

            //Why use windows since there is a door?//
            • 3749
            • 24,544 Posts
            Look at the content of those config.core.php files and see if they’re really pointing to your current core directory.

            Are you using the traditional or the advanced install?

            Are you using a plugin or index.php to select the right context?
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 25979
              • 178 Posts
              I use index.php, the paths in core.config.php files are correct.
              I had rc here and updated it to stable version.

              regards,

              mike
                //Why use windows since there is a door?//
                • 3749
                • 24,544 Posts
                I’m afraid I’m out of ideas. 503 usually means that the server is temporarily out of service. I don’t see how that would be caused by a problem with contexts (assuming that your original site still works).

                Maybe someone else will have a better idea.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 25979
                  • 178 Posts
                  Thx anyway smiley
                    //Why use windows since there is a door?//
                    • 25979
                    • 178 Posts
                    OK, so I thought it might because of bad upgrade process. I installed fresh copy of modx rvolution in the root directory of domain.tld Then created context ’test’ and added subdomain test.domain.tld (resolves OK).

                    Then I copied index.php (changed initialized context to test), .htaccess, and core.config.php (changed core path to the full path to the mox root dir) to subdomain folder.

                    After that I added four settings to the context: site_start (2), base_url (/), http_host (test.domain.tld) and site_url (http://test.domain.tld/) updated context and cleared site cache.

                    Of course I got 503 error sad

                    In modx logs i found that:

                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not copy /home/user/domains/domain.tld/public_html/core/packages/core/modContext/bb0ab31ff60c6076faf4e52380d863d4/0/ to index.php
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not copy /home/user/domains/domain.tld/public_html/core/packages/core/modContext/bb0ab31ff60c6076faf4e52380d863d4/1/ to ht.access
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not copy /home/user/domains/domain.tld/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/0/ to assets
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not copy /home/user/domains/domain.tld/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/1/ to controllers
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not copy /home/user/domains/domain.tld/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/2/ to templates
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not copy /home/user/domains/domain.tld/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/3/ to ht.access
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not copy /home/user/domains/domain.tld/public_html/core/packages/core/modContext/4d43e647705a21a39cce4e206eae2fc4/4/ to index.php
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not install files from /home/user/domains/domain.tld/public_html/core/packages/core/xPDOFileVehicle/788c3d8c5ceea2081e0e45beea59445c/ to 
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not install files from /home/user/domains/domain.tld/public_html/core/packages/core/xPDOFileVehicle/cfb6e044acfd4380af21297330d6e10a/ to 
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not install files from /home/user/domains/domain.tld/public_html/core/packages/core/xPDOFileVehicle/4ad20f2590e41758af884f8f50cf9e90/ to 
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not install files from /home/user/domains/domain.tld/public_html/core/packages/core/xPDOFileVehicle/c9366179780330a60397dc65652071a9/ to 
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not install files from /home/user/domains/domain.tld/public_html/core/packages/core/xPDOFileVehicle/70496e8c8b2f20b1a5475b6a53d8ae08/ to 
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not install files from /home/user/domains/domain.tld/public_html/core/packages/core/xPDOFileVehicle/62dfa0c3aa4f49d0842fcd1e508daddb/ to 
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not install files from /home/user/domains/domain.tld/public_html/core/packages/core/xPDOFileVehicle/d095a33f0877ac62fc7e084c26b68f9b/ to 
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not install files from /home/user/domains/domain.tld/public_html/core/packages/core/xPDOFileVehicle/479db3a211064595e3407956f5d5e1bc/ to 
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not install files from /home/user/domains/domain.tld/public_html/core/packages/core/xPDOFileVehicle/f33b0387efe09cd9b3c233b2d05ca7e0/ to 
                    [2010-09-12 23:39:33] (ERROR @ /setup/index.php) Could not install files from /home/user/domains/domain.tld/public_html/core/packages/core/xPDOFileVehicle/6d1e6577b5c6677358691d2ad56ad8e1/ to 
                    [2010-09-12 23:42:24] (ERROR @ /connectors/context/index.php) modManagerLog: Attempt to set NOT NULL field item to NULL
                    [2010-09-12 23:43:20] (ERROR @ /connectors/context/setting.php) Error 42S02 executing statement: 
                    Array
                    (
                        [0] => 42S02
                        [1] => 1146
                        [2] => Table 'emgie_test.modx_lexicon_topics' doesn't exist
                    )
                    
                    


                    what it could mean?

                    mike

                      //Why use windows since there is a door?//
                      • 25979
                      • 178 Posts
                      As far as I found till now there is sth wrong with MODX_CORE_PATH in index.php The path looks like this:

                      /home/user/domains/domain.tld/public_html/subdomain_folder/core


                      no matter I set is to

                      /home/user/domains/domain.tld/public_html/core

                      explicitly in config.core.php

                      I got no core folders in my subdomain folder and I believe there should be none.

                      I got none errors with contexts adn subdomains on MODx Revolution 2.0.0-beta-5 rev6224 on the same machine with same environment.

                      Any ideas?
                        //Why use windows since there is a door?//