On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi,

    I just need a confirmation regarding this problem.

    I have few evo sites on eleven 2 shared hosting and all of them, since recent, have problem mentioned in this this post (login/session problems). So,
    Session doesn’t work at all, as once I log in to the manager and open new browser tab, lets say page with maxigallery, it doesn’t recognised active session (e. manage gallery button) and of-course intermittent log-outs.

    I would like to think that I’ve tried all solution (after googling for the last two days), but unfortunately I still can not resolve this problem. I tired adding php_value session path to .htaccess file in website root and manager directory but then I’m getting 500 internal server error.
    I’ve created new session folder (not publicly available) with correct permissions (755) I’m pretty sure I’ve used correct path.


    As this post is marked as solved (and I’ve tried suggested fix), I would appreciate if somebody could list exact steps required to fix this, e.g. include whole .htaccess, php.ini files and place it in original post (for easy access)

    Again, my guess is that my hosting service changed something on their network and the way they save sessions files... Only difference, if it will help, my hosting provider is providing new software package Softaculouse in Cpanel which by the way comes with MODX Rev (Installing Rev through this service looks like resolved the problem, without fully testing it, - and couldn’t see anything special in .htaccess file for this installation). Seeing revo in softaculouse was nice surprise.

    I’m sure there is something simple I’m missing. This problem is frustrating, any pointers would be much appreciated. Just thinking, if newbie comes across this problem, they might not give it enough chance to experience the greatness of modx.

    Thanks
    IK


    MODx version 1.0.0 Version codename rev 5601 (I know I should update)
    Apache version 2.2.19
    PHP version 5.2.17
    MySQL version 5.0.92-community
    Architecture i686
    • I am currently having the same problems mentioned in the first post. My current setup is the following:
      MODx 1.0.6
      PHP 5.3.13
      MySQL 5.5.27

      Upon logging into the admin area I get the message that another person is currently editing these settings. I have updated the php.ini file to save the sessions in a location outside of my web root and set the gc_maxliftime value and I am still getting the same error.

      Are there any new variations of this problem out there since the first post?
      • Looks like this is the same problem I'm having and just posted about. I haven't tried any of these fixes yet. I just don't feel super comfortable dealing in these code issues. I guess I'll have to bite the bullet and try some of these fixes.

        Any other thoughts would be great. This started when I upgraded to ModX 1.0.6 over the weekend. Now, no one can login to the site. I get the following message:

        bpadmin is currently editing these settings. Please wait until the other user has finished and try again.
          Michael Smull
          http://www.bigpixelstudio.com
          twitter: @mdsdesign
        • Is your site in a shared hosting environment?
          • I am using a shared host and none of the solutions online worked. Turns out my host blocks the fsockopen open command in core/model/modx/xmlrss/extlib/snoopy.class.php , which they unblocked on request.