New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Quote from: inreti at Jan 29, 2014, 04:38 PM
    @Mark: maybe it is possible to pack your patch into a patch package? That would ease it to quick fix the problem reliably until a new patch release is out...

    I just checked with the team, and they are planning a new patch release soon (likely within the week). While I could release a patch-package in the mean time, I think that would only add to the confusion.
      Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

      Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
    • If it is going to take more than a couple of days, it would be helpful if there was a downloadable patch, or if someone could clearly identify what code needs to be commented/swapped out. The embarrassing thing is that we had the Chrome issue with 2.2.10 which was annoying my users, and then it was announced by the MODX team that 2.2.11 addressed this issue, and then I passed that message on to my users and I updated to 2.2.11 and now the problem is actually worse (at least I could tell them to use Safari or Firefox to bypass the issue in 2.2.10).

      Naturally, I learned a valuable lesson--test the updates for myself first before passing on such announcements!
      • I can confirm, that Rich Text editors are definetely the cause (at least, one of). When creating new Resources or in the Edit Mode (having done no changes), when navigating away right away, trying to close or refresh the page - always ^^)

        Just tested it on: MODX Revo 2.1.11 fresh install + TinyMCE 4.3.3 installed and enabled. Without RTE enabled on the document - everything goes fine. The same is on a couple of other 2.1.11 instances.

        The 2.2.8 installs (both fresh and working for a couple of monthes) semm not to suffer from the problem.

        So, looking forward to have the official fix =) [ed. note: bonflash last edited this post 5 years, 1 month ago.]
        • Still no sign of MODX 2.2.12...

          Anyhow, I found something like a "fix" that works for me: Dump "TinyMCE" and use "CKEditor" instead. Besides looking better than the bubble-gum-icons-design of Tiny, CK handles text way better! And the popup-alerts don't not show up.

          Oliver
            MINDEFFECTS – DESIGN for PRINT, WEB and MEDIA
            http://twitter.com/mindeffects · http://www.facebook.com/mindeffects · http://www.youtube.com/mindeffects/ · skype://mindeffects_oliver
          • Quote from: mindeffects at Feb 10, 2014, 11:34 AM
            Still no sign of MODX 2.2.12...

            Anyhow, I found something like a "fix" that works for me: Dump "TinyMCE" and use "CKEditor" instead. Besides looking better than the bubble-gum-icons-design of Tiny, CK handles text way better! And the popup-alerts don't not show up.

            Oliver

            I have 2.2.12 with CodeMirror only and having issues since *.11.
            • Quote from: mindeffects at Feb 10, 2014, 11:34 AM
              Dump "TinyMCE" and use "CKEditor" instead.
              It really does the trick. Haven't thoroughly studied CKEditor yet, but at first glance it really looks better than TiniMCE. Thanks for the hint =)
              • There is a downer, bonflash: The "CKEditor" lags a comfortable way to use MODX links. TinyMCE does this job very well. But in nearly all other things CK beats Tiny!

                It's sad that Danya somehow does not continue working on the MODX implementation. CK would make a perfect free standard RTE.
                  MINDEFFECTS – DESIGN for PRINT, WEB and MEDIA
                  http://twitter.com/mindeffects · http://www.facebook.com/mindeffects · http://www.youtube.com/mindeffects/ · skype://mindeffects_oliver
                • Just chiming in: this happens to me with the Articles Package, on both the Article Container page and internal Article Pages.

                  e.g. you edit the Article Container, don't touch anything, then click to load a different page and you get "There are unsaved changes. Are you sure you want to leave this page? Are you sure you want to leave this page?"

                  And edit an Article page and don't touch anything, then click to load a different page and you get the alert. Every time.

                  Regular pages are fine, though.

                  Articles 1.7.6 on MODX 2.2.13
                  • @atmmarketing. Articles uses a custom Resource type and is not a standard MODX Resource. What you're reporting should be filed as a bug for Articles as it needs to be fixed in the Articles code.

                    @mindeffects, it appears that DanyaPostfactum is rekindling development on some of his extras. I'd not be surprised if he revisits CKEditor again.
                      Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. BlogTwitterLinkedInGitHub
                    • Is there a system setting to disable this check?

                      The "Do you really want to leave this page" problem also affects Collections Extra even in modx 2.2.14 (Tested in Safari and Chrome latest versions)

                      Setting a Resource as "Collection" Resource Type, clicking on it on the left tree and then hitting on the Edit button on any children of the Collection Grid triggers the window message even if nothing has been changed.


                      [ed. note: lithiumlab last edited this post 4 years, 11 months ago.]