New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • A user keeps telling me that he gets the mentoined warning. I don't beleve that this comes from the Manager but I don't have any proof for that. Therefor I am here to ask the pros wink -> Is this Message from the Manager? -> If so, how can I disable it?

    If the Message is not from the Manager, It would be nice to get some suggestions to solve this Problem.

    Thanks already to everyone smiley
    • It's supposed to only show if you are leaving a page where you've edited the forms without saving. It's just some Javascript, and some versions of MODx don't quite get it right. It doesn't hurt anything, it's just annoying.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
      • Quote from: sottwell at Dec 03, 2013, 01:21 PM
        ...it's just annoying.
        Well thats the problem ^^ ... So how to disable it?
        • It does come from the Manager and it seems to appear completely at random in the current version of Revo. I don't any way to disable it without hacking the JS code.

          Could you file a bug report here (if there isn't one already): http://bugs.modx.com?
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
          • Quote from: BobRay at Dec 03, 2013, 05:52 PM
            Could you file a bug report here (if there isn't one already): http://bugs.modx.com?
            I will do so. But I am not the one experiencing this Bug. Its a client. Thats why I apsolutly have to solve this! :/

            Does someone know where to find this funktion and to disable it in the Javascript Code? Maybe you Bob? I will look for it in the meantime.
            • If you give me the *exact* message in the popup, I can probably find it for you.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
              • Sorry guys, I forgot to mentoin that it is a Modx Revo 2.2.8 Maybe there is a quick fix for the problem in that version...

                Quote from: BobRay at Dec 03, 2013, 06:24 PM
                If you give me the *exact* message in the popup, I can probably find it for you.

                Thanks, I will ask for the text.
                • Quote from: BobRay at Dec 03, 2013, 06:24 PM
                  If you give me the *exact* message in the popup, I can probably find it for you.
                  I just asked the client. When he answers me I will post it and then open a new ticket.
                  • Better if you post it here. I'm more likely to see it.
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                    • Not sure if this helps, but I saw this problem for the first time today on 2.2.10-pl.
                      I was using Articles. I had an article container open, I had created an article, saved it. Everything was fine. The save button was greyed out. So, I went to close the article container, and it gave me this error. Again the saved button was greyed out.

                      I changed some text and got the save button to light up, pressed save. Thought this would fix it, not luck. pressing close still gave me the error.

                      I finally noticed that somehow the article template field had gotten reset. It did not have a valid template selected. I selected the template, pressed save, and "Ta Da" close worked.

                      You may not be working with Articles, but maybe what MODX is doing, is that for some reason it thinks a required field is not entered, but it is not displaying the red text or message? Maybe if they just put a value in some field it will stop the error message. It might me a temporary work around until someone provides you a way to disable this or fix it.

                      Just a thought.....