On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Quote from: bs28723 at Dec 04, 2013, 03:33 AM
    Not sure if this helps, but I saw this problem for the first time today on 2.2.10-pl.
    I was using Articles. I had an article container open, I had created an article, saved it. Everything was fine. The save button was greyed out. So, I went to close the article container, and it gave me this error. Again the saved button was greyed out.

    I changed some text and got the save button to light up, pressed save. Thought this would fix it, not luck. pressing close still gave me the error.

    I finally noticed that somehow the article template field had gotten reset. It did not have a valid template selected. I selected the template, pressed save, and "Ta Da" close worked.

    You may not be working with Articles, but maybe what MODX is doing, is that for some reason it thinks a required field is not entered, but it is not displaying the red text or message? Maybe if they just put a value in some field it will stop the error message. It might me a temporary work around until someone provides you a way to disable this or fix it.

    Just a thought.....

    Sounds a lot like there is a Class or ID missing or just the wrong one in the Javascript Validation.

    My client answered me this morning and it seems that he is using the Internet Explorer 9 or 10, he sent me a screenshot. So I tried it out and it seems to be related to Internet Explorer.

    And to use IE in the Manager seems to be realy anoying! Everytime I open a resource it is asking me if I realy want to leave the page.

    I know that this is offtopic now because its no longer Modx related but I still want to ask, does someone knows how to disable this check in the IE?
    • Here is what I found out about this problem. Hope this helps!
      • Hi there,

        same problem here. The client and my colleague get the error popup on every click in the resource tree. Open a document, click to another document in the tree and every time comes the popup. On my machine there isn't shown the popup, but I have another error. It's the same like here: http://forums.modx.com/thread/83901/after-2-2-7-upgrade-manager-refreshes-after-every-resource-save#dis-post-463313 Maybe both belong together.

        We use 2.2.10-pl. I use Chrome 30, my colleague is using Chrome 32. And we use Mac OSX Mountain Lion.

        Any suggestions?

        Ciao
        Ralf
        • @Ralf,

          There is a known bug in versions of Revolution below 2.2.11 and Chrome 32 that was fixed in 2.2.11. What has confused the issue some is that in 2.2.11 we also introduced the exact same alert, however, this time intentionally when the edit view enters what is called docDirty state (a change has been made to one of the fields) and then you click on a ui object like another document in the tree or the back button. This will alert you to this and aims to prevent loss of edits.

            Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. BlogTwitterLinkedInGitHub
          • A bit awkardly; you get the message when you change the template and the page refreshes.
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
            • It's certainly not a perfect execution here. It may need refinement in an upcoming release. In addition, it's been requested that there be a system setting to disable/enable this feature too.

                Author of zero books. Formerly of many strange things. Pairs well with meats. Conversations are magical experiences. He's dangerous around code but a markup magician. BlogTwitterLinkedInGitHub
              • And a feature request from moi for a System Setting to disable the many maddening "Are you sure you want to do this" and "By the way, this will only put the packages in the grid, it won't install them" and "This could break you site" messages. wink
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                • Quote from: sottwell at Jan 23, 2014, 09:00 PM
                  A bit awkardly; you get the message when you change the template and the page refreshes.
                  You mean if you change the Template, page refreshes, and you try to navigate away from the page without saving the change? That is the intention. How is that awkward?
                  • I meant, when you change the template the page automatically re-loads. This automatic re-load apparently triggers the warning dialog.

                    However, on further research, I find this only seems to happen with Firefox (FF 26/OSX 10.8.5). Chrome doesn't do it, Safari doesn't do it.

                      Studying MODX in the desert - http://sottwell.com
                      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                      Join the Slack Community - http://modx.org
                    • Hi @all,

                      thanks for your answers. We are in the acceptance process by our client and so I don't like to make a system update. My current solution is to comment out the beforeunload event in `manager/assets/modext/sections/resource/update.js` lines 42-49

                      /* if (!Ext.isIE) {
                              Ext.EventManager.on(window, 'beforeunload',function(e) {
                                  MODx.releaseLock(this.config.resource);
                                  MODx.sleep(400);
                                  e.browserEvent.returnValue = '';
                                  return false;
                              }, this);
                          } */
                      


                      And it works. No popup and no error message. It's ok for the moment.

                      Thanks & ciao
                      Ralf