On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I expect part of the problem with browsing the gallery is that the images never uploaded, so it is trying to reference a file that does not exist. As for the error uploading the file, make sure to have the folders have the correct permissions and the settings in the manager are set correctly. Test with small images first and work your way up. I found that on some servers the host setup may block large files no matter what you might have in the settings.

    The css is a little crazy. My focus has been on the development of the functionality, not on appearance. I hope that once I work out a few more bugs and really get this running smoothly I will have time to really work on the css. If you wish to put together a nicer css package for me that is friendly with foundation, I will be happy to incorporate it with the next package release, otherwise I probably wont make any changes until I get past the beta stage.

    As for favorites, it is available, but I'm still playing around with it so it may change in future versions. Currently it is a two part snippet. First you need a helper page. Create a new resource and set the template to "0" with this snippet call:
    [[!favorites.helper]]

    Then on the page calling the favorites you can use custom css in relation to the assets folder by:
    [[!favorites.panel? &customcss=`css/favorites.css`]]


    Also make sure that you assign the various pages in your settings to point to the correct helper pages. If you don't assign the various resource_id settings, sekusergalleries may not function properly.

    Hope this helps.
    • Hey insomnix,

      First of all thanks for this, I haven't quite got it working yet but it seems like its gonna fit my needs perfectly.

      The problem I'm running into now is the before mentioned "SyntaxError: Unexpected token <" I tested with a jpeg that was smaller than a kb. I've tried going over my settings, but I don't see anything that's wrong. What are the correct permissions for the folders?

      Another curiosity which may help is the directory statistics returns "No space alloted".


      Anyway, I'm gonna keep tinkering with it, but I thought you might know what I'm doing wrong.

      • You must set the Group Settings. This allows you to manage how much space each user may use on your server.
        • Awesome, that worked like a charm. I still get the syntax error from before, but the images are being saved.

          Thanks again for this!

          edit: I had this done for regular members, but I was testing with a super user acct. I just created a new user group and presto. Just in case anyone else runs into something similar. [ed. note: tinman last edited this post 8 years, 5 months ago.]
          • [[!album.items.manage]]
            returns "You are not authorized to view this page." How and where to set permisions ?
            • Make sure you create a group setting in User Galleries and assign your user to that user group.
              Look under Manager: Group Settings in the documentation: http://rtfm.modx.com/display/ADDON/sekUserGalleries
              • I have 3 member groups: Basic, Gold, Premium. In User Galleries Manager I created:
                User Group: Basic
                User Role: Member
                Amount: 1
                Unit Gigabyte
                Enforcement Level: Soft
                Private Viewing Only: No

                [[!album.items.manage]]

                returns now: You are not the owner of this album.

                My snipet checkUserMember
                <?php
                if ($modx->user->isMember('Basic') ) {
                  return "user is a member of Basic Group";
                } else {
                  return "not a member";
                }


                returns: user is a member of Basic Group
                What I'm doing wrong?
                • Sometimes the manager session interferes with the web context. In a separate browser from the browser you have the manager open in, log into your test user account. Create the album, then go to the album items page to upload images.
                  • I'm also getting the "Max alloted space used." error message when trying to upload photos. I've set it up with a test member (not the admin) and I've even set the max file size amount to 10,000 Yobibytes without any luck!

                    I have also noticed I get some errors in the MODX error log; when I first load the photo upload page (before trying to upload photos) I get these errors:

                     [2013-09-04 15:04:19] (ERROR @ /paas/c0075/www/core/components/sekusergalleries/controllers/web/managealbumitemshelper.class.php : 244) PHP warning: array_map(): Argument #2 should be an array
                    [2013-09-04 15:04:19] (ERROR @ /paas/c0075/www/core/components/sekusergalleries/controllers/web/managealbumitemshelper.class.php : 244) PHP warning: array_filter() expects parameter 1 to be array, null given
                    [2013-09-04 15:04:19] (ERROR @ /paas/c0075/www/core/components/sekusergalleries/controllers/web/managealbumitemshelper.class.php : 244) PHP warning: array_values() expects parameter 1 to be array, null given



                      MODX Ambassador for Thailand. Managing Director at Monogon, a web design and development studio based in Bangkok, Thailand. - Follow me on Twitter.
                    • I have not seen those errors before I'm not sure what would cause that.