On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • After upgrading to Evolution-1.0.1, EditArea eventually stopped working. Reinstalling it didn’t help. There were messages in error.log like this:
    PHP Parse error:  parse error, unexpected $ in /var/www/vhosts/host.name.ru/httpdocs/manager/includes/document.parser.class.inc.php(746) : eval()'d code on line 187, referer: http://host.name.ru/manager/index.php?a=102&id=41&r=2&stay=2

    After some debugging, I figured out that error was caused by HEREDOC construct.
    It is strange, because everything worked well before upgrade.
    I am using PHP 4.3.11.

    I’ll attach fixed version of plugin (replaced HEREDOC with "", works for me) and its diff to original code.
    • There were some slight changes in the parser of 1.0.1 related to the caching of snippets and plugins. I didn’t encounter any troubles with HEREDOC during my testing, but after seeing this report, I am going to go back and take a closer look. The parser should support the use of HEREDOC in plugins (even in PHP 4) laugh
        Mike Schell
        Lead Developer, MODX Cloud
        Email: mike@modx.com
        GitHub: https://github.com/netProphET/
        Twitter: @mkschell
      • The save button on the toolbar doesn’t seem to work for me under modx 1.0.1. Is anyone else having this problem?
        • I had same problem after upgrading to 1.0.0, but I can’t remember how I fixed it... sad
          • Quote from: MarSoft at Nov 07, 2009, 12:05 AM

            I had same problem after upgrading to 1.0.0, but I can’t remember how I fixed it... sad

            Anyone else?
            • Save button and "Ctrl-S" are working for me in Firefox (3.5.5) but not in Safari (4.0.4), both on MacOS X 10.5.8.

              • Update to my previous post above:

                In Safari save button works fine in documents but not in elements (templates, chunks ...)

                • Almost the same plugin but with fresh version of EditArea and more simple is here http://code.google.com/p/modxeditarea/
                  • Any idea how to get this implementation of EditArea working with the EditArea Zen Coding plugin (http://zen-coding.ru/demo/)?

                    No matter what I try, I just get the text [zencoding] jammed into my EditArea toolbar when I try to load the plugin.
                    • In the Edit Area plug-in configuration try :
                      Active Plugins -> modx,zencoding
                      That worked for me, after uploading the zencoding folder to :