We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 10076
    • 1,024 Posts
    I tried to update an installation to 2.5, unfortunatly I forgot to logout and maybe that s the cause of the login error i get:

    Fatal error: Call to undefined method modUser_mysql::getPhoto() in /home/comprepnl/domains/computer-reparateur.nl/public_html/manager/controllers/default/header.php on line 112

    Or is this related to PHP 5.3.29

    This question has been answered by franklos. See the first response.

    [ed. note: franklos last edited this post 10 years, 2 months ago.]
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Are you sure the update went smoothly? How did you upload the new version's files?
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 10076
        • 1,024 Posts
        Thanks Susan, I uploaded the zip over ftp, unzipped in cpanel.

        After noticing above error I deleted cache contents, etc. Guess I l download again and upload once more.
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          You can also try the install.php script, it downloads and moves the files into place for you. It's specifically intended for new installations, but it works for upgrades as well.

          https://github.com/sottwell/installer
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 9995
            • 1,613 Posts
            Maybe a silly answer, but did you actually run the installer?
            I once only updated the cms by uploading the new version with FTP, forgot to run the installer and got allkind of errors lipsrsealed
              Evolution user, I like the back-end speed and simplicity smiley
              • 36448
              • 58 Posts
              Or is this related to PHP 5.3.29


              maybe? as rtfm the server requirements is PHP 5.3.3 and above.
              sorry this was nonsense, you have a higher version

              btw: I updated my testpage MODX 2.4.2-pl to 2.5.0-rc1 with the installer from susan smiley
              After that I upgraded to PHP7 without problems. This is big speed improvement! [ed. note: krischel last edited this post 10 years, 7 months ago.]
              • discuss.answer
                • 10076
                • 1,024 Posts
                Finaly tackled above, related to this post:

                Thanks! This also worked for me. If you're not so familiar with the process:

                1. Go into phpmyadmin via CPanel
                2. Look for a table called modx_dashboard_widget in the MODX database (Alt: just search on 'modx_dashboard_widget' in the phpmyadmin search)
                3. Delete any big brother or google analytics entries.

                https://forums.modx.com/thread/79441/fatal-error-call-to-a-member-function-setnamespace-on-a-non-object-in-core-model-modx-moddashboardwidget-class-php-on-line-104