We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 21075
    • 24 Posts
    Okay, I managed to get rid of this error:

    [18-Jan-2016 20:24:25 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0

    by just commenting out that extension in my php.ini

    So there's just one error left. Whenever I try to load /manager, I find this in my error_log:

    9-Jan-2016 16:12:30 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
      • 3749
      • 24,544 Posts
      Paste the code from around line 43 in that file here.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 21075
        • 24 Posts
        Lines 37-44:

        $this->modx->lexicon->load('dashboard','topmenu','file');
        if ($action == 0) {
        $action = $this->modx->getObject('modAction',array(
        'namespace' => 'core',
        'controller' => 'welcome',
        ));
        $action = $action->get('id');
        }
        • discuss.answer
          • 3749
          • 24,544 Posts
          It's not finding the action with those fields (namespace and controller) in the modx_actions table.

          It kind of looks like your files may be for a different version of MODX than that of your database. Is there anything in your modx_actions table?
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 21075
            • 24 Posts
            Quote from: BobRay at Jan 19, 2016, 11:56 PM
            It's not finding the action with those fields (namespace and controller) in the modx_actions table.

            It kind of looks like your files may be for a different version of MODX than that of your database. Is there anything in your modx_actions table?

            Hmm... I don't know how there could be a mismatch between files and DB. If that were the case, would upgrading to a later version correct it?

            As to your question, yes, that table has 67 rows and the very first one has namespace "core" and controller "welcome."
              • 21075
              • 24 Posts
              Thank you, BobRay. turns out you were right. Since my attempt to upgrade had crashed the instant I hit the install button, I assumed the db hadn't been affected and never bothered restoring my original db backup when I restored my folder tree backup. Obviously, that was a dumb assumption. I restored both and everything is back to normal. And the original problem is fixed now too, since I got the http plugin installed.

              Your help is very much appreciated. You and everyone who commented with tips has my overwhelming thanks.
                • 3749
                • 24,544 Posts
                I'm glad you got it sorted. smiley
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting