We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 21075
    • 24 Posts
    Hello all-

    I have not used MODx much for a few years, but I am having trouble with a site I built back then, and I could really use some help. I hope I am not double posting. I have found others with similar questions, but none of the solutions in their threads have worked for me. Here's the situation:

    A client who regularly updates his site through the back end suddenly discovered that his resource tree was not appearing a couple days ago. The left hand sidebar would say "Web," and that's it. Since I couldn't immediately fix the problem, I figured the best thing to do was upgrade to the latest version of MODx and start from there.

    I made a backup, then uploaded the latest version of MODx as I used to do all the time when upgrading a website. I went to /setup, selected my language and everything, but then when I hit "Install," I received a 500 error. From then on, both the back end and the front end would return only 500 errors. I tried emptying the cache folder, and this had no effect, so I restored my backup. This also did nothing. I was still getting 500 errors.

    The site is on a Linux server through Bluehost, so I contacted support. They were able to restore a week-old automatic backup they had on their end, which had the effect of making the front end accessible again, but not the back end. I still get 500 errors when I try go to /manager.

    I have since discovered that, if I clear the session table in the database, the manager login will reappear, but as soon as I actually attempt to login, the 500 errors return, and remain until I clear the session table again.

    My php memory_limit is 128M. I would think that's plenty, right?

    Here are the contents of the error_log in the manager folder

    [15-Jan-2016 02:20:32 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 02:20:32 America/Denver] PHP Fatal error: Call to a member function get() on null in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 02:21:13 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 02:21:13 America/Denver] PHP Fatal error: Call to a member function get() on null in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 02:21:15 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 02:21:15 America/Denver] PHP Fatal error: Call to a member function get() on null in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 02:25:29 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 02:25:29 America/Denver] PHP Fatal error: Call to a member function get() on null in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 02:30:26 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 02:30:26 America/Denver] PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home4/mightywo/public_html/datsun-roadster-parts/core/model/smarty/Smarty_Compiler.class.php on line 270
    [15-Jan-2016 06:25:27 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 09:41:18 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 10:17:50 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 10:17:50 America/Denver] PHP Fatal error: Call to a member function get() on null in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 10:17:52 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 10:17:52 America/Denver] PHP Fatal error: Call to a member function get() on null in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 11:10:07 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/http.so' - /usr/php/56/usr/lib64/php/modules/http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    [15-Jan-2016 11:10:07 America/Denver] PHP Fatal error: Call to a member function get() on null in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 11:39:50 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 12:21:15 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 12:21:17 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 12:25:03 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 12:29:05 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 12:29:26 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 12:31:07 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 12:31:09 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 15:07:12 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 15:08:20 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 15:09:29 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43
    [15-Jan-2016 15:09:32 America/Denver] PHP Fatal error: Call to a member function get() on a non-object in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modmanagerresponse.class.php on line 43

    Can anyone help me figure out what is going on? I will owe you a cookie.

    This question has been answered by BobRay. See the first response.

      • 13226
      • 953 Posts
      You might want to take a look here, it might be a starting point
        • 21075
        • 24 Posts
        Quote from: iusemodx at Jan 15, 2016, 05:13 PM
        You might want to take a look here, it might be a starting point

        Thank you, I will take a look.
          • 21075
          • 24 Posts
          Thank you for the suggestion, lusemodx, but that is unfortunately not helping. Side note: I am running php 5.4. When I upgrade to 5.6, whether I set the timezone or not, I get the following error while loading the site:

          Fatal error: Undefined class constant 'MYSQL_ATTR_USE_BUFFERED_QUERY' in /home4/mightywo/public_html/datsun-roadster-parts/core/model/modx/modx.class.php on line 363
            • 3749
            • 24,544 Posts
            I know two of us have had trouble on Bluehost in the last couple days.

            I found these lines added to .htaccess:

            # Set PHP handler to application/x-httpd-phpbeta on Mon Jan 11 16:59:45 MST 2016.
            AddHandler application/x-httpd-phpbeta .php


            Setting the date/timezone settings for both MODX and PHP, and restoring an old .htaccess file fixed my problem.

            The two of us had different error messages than yours, though. Ours said "cannot find driver."

              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 21075
              • 24 Posts
              Quote from: BobRay at Jan 15, 2016, 05:48 PM
              I know two of us have had trouble on Bluehost in the last couple days.

              I found these lines added to .htaccess:

              # Set PHP handler to application/x-httpd-phpbeta on Mon Jan 11 16:59:45 MST 2016.
              AddHandler application/x-httpd-phpbeta .php


              Setting the date/timezone settings for both MODX and PHP, and restoring an old .htaccess file fixed my problem.

              The two of us had different error messages than yours, though. Ours said "cannot find driver."


              Thank you for that tip. Any idea how I can check/set the MODx timezone without access to the manager?
                • 30585
                • 833 Posts
                On the site's root folder (where MODX is intalled), create a phpinfo.php file and put this in it:
                <?php
                phpinfo();
                ?>
                

                Visit yoursite.com/phpinfo.php, and search for "date.timezone". It should tell you the current date.timezone setting.
                  A MODx Fanatic
                  • 28042 ☆ A M B ☆
                  • 24,524 Posts
                  Skip the closing ?> tags.
                  Files MUST use only <?php and <?= tags.

                  https://github.com/php-fig/fig-standards/blob/master/accepted/PSR-1-basic-coding-standard.md

                  Why are coding standards and common interfaces important to the PHP community? And more importantly, why are they important to the MODX community? Because MODX is a part of the PHP community and for far too long this project has chosen to create instead of adopt existing solutions for one reason or another. Some of those reasons may have been valid at the time, but to ignore the strides the PHP-FIG has achieved in solving the Not-Invented-Here culture prevalent in many PHP projects would almost guarantee irrelevance for the MODX project over the next few years.
                  https://medium.com/@drumshaman/keeping-modx-relevant-part-one-42dc6632f86b#.mdsyulkna
                    Studying MODX in the desert - http://sottwell.com
                    Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                    Join the Slack Community - http://modx.org
                    • 3749
                    • 24,544 Posts
                    Quote from: Neatoman at Jan 15, 2016, 11:36 PM
                    Quote from: BobRay at Jan 15, 2016, 05:48 PM

                    Thank you for that tip. Any idea how I can check/set the MODx timezone without access to the manager?

                    Yes, set the 'value' field of the date_timezone System Setting in the modx_system_settings table in the DB.
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                      • 21075
                      • 24 Posts
                      Quote from: BobRay at Jan 16, 2016, 12:11 PM
                      Quote from: Neatoman at Jan 15, 2016, 11:36 PM
                      Quote from: BobRay at Jan 15, 2016, 05:48 PM

                      Thank you for that tip. Any idea how I can check/set the MODx timezone without access to the manager?

                      Yes, set the 'value' field of the date_timezone System Setting in the modx_system_settings table in the DB.

                      The only relevant field I see in that table or any other is "server_offset_time." But if php is already set to the correct time zone (which it is), then that field should be 0, right?