We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3866 ☆ A M B ☆
    • 350 Posts
    I've done plenty of upgrades both locally and on live sites, I've taken back ups (after a bad experience wink ) and have been able to troubleshoot most problems either by Googling or checking out the Forums but this one has me truly scratching my head...

    I've upgraded a site from 2.2.14 to 2.3.1 and everything looks great I get the lovely new log in screen but when I log in I'm presented with an unstyled manager - and yes I've cleared the cache many times. There are not a whole load of extras running on the site so I'm completely at a loss to what next.

    Fortunately the front end is still functioning absolutely fine, its just the manager that is a bit of a mess!

    And so over to anyone who has had a similar experience and can provide a solution...

    If image shows the extras running on the site prior to upgrade and second shows what happens after I've run an upgrade.

    I can't access the logs via the manager and the only error within the manager error log for today showed:

    [06-Aug-2014 17:01:12 Europe/London] PHP Fatal error:  Class 'IndexManagerController' not found in /home/site/public_html/nodular/model/modx/modmanagerresponse.class.php on line 185



    This question has been answered by boomerang. See the first response.

      Helen Warner
      Number one pixel!
      Proud to be linked with MODX at Crimson Pixel
      • 3749
      • 24,544 Posts
      I'm assuming that you didn't use FTP to transfer the files individually, and that you ran setup after putting the files in place.

      The first thing to try is clearing your browser cache *and cookies*. A leftover cookie can cause all kinds of weirdness in the Manager.

      You've probably turned off the compress_js and compress_css System Settings. If not, try that.

      If none of that helps, take a look in the DB and see if the modx_context table has a 'name' column and whether there is a modx_extension_packages table. I've seen a couple reports where the DB did not get updated properly during setup.

        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 27106
        • 147 Posts
        By the way, try logging in using "incognito mode" in Chrome or "Private Window" in Firefox. I believe these both ignore the cache and cookies, so you may be able to at least access the manager this way while you work out the problem.
          David Walker
          Principal, Shorewalker DMS
          Phone: 03 8899 7790
          Mobile: 0407 133 020
          • 3866 ☆ A M B ☆
          • 350 Posts
          I had cleared all browser cookies and cache, and I had already tried the compress_js and compress_css but to no avail. Also tried the Private Window in Firefox but still same unstyled manager.

          Did run BobRay's Sitecheck (http://bobsguides.com/sitecheck-promo.html) and the only error real issue is the DB charset which is a bit mixed up!

          Mismatch between MODX character set and DB character set
          Database character set: latin1
          MODX Character Set: utf8
          Database character set: latin1


          I'm now trying to resolve this upgrade locally so did amend the config file to latin1 and re-run setup but still no joy.

          Attempted to run the convert to utf8 script http://bobsguides.com/convert-db-utf8.html but couldn't seem to get it to run.

          I have upgraded sites where the DB has a mixture of CharSets and this hasn't caused a problem - maybe till now!!

          I can also confirm that the tables BobRay suggested might not have been created are there - so it isn't that either.

          I have subsequently upgraded a couple of other sites I have running in exactly the same server environment and these have gone without a problem, so it would seem there is something running on this particular site which is causing the problem.

          I will keep digging and report back if I find a solution - any other suggests welcome!
            Helen Warner
            Number one pixel!
            Proud to be linked with MODX at Crimson Pixel
            • 3866 ☆ A M B ☆
            • 350 Posts
            Ok I vapored site into Cloud to see if that might help but the manager looks exactly the same - if you want to take a look PM me...

            UPDATE: On the cloud deployment if I click on Create Static Resource it does actually go to the correct page and displays correctly. Some parts of the site do display correctly - definitely not the dashboard or unfortunately the Error Log.

            [ed. note: boomerang last edited this post 12 years, 1 month ago.]
              Helen Warner
              Number one pixel!
              Proud to be linked with MODX at Crimson Pixel
              • 3866 ☆ A M B ☆
              • 350 Posts
              Ok still trying to resolve this - fortunately this client is patient and at the moment his site still works! I can access in the error logs via Firebug the following information:

              (ERROR @ /index.php) modTemplateVar: Attempt to set NOT NULL field type to NULL [2014-08-07 18:24:14] (ERROR @ /index.php) modTemplateVar: Attempt to set NOT NULL field type to NULL [2014-08-07 18:24:14] (ERROR @ /index.php) modTemplateVar: Attempt to set NOT NULL field type to NULL [2014-08-07 18:24:14] (ERROR @ /index.php) modTemplateVar: Attempt to set NOT NULL field type to NULL [2014-08-07 18:24:14] (ERROR @ /index.php) modTemplateVar: Attempt to set NOT NULL field type to NULL [2014-08-07 18:24:14] (ERROR @ /index.php) modTemplateVar: Attempt to set NOT NULL field type to NULL [2014-08-07 18:26:22] (ERROR @ /connectors/resource/index.php) Processor /home/site/public_html/core/model/modx/processors/gettoolbar.php does not exist; Array (     [action] => gettoolbar )  [2014-08-07 18:26:23] (ERROR @ /connectors/resource/index.php) Processor /home/site/public_html/core/model/modx/processors/getnodes.php does not exist; Array (     [action] => getnodes )  [2014-08-07 18:26:23] (ERROR @ /connectors/security/user.php) Processor /home/site/public_html/core/model/modx/processors/getrecentlyeditedresources.php does not exist; Array (     [action] => getrecentlyeditedresources )   


              Does this help anyone to suggest what might be going on?
                Helen Warner
                Number one pixel!
                Proud to be linked with MODX at Crimson Pixel
                • 3749
                • 24,544 Posts
                It's looking for this file: core/model/modx/processors/getrecentlyeditedresources.php

                That would probably hang the Manager when it tries to render the Dashboard, but I don't have that file in MODX 2.3.1 either.

                Check the processors path and connectors path and URL in core/config/config.inc.php. SiteCheck will pass them if the specified directory exists, but it could still point to the wrong directory.

                If that's not it, my guess would be that one or more files didn't get overwritten when you installed the 2.3.1 files.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 3866 ☆ A M B ☆
                  • 350 Posts
                  I've checked those paths Bob, and everything looks the same as the other sites I've upgraded which work just fine.

                  There is nothing very exciting about this site, it really is quite basic with no custom plugins or extras. I vapored it into MODX Cloud to see if that would work, but still the same problem, although strangely enough I was able to get to create static resource which rendered correctly, but as soon as I navigate to anywhere such as system/ or security/ it goes back to the same unstyled dashboard. It is most odd.

                  I have done a couple of re-runs of upgrading locally and I did get the following errors on one attempt - its a screen grab image, so see image below.
                    Helen Warner
                    Number one pixel!
                    Proud to be linked with MODX at Crimson Pixel
                    • 3749
                    • 24,544 Posts
                    I think those errors are just there because those columns already exist in the DB tables from the previous setup.

                    Installing it on Cloud was a great idea. It rules out a problem with the host or server. That brings us back to my idea that there are one or more missing, corrupted, or old files somewhere.

                    I would do the steps listed here: http://bobsguides.com/modx-upgrade-faq.html to retry upgrading the files.
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                      • 30672
                      • 180 Posts
                      Hi,

                      no idea what the problem is, but i would suggest to restore the production website and try to resolve the problem in the Cloud. Not cool to work under pressure (not yet but,...) smiley

                      good luck!