Thank you for getting back to me.
The issue was as soon as I logged in without clicking on anything. I could see only what was in the attached screen shot, and clicking any of the visible interface had no effect and triggered no errors in the log.
Friendly URL's were off, and I double checked in db to make that was the case still. I have renamed .htaccess at the root to ht.access (although this file was all commented out anyway), emptied the cache via ftp and in browser and tried again.
I have checked and rechecked these files many many times over! But not 100% sure on what the right information should be. I've attached the core/config file for you to see in case I'm doing something ridiculous! I've taken out the database stuff as I don't want to post that online, but obviously that's working as the front end is showing!
Line 63 which is
$http_host= array_key_exists('HTTP_HOST', $_SERVER) ? $_SERVER['HTTP_HOST'] : 'www.terasaki.se'; was actually not present in another working installation I have of modx although that's 2.2.0. So I have also tried with that line out, and originally it had the IP in so have tried with that and with the url.
Inline with my other installation I had defined MODX_CORE_PATH in both the manager/config.core.php and /config.core.php
define('MODX_CORE_PATH', dirname(dirname(__FILE__)) . '/core/'); Having looked at the help on this page
http://rtfm.modx.com/revolution/2.x/administering-your-site/moving-your-site-to-a-new-server as to what these settings should be, I changed these to
define('MODX_CORE_PATH', dirname(dirname(__FILE__)) . '/var/www/vhosts/terasaki.se/httpdocs/core/');
Weirdly now I am actually getting an error in the log and now getting the white screen and "Site is unavailable" message rather than no errors in the log and a contracted manager view after login. Not sure if this is a step back or a step forward!
I've attached the error log too. The fact the error log now shows double URLS makes me think that I was right the first time with the settings in manager/config.core.php and /config.core.php... but I still have a lot to learn so hoping you can advise me more on this!
My host is called ONYX, and it was working until we changed the URL from the testing one to the live on. If it could be server issues, how can I point ONYX in the right direction?