We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3749
    • 24,544 Posts
    Double-check all the paths and urls in the core/config.config.inc.php file.

    Check the path in the config.core.php files in the root, the manager directory, and the connectors directory.

    Make sure there is no .htaccess file (rename it if there is) and in PhpMyAdmin, make sure the use_friendly_urls System Setting (in the modx_system_settings table) is off (0). Then delete all files in the core/cache directory again before logging in.

    If none of that works, the only thing I can suggest is checking with your host to see if there's a problem with the server.
      Did I help you? Buy me a beer
      Get my Book: MODX:The Official Guide
      MODX info for everyone: http://bobsguides.com/modx.html
      My MODX Extras
      Bob's Guides is now hosted at A2 MODX Hosting
      • 19872
      • 1,078 Posts
      Who is the host? Do you have an error log from your server? What are those errors? More of the mod_fcgi type.

      Are the symptoms now such that parts of the manager load, but you can only click a few times before the screen goes blank? If yes, and you've followed all of Susan and Bob's pointers, do as Bob mentioned and talk to your host, but be specific. More than likely, they will tell your the server is functioning fine. Ask them to see if your IP is being blacklisted. In my case, I did 2 things a relatively the same time, so hard to tell what really was the fix. 1. I changed the ht.access file from the MODx upload to .htaccess, and 2. Had my host whitelist my IP.

        • 36977
        • 36 Posts
        Thank you for getting back to me.

        The issue was as soon as I logged in without clicking on anything. I could see only what was in the attached screen shot, and clicking any of the visible interface had no effect and triggered no errors in the log.

        Friendly URL's were off, and I double checked in db to make that was the case still. I have renamed .htaccess at the root to ht.access (although this file was all commented out anyway), emptied the cache via ftp and in browser and tried again.

        I have checked and rechecked these files many many times over! But not 100% sure on what the right information should be. I've attached the core/config file for you to see in case I'm doing something ridiculous! I've taken out the database stuff as I don't want to post that online, but obviously that's working as the front end is showing!

        Line 63 which is
        $http_host= array_key_exists('HTTP_HOST', $_SERVER) ? $_SERVER['HTTP_HOST'] : 'www.terasaki.se';  
        was actually not present in another working installation I have of modx although that's 2.2.0. So I have also tried with that line out, and originally it had the IP in so have tried with that and with the url.

        Inline with my other installation I had defined MODX_CORE_PATH in both the manager/config.core.php and /config.core.php
        define('MODX_CORE_PATH', dirname(dirname(__FILE__)) . '/core/');
        Having looked at the help on this page http://rtfm.modx.com/revolution/2.x/administering-your-site/moving-your-site-to-a-new-server as to what these settings should be, I changed these to
        define('MODX_CORE_PATH', dirname(dirname(__FILE__)) . '/var/www/vhosts/terasaki.se/httpdocs/core/');


        Weirdly now I am actually getting an error in the log and now getting the white screen and "Site is unavailable" message rather than no errors in the log and a contracted manager view after login. Not sure if this is a step back or a step forward!

        I've attached the error log too. The fact the error log now shows double URLS makes me think that I was right the first time with the settings in manager/config.core.php and /config.core.php... but I still have a lot to learn so hoping you can advise me more on this!

        My host is called ONYX, and it was working until we changed the URL from the testing one to the live on. If it could be server issues, how can I point ONYX in the right direction?
          • 3749
          • 24,544 Posts
          You might try SiteCheck. It will run outside of MODX, though not as conveniently as it does as a CMP. The PathCheck code does fairly extensive checks on the validity of all the paths and URLs in all the config files.

          http://bobsguides.com/sitecheck-promo.html
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 36977
            • 36 Posts
            Thanks for that! I've downloaded and ran it and this happens:

             Checking Encoding and Collation for all text columns
            Fatal error: Call to a member function fetch() on a non-object in /var/www/vhosts/terasaki.se/httpdocs/core/components/sitecheck/model/sitecheck/pathcheck.class.php on line 443 


            I'm not sure what this indicates?
              • 3749
              • 24,544 Posts
              Did you get all "OK" and "Success" messages up to that point?

              I assume you're running it outside of MODX.

              Try editing the sitecheck.snippet.php file and changing the settings section around line 54 to skip that particular test:

              Change:

              'checkCharset' => true,


              to

              'checkCharset' => false,




                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 36977
                • 36 Posts
                Quote from: BobRay at Aug 07, 2014, 03:16 PM
                Did you get all "OK" and "Success" messages up to that point?
                Yes
                Quote from: BobRay at Aug 07, 2014, 03:16 PM

                I assume you're running it outside of MODX.
                Yes, I placed all the files in the similaraily named folders within the modx installation and then browsed directly to *my url*/assets/components/sitecheck/index.php

                I've done as you advised and now I get some errors:

                2014-08-07 22:21:41] (WARN @ /assets/components/sitecheck/index.php)
                Could not load metadata map modx/mysql/modnamespace.map.inc.php for class modNameSpace from modx.mysql.modnamespace

                [2014-08-07 22:21:41] (WARN @ /var/www/vhosts/terasaki.se/httpdocs/core/xpdo/om/xpdoobject.class.php : 1060)
                PHP notice: unserialize(): Error at offset 15336 of 16534 bytes

                Under the heading: Resources with duplicate alias in same context.

                Here is the final summary:

                Final Audit
                Total Configuration Errors: 0
                Total Permission Errors: 0
                No Charset checks Performed
                Total DateTime Errors: 0
                Total Workspace Errors: 0
                Total Transport Package Errors: 0
                Total Resource Errors: 16
                Total Element Errors: 0
                Total Intersect Errors: 0
                Total Tests Performed: 952
                Total Errors found: 16


                  • 3749
                  • 24,544 Posts
                  Looking back over this thread, I don't see any recommendation to turn off the compress_js and compress_css System Settings in the modx_system_settings table in the DB (change the 1 to a 0). Then clear your browser cache *and cookies$ (or use an incognito window in Chrome or a private window in Firefox). Then delete the files in the core/cache directory again before checking the Manager. Try all that first.

                  I think the the two warnings in SiteCheck are trivial.

                  I was mainly thinking about the check of the configuration files and workspace, which you say are fine. You can eliminate them as the source of the problem, unless there is any chance that SiteCheck could find things in the previous location of the site (unlikely).

                  Going into PhpMyAdmin and repairing all tables is worth a try.

                  My next step would be to turn on Dev. Tools in Chrome (Ctrl-Shift-I) and watch the Network tab as you try to access the Manager. You can see if there are any missing files (no 200 response) or JavaScript errors. You can also drill down to see the actual processor responses if necessary.
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 36977
                    • 36 Posts
                    Quote from: BobRay at Aug 07, 2014, 03:57 PM
                    Looking back over this thread, I don't see any recommendation to turn off the compress_js and compress_css System Settings in the modx_system_settings table in the DB (change the 1 to a 0). Then clear your browser cache *and cookies$ (or use an incognito window in Chrome or a private window in Firefox). Then delete the files in the core/cache directory again before checking the Manager. Try all that first.
                    I've done all those thing.

                    Quote from: BobRay at Aug 07, 2014, 03:57 PM
                    Going into PhpMyAdmin and repairing all tables is worth a try.
                    I've done that now, cleared caches, retried.

                    I ran Dev tools Network monitor and got nothing.

                    I've changed back the settings which I had changed in all the config files so that I at least get to the login stage, and ran dev tools network monitor again.

                    This time I get a 404 for the following file:
                    /terasaki.se/httpdocs/assets/components/articles/css/mgr.css. I've checked and there is a file there so I wonder if that's corrupt somehow?

                    And a 401 for this: lang.js.php?ctx=mgr&topic=topmenu,file,resource,welcome,configcheck&action=
                    /connectors

                    I tried site checked again after changing the config back to the way it was so that I at least could get to the log in screen and this time got lots of errors:

                    Checking settings in MODX_CONNECTORS_PATH config.core.php
                    MODX_CORE_PATH in config.core.php does not match path in /core/config/config.inc.php
                    config.inc.php setting: /core/
                    config.core.php setting: /var/www/vhosts/terasaki.se/httpdocs/core/
                    ________________________________________________________________
                    
                    Checking settings in MODX_MANAGER_PATH config.core.php
                    
                    -- 
                    
                    OK!
                    ______________________________________________________________________
                    
                    Checking File and Directory Permissions
                    Checking MODX_CORE_PATH/cache/ for write permission
                    /core/cache/ does not exist
                    Checking MODX_CORE_PATH/packages/ for write permission
                    /core/packages/ does not exist
                    Checking MODX_CORE_PATH/import/ for write permission
                    /core/import/ does not exist
                    Checking MODX_CORE_PATH/export/ for write permission
                    /core/export/ does not exist
                    Checking MODX_CORE_PATH/components/ for write permission
                    /core/components/ does not exist
                    Checking main config file for write permission
                    /core/config/config.inc.php does not exist
                    Checking MODX_ASSETS_PATH/ for write permission
                    
                    -- 
                    
                    OK!
                    ______________________________________________________________________
                    
                    /core/config/config.inc.php file does not exist (normal before setup)
                    Ending SiteCheck
                      • 3749
                      • 24,544 Posts
                      I would hard-code this whole path in the MODX_CORE_PATH definition in config.inc.php:

                      core/model/modx/processors/getrecentlyeditedresources.php

                      Check the permissions and ownership on the mgr.css file in the 401 error above.
                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting