-
☆ A M B ☆
- 237 Posts
I spoke with support yesterday. They of course said they don't know anything about ModX and asked me to turn off all of the plugins, etc. to trouble shoot. They also turned on the error logs in their control panel for us to look at today to see what is going on. But, they didn't feel it could possibly be their servers and pretty much acted as if I must have something messed up in my ModX install. I actually installed ModX from their control panel. It was version 2.2.8 and then I just updated to 2.2.14 myself. So, I really didn't install it.
I'm thinking a move is probably in order. Just have to let the client know what's going on. I'm going to call back today to see what the logs reveal.
Thanks for everyone who chimed in.
Mike
After 45 minutes on the phone to support, they claim that they couldn't reproduce the issue and that it was likely to be my router.
I ran a traceroute that was fine when then site was up, but timed out before reaching their servers when down, but then picked it up again. However, my manager wouldn't load in this time. When I came back up, it promptly fell over again when loading the page.
Having reset my router and simultaneously browsing my site from my mobile provider I can confirm that it's not my router. It has to be something their end. This is really annoying me now as I don't want to waste more time calling them for the same BS. I think it's time to move too.
Problem now is how to backup my latest site as I can't flush permissions for a clean sweep to move it.
Of all the things it could be, I'm surprised they suggested your router since it is just about the last thing that could cause you an error like this.
-
☆ A M B ☆
- 2,213 Posts
@mdsdesign - Thanks for reporting back. I'm not surprised they are blaming MODX despite providing the installer. It's hosting support 101 to blame the clients script, as servers clearly never break. Let us know if you have any problems moving your sites.
@Randomio - That error is screaming server configuration problem to me. If you would like I can offer you a trial of our hosting, give your site a try. If the issue persists it's related to your site, otherwise it's related to their hosting having issues.
-
☆ A M B ☆
- 237 Posts
Just one more quick update on this.
I spent a good deal of time on the phone with GoDaddy support yesterday. They claimed that they had an A Record that was misconfigured. They said they fixed it and in an hour or so, all would be fine.
Well, it's the next day and the same exact thing is happening. So, I guess it wasn't the A Record. Time to move this site.
-
☆ A M B ☆
- 2,213 Posts
@Randomio - If you signup for our starter hosting plan (
https://my.skytoaster.com/cart.php?a=add&pid=18¤cy=1) and send me a PM with the domain name I will be more than happy to activate the trial for you. In regards to the routing, do you mean selecting the location the site will be hosted? That's part of the hosting signup process, you chose from one of our locations and the site is setup in that location. Routing beyond that is based on the peering providers for the datacenter and varies, but all locations have global routing. Selecting Seattle for example does not limit your sites accessibility to the US for example.
@mdsdesign - I'm sorry to hear GoDaddy wasn't able to resolve your problems. I find it very hard to believe an A record would be the cause of the problem. It sounds related to their hosting environment. If you need any help with the hosting please feel free to ask, we are more than happy to help.
I am in a similar situation with goDaddy, to now trying to pencil in time to migrate to another host.
Having recently cleared out all remnants of the Core Services Hack, my manager is still wacky. In discussions with goDaddy, they did not so much as say my IP as being blacklisted, but inferred it. Supposedly my site is being reviewed by higher level tech support. They could not understand why I might try to access the manager 30 times in less than a minute. My response was that I was clicking around trying to replicate issues and testing to see what was working and what wasn't.
My hunch is that something has changed at goDaddy, or they have a problem that I hope they are trying to resolve.
When working in my manager on my site, certain aspects of the backend are not visible—chunk list shows, but template variables don't. All random in occurrence of what shows up and what doesn't. Eventually the manager will not load at all—blank page only, and I've found that waiting a couple of minutes allows something process to cycle through and I'm able to log back in – though I am still already logged in to the manager. In worst case scenarios, manually deleting contents of core/cache allows me to get back in to the manager, but the manager is still all messed up.
My MODx error log initially had multiple errors such as yours, but has since been reduced to two that consistently reappear.
[2014-07-24 19:44:34] (ERROR @ /connectors/lang.js.php) Error caching action map mgr/actions
[2014-07-24 19:44:34] (ERROR @ /connectors/modx.config.js.php) Error caching lexicon topic lexicon/en/core/resource