We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 18961 ☆ A M B ☆
    • 237 Posts
    Hi,

    I'm having an issue when working on a site that has ModX Revo 2.2.14 installed. Every few minutes when I'm working in the manager, if I try to save something I get the following:

    The connection was reset

    The connection to the server was reset while the page was loading.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer's network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

    This is on GoDaddy hosting and I'm not sure what to do. It's a client's site and I'm waiting to talk to them so I can call GoDaddy support. The site was running fine a month ago so I'm guessing there was some kind of server upgrade or this site is hacked. I'm not even sure where to look to find out if it's hacked on not. This problem also causes problems on the front end as well.

    Any help would be appreciated.

    Thanks.
      Michael Smull
      http://www.bigpixelstudio.com
      twitter: @mdsdesign
      • 18961 ☆ A M B ☆
      • 237 Posts
      Here are the error logs from ModX:

      [2014-06-12 19:48:20] (ERROR @ /connectors/layout/modx.config.js.php) Error caching lexicon topic lexicon/en/core/resource
      [2014-06-13 11:00:16] (ERROR @ /manager/index.php) Error caching lexicon topic lexicon/en/core/topmenu
      [2014-06-13 11:00:16] (ERROR @ /manager/index.php) Error caching lexicon topic lexicon/en/core/file
      [2014-06-13 11:00:19] (ERROR @ /manager/index.php) Error caching lexicon topic lexicon/en/core/chunk
      [2014-06-13 11:00:20] (ERROR @ /manager/index.php) Error caching lexicon topic lexicon/en/core/category
      [2014-06-13 11:00:21] (ERROR @ /manager/index.php) Error caching lexicon topic lexicon/en/core/propertyset
      [2014-06-13 11:00:22] (ERROR @ /manager/index.php) Error caching script elements/modplugin/1
      [2014-06-13 11:35:04] (ERROR @ /connectors/layout/modx.config.js.php) Error caching lexicon topic lexicon/en/core/resource
      [2014-07-22 17:47:11] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/sisea/properties
      [2014-07-22 17:47:11] (ERROR @ /index.php) Error caching script elements/modsnippet/4
      [2014-07-22 17:49:31] (ERROR @ /connectors/layout/modx.config.js.php) Error caching lexicon topic lexicon/en/core/resource
      [2014-07-23 06:14:17] (ERROR @ /connectors/lang.js.php) Error caching lexicon topic lexicon/en/core/resource
        Michael Smull
        http://www.bigpixelstudio.com
        twitter: @mdsdesign
        • 18961 ☆ A M B ☆
        • 237 Posts
        A lot of views.... no replies.

        I was hoping this wasn't something huge. Any thoughts would be appreciated.
          Michael Smull
          http://www.bigpixelstudio.com
          twitter: @mdsdesign
          • 33988
          • 110 Posts
          I've been trying to come up with a good reply to this without much luck. All I can say is that I have tried to get MODX working on GoDaddy without much luck and have encountered many others who have had issues. That being said, it can be done, just not easily.

          Things you could do:
          -You could check your cache directory's folder permissions, they should be 755.
          -Try upgrading to 2.2.15. You never know if something was fixed that helps this specific case. It also has the added benefit of overwriting your existing MODX files, one of which may have become corrupted.
          -You could ask GoDaddy about your server's stability. The error message you posted makes me wonder if the server is having issues and is overloaded.
          -Have someone look into it. We (SkyToaster) could help by logging in and investigating further.

          Hope this helps!
            Sal Sodano
            President & Co-Founder of SkyToaster
            My Website Salscode.
            • 18961 ☆ A M B ☆
            • 237 Posts
            Thanks for you help. I guess I have work to do. I typically won't use godaddy hosting, but this is a client site and that's where they were setup. If I can't make it work, I'll be moving it.

            I'll try your suggestions and see if anyone else has any thoughts.
              Michael Smull
              http://www.bigpixelstudio.com
              twitter: @mdsdesign
              • 33988
              • 110 Posts
              Well if you do end up moving it, please consider us for hosting. We offer free migration and because you are an Ambassador, you will receive $6/mo off for life. https://skytoaster.com/blog/2014/modx-ambassador-appreciation/

              Good luck with correcting the error.
                Sal Sodano
                President & Co-Founder of SkyToaster
                My Website Salscode.
                • 1343 ☆ A M B ☆
                • 2,213 Posts
                There are two main causes I generally see associated with the error message in question. The first is simply Apache having been restarted, which shouldn't occur all that often. The second is Apache running out of available connections, which is generally caused by a misconfigured or overloaded server.

                In short I am fairly certain the problem is related to your hosting environment. That being said you did note your hosting environment is everyone's favorite choice for this (among other) exact reason. You should talk with their support as they might be able to resolve the problem, but for your long term sanity I would suggest moving the site to a more MODX friendly host.

                If you are looking for a cost effective hosting option, as Sal pointed out above we are offering Ambassadors some free hosting. If you want a low cost option to test the site (confirm it's hosting related), feel free to take advantage of that offer. If you do go that route and the problem persists let us know, as I am more than happy to help you troubleshoot it further. It's much easier in a known MODX friendly environment, especially when the support has full access to the server and understands MODX wink
                  Patrick | Server Wrangler
                  About Me: Website | Tweets |  MODX Hosting
                  • 43957
                  • 79 Posts
                  I think this is an issue with Godaddy.

                  I've had my site hosted with them for nearly 3 years and had minimal problems until recently. Tonight I can't even load the manager without the connection being reset.

                  Think it's time to take it up with Godaddy Support......
                    • 43957
                    • 79 Posts
                    Quote from: dave-b at Jul 24, 2014, 02:53 PM
                    I think this is an issue with Godaddy.

                    I've had my site hosted with them for nearly 3 years and had minimal problems until recently. Tonight I can't even load the manager without the connection being reset.

                    Think it's time to take it up with Godaddy Support......

                    I've just discovered that it looks like I can't just "raise a ticket" any more and have to phone... is this for real?????
                      • 33988
                      • 110 Posts
                      Quote from: dave-b at Jul 24, 2014, 03:06 PM
                      I've just discovered that it looks like I can't just "raise a ticket" any more and have to phone... is this for real?????

                      Let us know what they say.
                        Sal Sodano
                        President & Co-Founder of SkyToaster
                        My Website Salscode.