We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28042 ☆ A M B ☆
    • 24,524 Posts
    That's just a standard UNIX file listing (ls -l command). Like you thought, it's probably something from GoDaddy's work.

      Studying MODX in the desert - http://sottwell.com
      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
      Join the Slack Community - http://modx.org
      • 19872
      • 1,078 Posts
      Good to know. So at this point, not sure how best to proceed. Whether to try and fix, or scrap and do a complete rebuild from the ground up.

      MODx error log seems to consistently now only display these errors:
      [2014-07-22 10:59:19] (ERROR @ /connectors/modx.config.js.php) Error caching action map mgr/actions
      [2014-07-22 10:59:20] (ERROR @ /connectors/modx.config.js.php) Error caching lexicon topic lexicon/en/core/resource

      goDaddy Error log is showing many errors like these:
      [Mon Jul 21 21:01:56 2014] [#######] [negotiation:error] [client ##.###.##.###:#####] AH00687: Negotiation: discovered file(s) matching request: /var/chroot/home/content/##/#######/html/beachhouse/index.php (None could be negotiated)., referer http://www.mydomain.com/
      [Mon Jul 21 21:02:04 2014] [#######] [negotiation:error] [client ##.###.##.###:#####] AH00687: Negotiation: discovered file(s) matching request: /var/chroot/home/content/##/#######/html/domain/index.php (None could be negotiated)., referer http://www.mydomain.com/
      [Tue Jul 22 03:01:52 2014] [#######] [fcgid:warn] (9)Bad file descriptor: [client 207.191.219.83:43866] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer http://www.mydomain.com/manager/?a=system/event
      [Tue Jul 22 03:01:52 2014] [#######] [fcgid:warn] (9)Bad file descriptor: [client ##.###.##.###:#####] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer http://www.mydomain.com/manager/?a=system/event
      [Tue Jul 22 03:01:54 2014] [#######] [fcgid:warn] (9)Bad file descriptor: [client ##.###.##.###:#####] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer http://www.mydomain.com/manager/?a=system/event
      [Tue Jul 22 03:01:55 2014] [#######] [fcgid:warn] (9)Bad file descriptor: [client ##.###.##.###:#####] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer http://www.mydomain.com/manager/?a=system/event
      [Tue Jul 22 03:01:59 2014] [#######] [fcgid:warn] (9)Bad file descriptor: [client ##.###.##.###:#####] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer http://www.mydomain.com/manager/?a=system/event
        • 19872
        • 1,078 Posts
        Bob & Susan:

        You were both extremely helpful last night assisting me with the removal of the core service hack. I've very grateful for your assistance.

        The manager is still not working quite right. Various elements are either not available or available only for a brief time. Eventually, clicking around enough in the manager results in a white screen, and then the site won’t load on the front end.

        The only way to resolve is to manually delete the core/cache. I’m unable to delete the cache from within the manager.

        Essentially, the site seems to run fine on the front end, but I can’t reliably develop content from within the MODx manager.

        The error log now seems to consistently return these two errors.

        [2014-07-22 10:59:19] (ERROR @ /connectors/modx.config.js.php) Error caching action map mgr/actions
        [2014-07-22 10:59:20] (ERROR @ /connectors/modx.config.js.php) Error caching lexicon topic lexicon/en/core/resource

        Would the fact that even the goDaddy file manager seems to have trouble loading have anything to do with this issue—meaning that maybe I’m now struggling not with core services hack issue, but rather goDaddy server issues?
          • 3749
          • 24,544 Posts
          I've seen lots of problem reports from people with MODX sites on GoDaddy.

          http://bobsguides.com/modx-friendly-hosts.html wink

          Something is clearly corrupting your cache. I doubt if it is the hack, but it might be. I think it's likely related to the error in caching the action map. I suspect that it's writing a partial version of the action map, which is then crashing MODX the next time it's accessed. If the front-end continues to work, that would support this theory.

          If that's the case, you could just delete the action map file instead of the whole core/cache directory. A utility snippet could do that for you from inside the Manager.

          You might also take a look at the ClearCache extra, which does delete all files in the core/cache directory from the Manager.

          All that said, what I would probably do in your situation is to install a fresh version of 2.3 on a MODX-friendly host, install the extras you need through Package Manager, and migrate the users and content to it (but not any files except ones you're sure are yours and are uninfected).

            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 19872
            • 1,078 Posts
            Thanks Bob. I think migrating might be the only thing to do at this point.

            I'll try clearing the cache from within the manager, and then maybe running the setup again, and see what happens.

            Thanks for all of your feedback and guidance.
              • 19872
              • 1,078 Posts
              So the clear cache model has been sitting there for about 10 minutes stating "console running..."

              Finally got tired of waiting and clicked download output, which is: /*
              * MODX Console Output
              *
              * @date 2014-07-22 17:43:30
              */

              /* EOF */

              I think it might be time to migrate off this server. Will have to wait until the weekend though. I appreciate your help. Definitely learned a lot.
                • 19872
                • 1,078 Posts
                Actually just navigated back into the manager and ran clear cache again and this time it ripped right through it.

                /*
                * MODX Console Output
                *
                * @date 2014-07-22 17:46:22
                */
                Processing automatic publishing dates

                -> 0 documents were published.

                -> 0 documents were unpublished.

                Regenerating system settings cache: Refresh successful!

                Regenerating the context caches

                -> mgr: Refresh successful!

                -> web: Refresh successful!

                refresh_media_sources: Refresh successful!

                Clearing the lexicon topics cache: Refresh successful!

                Clearing the Snippet/Plugin script cache: Refresh successful!


                /* EOF */
                  • 19872
                  • 1,078 Posts
                  Still no go though. Files and resources are not listed in the tree. An cannot get the error log to display.

                  At this point, if I move the site, I'm concerned that I will just be bringing along the baggage of this corrupted site.
                    • 19872
                    • 1,078 Posts
                    Final got the error report to load. Now there is a completely new error.

                    [2014-07-22 15:46:57] (ERROR @ /manager/index.php) Error 23000 executing statement:
                    INSERT INTO `modx_session` (`id`, `access`, `data`) VALUES ('0c3a68df00d379df1e131361384b18aa', 1406069217, 'modx.user.contextTokens|a:1:{s:3:\"mgr\";i:1;}modx.mgr.user.token|s:52:\"modx53ce175c2baf60.38935681_153cee555119089.72203523\";modx.mgr.session.cookie.lifetime|i:0;modx.mgr.user.config|a:0:{}')
                    Array
                    (
                    [0] => 23000
                      • 19872
                      • 1,078 Posts
                      I actually didn't copy the entire piece.

                      [2014-07-22 15:46:57] (ERROR @ /manager/index.php) Error 23000 executing statement:
                      INSERT INTO `modx_session` (`id`, `access`, `data`) VALUES ('0c3a68df00d379df1e131361384b18aa', 1406069217, 'modx.user.contextTokens|a:1:{s:3:\"mgr\";i:1;}modx.mgr.user.token|s:52:\"modx53ce175c2baf60.38935681_153cee555119089.72203523\";modx.mgr.session.cookie.lifetime|i:0;modx.mgr.user.config|a:0:{}')
                      Array
                      (
                      [0] => 23000
                      [1] => 1062
                      [2] => Duplicate entry '0c3a68df00d379df1e131361384b18aa' for key 1
                      )