My guess is, they hacked, the saw there was nothing to grab, and they left a mess in their wake.
I am hoping that my other MODx sites are OK as well. As a result of your help, I'll know more of what I'm looking for.
Well... something is still off. I started clicking various items in the Elements tree and then get the blank screen.
Let me see if I can get back in and access the error log.
These errors were as of midnight, so no new errors is good?
[2014-07-22 00:01:08] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href=’function.get-headers’>function.get-headers</a>]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0
[2014-07-22 00:01:08] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href=’function.get-headers’>function.get-headers</a>]: This function may only be used against URLs
[2014-07-22 00:01:23] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href=’function.get-headers’>function.get-headers</a>]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0
[2014-07-22 00:01:23] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href=’function.get-headers’>function.get-headers</a>]: This function may only be used against URLs
[2014-07-22 00:01:24] (ERROR @ /connectors/index.php) Error caching lexicon topic lexicon/en/core/namespace
[2014-07-22 00:07:49] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href=’function.get-headers’>function.get-headers</a>]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0
[2014-07-22 00:07:49] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href=’function.get-headers’>function.get-headers</a>]: This function may only be used against URLs
I cleared the error log. Went and clicked on Elements, then began to toggle open my chunks, tvs, etc, and no files are listed. My templates are listed, and the snippets and plugins. Then going back to the error report log results in a blank white screen.
-
☆ A M B ☆
- 24,524 Posts
No, MODX has its own PHP-based file manager. See /core/model/modx/modfilehandler.class.php. It depends on the PHP user being able to read and execute directories, read files, and possibly write directories and files.
When a server is running with some kind of su_exec (user is switched to the file's owner) then permissions usually aren't a problem. Otherwise, the PHP/webserver user has to have read and execute for folders and read for files just to view them, and write permissions to edit, create or delete files. That's what's referred to a "world-writable", and isn't a desirable situation. Before using a hosting company, I make sure they use some kind of su_exec so it doesn't have to have any world-writable folders or files.
These are new errors. More of the same.
[2014-07-22 00:09:56] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href=’function.get-headers’>function.get-headers</a>]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0
[2014-07-22 00:09:56] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href=’function.get-headers’>function.get-headers</a>]: This function may only be used against URLs
[2014-07-22 00:22:19] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href=’function.get-headers’>function.get-headers</a>]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0
[2014-07-22 00:22:19] (ERROR @ /path/to/folder/manager/controllers/default/header.php : 115) PHP warning: get_headers() [<a href=’function.get-headers’>function.get-headers</a>]: This function may only be used against URLs
-
☆ A M B ☆
- 24,524 Posts
Well, as long as you can backup your database using something like phpMyAdmin, all is not lost. Install fresh, install all of the add-ons you had, then import the database backup. Wouldn't hurt to run setup again in upgrade mode after clearing the entire core/cach/ directory. Also clear your browser cache and cookies.
Yes, try running Setup first before you start re-building everything.