Does anyone know of any conflicts with PHP 5.4.18 and eForm? None of my contact forms are working since the upgrade. No errors, just the email not being sent. I'm not getting any system errors or errors on the server logs. Just forms not working.
I upgraded a couple months ago, but finally realized today what was happening when someone called me and said they submitted the contact form twice yesterday, but got no response. Now I wonder how many people actually have done the same thing without response. This problem is happening across several of my sites on this server.
By the way, these are all Evo sites.
What PHP/MODX/eForm version [did]/[do you have] [when it]/[when it doesn't] work!?
[#9398] eForm & php 5.3
[#9545] PHP 5.4 compatibility
[#10097] htmlspecialchars in >PHP 5.4 no longer defaults to ISO-8859-1
https://github.com/modxcms/evolution/blob/bugfix/install/changelog.txt
Check your server log and MODX system events log after filling in a form
use the debug --> &debug=`1`
Wow, I wasn't even aware of this plugin! Nice -->
https://forums.modx.com/thread/87414/what-is-filesource
I would try:
- Disable the plugin: FileSource
- Make sure file permission in /assets/ are OK: Folders(755) Files(644)
- Under System configuration > Detection level of the PHP error choose: Ignore the warning of a slight notice level(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT)
...
References:
PHP 5.4 discussion _before_ EVO109 around EVO107
https://forums.modx.com/thread/?thread=80990&page=1
AS of EVO109 PHP 5.4 was supported
https://forums.modx.com/thread/83263/modx-evolution-1-0-9-is-now-available#dis-post-459337
I take it you had < MODX107. The upgrade from 107 to 1013 is drastic!!
A lot of deprecated functions, snippet parameters and code changes to consider.
Do you have a local server?
https://forums.modx.com/thread/19374/uploading-web-pages-to-my-host#dis-post-107426
So, there's something else going on now. I can't even edit any pages. I just get this error:
Fatal error: Call to undefined function mm_galleryLink() in /home/website/public_html/assets/plugins/managermanager/mm.inc.php(178) : eval()'d code on line 17
Do you have a backup of the site before you upgraded?
I upgraded from 1.0.12
The changes weren't that drastic from 1.0.12 > 1.0.13 were they? I have an old backup. Unfortunately, this site was only backed up occasionally. I have an old back up from 6 months ago, but that was 1.0.9 or something back then. Plus, A lot has changed since. I can back up the content now and do a reinstall I guess. Not the funnest thing, but I can try that.
I take it you upgraded using the installer with everything checked = You have overwritten old code = You need to go through your MODX snippets, tplchunks and your ManagerManager chunk rules. It's still possible to save this install just not fun if you are on a live server.
I would reinstate what was (where only eform was broken) and do this locally.
// RELATED THREAD
https://forums.modx.com/thread/90787/where-to-download-the-bugfixed-1-0-13
[ed. note: mrhaw last edited this post 12 years, 4 months ago.]