New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Hello folks,

    Currently running Evolution v1.0.10 at eessc.org with PHP 5.3 (hosted by Fatcow). Built the site on a GoDaddy server, with same version of Evolution, which ran without issue. One the site was fully developed, I installed MODx on the Fatcow server without issue. The site ran, but crashed after about seven hours of uptime and displayed an Internal Server Error (visible at eessc.org/index.php).

    Because of this, and after referencing here: (http://forums.modx.com/thread/36031/step-by-step-instructions-for-installing-0-9-6-3-with-fatcow-com-as-the-host), I reinstalled MODx, but using the latin1_swedish_ci collation, then rebuilt the site. This worked, but this time the site crashed again after about six days and began displaying the same error mentioned above, seen at eessc.org/index.php

    The PHP error log seems to display the following three entries most frequently:

    20140430T202309: eessc.org/manager/processors/login.processor.php
    PHP Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in /hermes/waloraweb026/b2407/moo.eessc/manager/includes/settings.inc.php on line 10
    PHP Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /hermes/waloraweb026/b2407/moo.eessc/manager/includes/settings.inc.php on line 11

    and

    20140430T210544: eessc.org/index.php
    <b>Security Alert!</b> The PHP CGI cannot be accessed directly.

    <p>This PHP CGI binary was compiled with force-cgi-redirect enabled. This
    means that a page will only be served up if the REDIRECT_STATUS CGI variable is
    set, e.g. via an Apache Action directive.</p>
    <p>For more information as to <i>why</i> this behaviour exists, see the <a href="http://php.net/security.cgi-bin">manual page for CGI security</a>.</p>
    <p>For more information about changing this behaviour or re-enabling this webserver,
    consult t (cutoff from this point on)

    and

    20140501T142608: www.eessc.org/index.php
    PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(/var/php_sessions/sess_09bc233e5e9e375dd7fadcb070655790, O_RDWR) failed: No such file or directory (2) in /hermes/waloraweb026/b2407/moo.eessc/manager/includes/config.inc.php on line 62


    Server configuration is as follows:
    CGI Active
    FrontPage Extensions No
    Logs http:////www.fatcow.com/controlpanel/LogFiles.bml
    Platform Type Debian
    MySQL Version 5.0.91-log
    Perl Version 5.8.8
    PHP Version 5.3


    Although I will be opening a support ticket on their website, Fatcow's technical support team does not appear to be well versed in PHP scripting. Thus, I am hoping someone here might be able to advise me as to the best course of action.

    Thanks everyone for your time and assistance.

    Ryan Gallant

    This question has been answered by AMDbuilder. See the first response.

    [ed. note: gallantr94 last edited this post 4 years, 9 months ago.]
    • After making an adjustment to /manager/includes/config.inc.php I was able to get most of the site back up without issue, with all content intact. The issue was that line 11 had somehow referenced a non-existent database (potentially a type-o on my part). With that fixed, the only issue remaining (to my knowledge) is that when attempting to login to the manager, even with correct credentials, the following errors appear as a popup when clicking the "Login" button:

      Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in /hermes/waloraweb026/b2407/moo.eessc/manager/includes/settings.inc.php on line 10

      Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in /hermes/waloraweb026/b2407/moo.eessc/manager/includes/settings.inc.php on line 11

      Warning: mysql_num_rows() expects parameter 1 to be resource, boolean given in /hermes/waloraweb026/b2407/moo.eessc/manager/processors/login.processor.php on line 71
      Incorrect username or password entered!
      • discuss.answer
        Hello Ryan,

        It sounds like there are several server issues that may be causing your problem. The first issue would be the unsupported MySQL version (http://rtfm.modx.com/revolution/2.x/getting-started/server-requirements/mysql-5.0.51-issues), which your host is unlikely to change without an extended notice. The second it sounds like the php configuration is less than ideal, as evident by the error in question.

        The installation post in question is over five years old now, and server configurations do change over time. It's highly possible some of the changes made since that post have broken or at least limited support for systems such as MODX.

        My recommendation would be to first upgrade your install to 1.0.13, ensuring the issues haven't since been corrected. The next action would be contacting your host and ask if you can be moved to a server with a newer MySQL version installed. If they are unable or unwilling to move your site to a server with a newer MODX version then switching hosts is likely your best option.

        You can find a list of MODX friendly hosts here: http://bobsguides.com/modx-friendly-hosts.html or http://modx.com/services/

        I do know MODX Evolution and Revolution are fully supported (server configuration & support staff) with SkyToaster.
          Patrick | Server Wrangler
          About Me: Website | TweetsMODX Hosting
        • Thanks AMD, appreciate the response!