On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I always create step-by-step instructions for installs as I frequently reinstall stuff and I can’t remember what I did before. I use fatcow.com and have been happy with them. There are apparently some steps unique to their site to get MODx installed. Please point any places where I screwed up or could have done better.

    * Sign into fatcow.com
    * Go to the Control Panel
    * Click on "CGI and Scripted Language Support"
    * Click on "PHP Scripting"
    * Set the default PHP version to "PHP 5"
    * Edit the php.ini file
    * On the fatcow page, find the path to your Web document root
    * Add to the php.ini file a line session.save_path = "xxxx/cgi-bin/tmp" where "xxxx" is the path to your Web document root
    * Save the php.ini file
    * Download the latest version of MODx to your PC
    * Using filezilla or some other ftp program, ftp the zip file to your home directory
    * Go to the fatcow control panel
    * Click on "Archive Gateway"
    * Select the modx zip file and click "Extract/Uncompress"
    * Go back to Filezilla
    * Drag the files and directory created in the "modx-x.x.x.x" directory to your root directory
    * Set the permissions as covered in the MODx install page
    * Go to the fatcow control panel
    * Click on "Manage MySQL"
    * Add a new database. Example values in the "Add New Database" box are "mydb" for Database Name, "mememe" for "Database Login", "mypass" for Password
    * Go to http://yourwebsite.com/install/index.php
    * Click "Next" to select English as the language
    * Click "Begin"
    * Check the "I agree to the terms set out in this license" box and click "Next"
    * Check "New Installation" and click "Next"
    * Go back to the fatcow control panel and click on "Manage MySQL"
    * You will see on the page "Database is on xxxxxx.fatcowmysql.com "
    * For the database host, put the "xxxxxx.fatcowmysql.com" from above
    * For the database login name, put your equivalent of "mememe"
    * For the database password, put your equivalent of "mypass"
    * Click on the "Click here to test your server connection and get the available collations" link’
    * You should get a message saying "passed"
    * For the database name, put your equivalent of "mydb"
    * You can use as the Connection Method "SET NAMES" or use "SET CHARACTER SET" and select "latin1_swedish_ci"
    * Click on the "Click here to create your database or to test the selection of your database"
    * You should get a message saying "passed"
    * For Administrator username, enter your user name. Then enter your email, your password and your password again
    * Click "Next"
    * I checked the Sample Web Site box, left all the other boxes checked and clicked "Install"
    * The Pre-install validation screen should come up with all OK’s. Click "Install"
    * The Install results web page should come up all green. Click "Close"
    * You will be taken to the manager web page. Enter your user name and password, then click "Login"
    * You now have a MODx website
    • That looks very good. The only thing I noticed is that not all users will be using latin1_swedish_ci (though many are).

      Thanks for the contribution. laugh
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
      • Quote from: BobRay at Jan 06, 2009, 05:13 AM

        That looks very good. The only thing I noticed is that not all users will be using latin1_swedish_ci (though many are).
        That is the only choice on fatcow.com

        Quote from: BobRay at Jan 06, 2009, 05:13 AM

        Thanks for the contribution. laugh
        You are welcome wink
        • Quote from: Diz at Jan 06, 2009, 05:07 PM

          Quote from: BobRay at Jan 06, 2009, 05:13 AM

          That looks very good. The only thing I noticed is that not all users will be using latin1_swedish_ci (though many are).
          That is the only choice on fatcow.com

          That’s surprising. I’ve never seen a host that restricts the character set of the MySQL dB. Do you have Import capability in PhpMyAdmin? If so, I wonder what happens when you import an SQL dump with UTF-8 specified internally. And can’t you specify the character set when you create the database in PhpMyAdmin -- or does fatcow create it for you?


            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
          • Quote from: BobRay at Jan 06, 2009, 07:22 PM

            Quote from: Diz at Jan 06, 2009, 05:07 PM

            Quote from: BobRay at Jan 06, 2009, 05:13 AM

            That looks very good. The only thing I noticed is that not all users will be using latin1_swedish_ci (though many are).
            That is the only choice on fatcow.com
            That’s surprising. I’ve never seen a host that restricts the character set of the MySQL dB. Do you have Import capability in PhpMyAdmin? If so, I wonder what happens when you import an SQL dump with UTF-8 specified internally. And can’t you specify the character set when you create the database in PhpMyAdmin -- or does fatcow create it for you?
            The first time you create a MySQL database, all you can specify are the Database Name, the Database Login and the Password. No character set. After that, I can go to the MySQLAdmin page. When I do so, the MySQL Charset value is UTF-8 Unicode (utf8) and the MySQL connection collation value is utf8_unicode_ci. When I look at my tables, the collation of all the VARCHAR columns is latin1_swedish_ci.

            Sometimes when I go to my website, I get "Unknown MySQL server host" errors. I am go to reinstall using "SET NAMES" to see if that solves the problem.
            • Since you’re sort of locked into UTF8, did you make sure that’s what is set in manager/includes/config.inc.php before installing?
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
              • Quote from: BobRay at Jan 07, 2009, 09:28 PM

                Since you’re sort of locked into UTF8, did you make sure that’s what is set in manager/includes/config.inc.php before installing?
                Let’s just say that modifying the config.inc.php file didn’t leap to mind. Wasn’t it suppose to be blank before installing?

                I was having a problem where the web site would every so often throw a series of errors:
                >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
                « MODx Parse Error »
                MODx encountered the following error while attempting to parse the requested resource:
                « PHP Parse Error »

                PHP error debug
                Error: mysql_connect() [function.mysql-connect]: Unknown MySQL server host ’ddisney.fatcowmysql.com’ (1)
                Error type/ Nr.: Warning - 2
                File: /hermes/web09d/b458/moo.ddisney/manager/includes/extenders/dbapi.mysql.class.inc.php
                Line: 89
                Line 89 source: if (!$this->conn = ($persist ? mysql_pconnect($host, $uid, $pwd) : mysql_connect($host, $uid, $pwd, true))) {
                <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

                The fatcow tech support came back with:
                >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
                A space was there in the database name in the config.inc.php and has been corrected. Please check your site functioning again.
                <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

                I haven’t had the problem since. Here is some of the current config.inc.php file:
                >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
                $database_connection_charset = ’latin1’;
                $database_connection_method = ’SET CHARACTER SET’;
                <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
                • Hi,

                  I just installed modx 1.0.2 on my fatcow hosting account using these settings with the exception that I choose "SET NAMES" and left it on "utf-8_general" (what ever it is when the page loads) without a problem all seems to be working correctly. Hope this helps someone.
                  • Has anyone been able to install revolution on fatcow?
                    • Please note that FatCow now has MODX Revolution listed as part of the SimpleScripts auto-install programs through the user control panel. I have not tried it yet but it’s promising that it is listed.