-
☆ A M B ☆
- 24,524 Posts
This strongly resembles a similar experience I had with a zombie TV - couldn't delete the TV, couldn't remove it from the template, any such attempts would result in a white-page with errors about a missing TV when trying to edit the resources. Even the MODx Cloud tech support team couldn't find where it was coming from. After a few days, I finally ended up creating new templates and new resources and deleting the affected ones.
I believe this would have solved that:
http://bobsguides.com/sitecheck-tutorial.html. I don't know if it would take care of the OP's problem, but it might.
-
☆ A M B ☆
- 24,524 Posts
Unfortunately this was over a year ago, so I didn't get the chance to try SiteCheck on it. Anyway, there have been a few cases of somewhat similar "zombie" behavior reported, so eventually somebody who has SiteCheck will get one of them and be able to see what SiteCheck finds. It did recently fix a site that had a broken Package Manager; somehow three package files had their filenames corrupted, although they looked fine.
discuss.answer
Good news. I found the problem, and BobRay's sitecheck helped me locate it, so thank you! The reason for the problem was that somehow an entry was made in the modx_document_groups table with the document_group set to 0 for the two groups that were always being selected. I don't know how this association was made, whether by MODx or by a snippet or a plugin, or what, but that's what caused it. It took way too long to discover the problem, but now I know.
One thing that I will mention about the sitecheck utility is that it took me a while to figure out what the feedback meant on the issue that was actually causing the problem. The feedback said
Checking 511 modResourceGroupResources
And it listed the error with a message something like this:
Invalid modResourceGroup(0) for modResource name(2)
I don't have the error message on the screen anymore, so I may not have written the error message exactly as it was, but it as something like that. It took me a while to realize that the message was referring to an entry in modx_document_groups with the document_group set to 0. I mean, your message sort of says that, but I was unfamiliar with what modResourceGroupResources was referring to, so it wasn't self-expanatory.
In any case, I'm grateful that the utility did in fact help me discover the issue, even if I had to first figure out what the utility was telling me!
I'm glad SiteCheck helped. Now that you mentioned it, I think the error went away for me after running SiteCheck and cleaning things up. I hadn't encountered the error recently and didn't make the connection until now.
Yes, it was telling you that the Resource with the pagetitle "name" was connected to a non-existent Resource Group (with an ID of 0). That was in the Intersect Tests section. I tried to explain intersects and the resulting error messages in the Docs, but if you don't understand database intersect tables, it's a little difficult to follow. I'll take a look at the docs and see if I can improve things.
Thanks for the feedback.
I do understand intersect tables. What took some time was trying to figure out which table you were referring to. You mentioned the MODx object name, not the table name, so I had to go through the tables that looked like they might be relevant until I actually found the right one. The object name and the table name don't match.
Still, your utility did help point me in the right direction, which was great.