So far I have updated 10 sites, mostly from 2.2.6 and 2.2.7 but a few older, including one from 2.0.4!
Two sites have multiple contexts, and these are fine.
The one that I have had issues with was upgrading 2.1.3 which failed on the "cannot unpack the core.transport.package" error. After going round in circles for a few hours and then going back to backup, I spend a few days back and forth with the Hosting company. They upgraded the PHP version to 5.3.17+, which also updates Ziplib (i'm lucky here, since it's on shared hosting). After that, I was able to install a fresh copy of Modx.
However, I can't upgrade. It fails at the 3rd screen (options). The issue seemed to be the config.inc.php file in core/config (which is obviously needed for the database configuration options, and lets you do an upgrade instead of a new install). I delete that, boom, no white screen and I can install.
For the site I was working on, it was so small that I ended up doing a fresh install and copying the bits from the old database (seriously, quicker than trying to troubleshoot in this case).
However, has anyone seen that in 5.3.17+ or any suggestions on what's causing this?
No luck here. I tried to upgrade from 2.2.7 several times, merged the update on the webserver and, after that didn't work, on my local computer before upload.
I get a successful pre-installation test. When I then press install, a blank page appears after about one minute, nothing more.
After the unsuccessful upgrade, the website returns a blank page. I paired both the "upgraded" modx-installation and the restored 2.2.7 against the "upgraded" database and the original one, and I see that the problem occurs somewhere in the "upgraded" modx-installation, not in the database.
Both 2.2.7 and '2.2.8 without running the upgrade script' work fine against the 2.2.7-database. After the unsuccessful runs of the upgrade-script, 2.2.8 stops working while a restored 2.2.7 still works fine without restoring the database to the state before the upgrade.
Did you try manually removing all files in the core/cache directory and clearing your browser cache and cookies after doing the upgrade?
I cleared the core/cache directory before and after the upgrade, the browser cache only before. I'll give it another try. Thanks!
Leftover browser cookies can cause all kinds of weirdness in the Manager.
It's probably not what you want to hear, but people with similar problems have solved them by moving to a more MODX-friendly host. I've had very good luck with Bluehost:
http://bit.ly/Hb5CAY