We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36575
    • 104 Posts
    So far I have updated 10 sites, mostly from 2.2.6 and 2.2.7 but a few older, including one from 2.0.4!

    Two sites have multiple contexts, and these are fine.

    The one that I have had issues with was upgrading 2.1.3 which failed on the "cannot unpack the core.transport.package" error. After going round in circles for a few hours and then going back to backup, I spend a few days back and forth with the Hosting company. They upgraded the PHP version to 5.3.17+, which also updates Ziplib (i'm lucky here, since it's on shared hosting). After that, I was able to install a fresh copy of Modx.

    However, I can't upgrade. It fails at the 3rd screen (options). The issue seemed to be the config.inc.php file in core/config (which is obviously needed for the database configuration options, and lets you do an upgrade instead of a new install). I delete that, boom, no white screen and I can install.

    For the site I was working on, it was so small that I ended up doing a fresh install and copying the bits from the old database (seriously, quicker than trying to troubleshoot in this case).

    However, has anyone seen that in 5.3.17+ or any suggestions on what's causing this?
      • 42109
      • 4 Posts
      No luck here. I tried to upgrade from 2.2.7 several times, merged the update on the webserver and, after that didn't work, on my local computer before upload.
      I get a successful pre-installation test. When I then press install, a blank page appears after about one minute, nothing more.
      After the unsuccessful upgrade, the website returns a blank page. I paired both the "upgraded" modx-installation and the restored 2.2.7 against the "upgraded" database and the original one, and I see that the problem occurs somewhere in the "upgraded" modx-installation, not in the database.
      Both 2.2.7 and '2.2.8 without running the upgrade script' work fine against the 2.2.7-database. After the unsuccessful runs of the upgrade-script, 2.2.8 stops working while a restored 2.2.7 still works fine without restoring the database to the state before the upgrade.
        • 3749
        • 24,544 Posts
        Did you try manually removing all files in the core/cache directory and clearing your browser cache and cookies after doing the upgrade?
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 42109
          • 4 Posts
          I cleared the core/cache directory before and after the upgrade, the browser cache only before. I'll give it another try. Thanks!
            • 3749
            • 24,544 Posts
            Leftover browser cookies can cause all kinds of weirdness in the Manager.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 42109
              • 4 Posts
              No success this time either. Another webbrowser, I cleared the browser's cache and cookies and core/cache before and after the install. Blank page at the end of the upgrade procedure, blank page when attempting to reach the site.
              The only things created in the core/cache directory during upgrade is a setup/smart/ folder with footer, install and header .tpl.php files.
              [EDIT] Another try, and now I got a log message in the core/cache/logs folder - similar to http://tracker.modx.com/issues/9965 (declared as invalid) - but for me the install fails.

              [2013-07-17 13:56:05] (ERROR in xPDOManager_mysql::addIndex @ <<removed>>/core/xpdo/om/mysql/xpdomanager.class.php : 329) Error adding index tv_cnt to modTemplateVarResource: Array
              (
              [0] => 42000
              [1] => 1061
              [2] => Duplicate key name 'tv_cnt'
              )

              Can anybody help? Thanks! [ed. note: daoane last edited this post 13 years, 2 months ago.]
                • 3749
                • 24,544 Posts
                It's probably not what you want to hear, but people with similar problems have solved them by moving to a more MODX-friendly host. I've had very good luck with Bluehost: http://bit.ly/Hb5CAY
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting