We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 38357
    • 178 Posts
    Many thanks jgrant. That may well be the problem. The PHP handlers link was a great help. I am currently looking at alternatives to get access to FastCGI instead of suPHP - including a change of server.
    I will post the results if I find a solution.
      • 38357
      • 178 Posts
      Problem resolved.
      After months of querying my hosting company I finally suggested that I would need to move all my domains as there appeared to be a problem with server errors. A couple of days later everything magically returned to normal - no errors in the backend at all and no server memory overloads in the server log. I suggested that someone had changed something as I had not, but this was denied. They indicated that they had done a 'server audit' and found anomalies with other clients.
      What a load of @$#%$! Quite obviously there was an error in the server config somewhere - probably suPHP. It's a pity as up to this point they have been very reliable over many years.
      Anyway everything is once again working perfectly.

      My thanks to everyone for their suggestions as I have learnt a bit through the exercise.
        • 35150 ☆ A M B ☆
        • 191 Posts
        Quote from: bobd72 at Apr 13, 2013, 12:03 AM
        Problem resolved.

        That's great! Sometimes the satisfaction of getting this sort of problem resolved even outweighs the weeks of frustration, though usually not quite : )

        I'm a little curious, what PHP handler is your server running now? You can check it by going to Reports > System Info, view phpinfo(), then look for Server API near the top.
          Extras :: pThumb • Resizer • imageSlim • setPlaceholders
          • 38357
          • 178 Posts
          I hadn't bothered to check this - I was just relieved that everythiong was working.
          A check now reveals:Server API CGI

          All my hosted sites are now running CGI - how strange as they were running suPHP:
          I got yhis reply to a request for changing the API:
          Sorry, as your account is on shared server, we can not change the PHP
          handler for your account.

          If you wish you can go for our dedicated server where you can use PHP
          handler as per your requirement.
          Then I found this (admittedly about four years old) from the Managing Director of *Hosting Company* on a forum which I qouted to Support:
          *Hosting Company* does support FastCGI, so please do go head and sign up.

          If you could also please whim me the ticket ID where you were told that*Hosting Company* doesn't support it that would be great too.

          When things suddenly came online correctly I queried why this had suddenly happened and got:

          We have not made any changes in server configuration or something with
          hardware level. I have replied you after I got the confirmation from our
          admins that they haven't made any kind of changes to server.

          We do regular audits on shared servers and if we found any account under
          AUP violation then we ask the owner of the account to delete the
          contents which usually affects the server performance. AUP violation in
          the sense such that accounts causing server load issues by using more
          resources on server.

          Someone is playing games smiley It just shows that you must be persistent and do your research.