I have posted on this issue before but it persists with no solution, so I thought I would approach it from a different direction.
I have severe problems with my Modx Revolution site. The same symptoms existed with v2.2.4-pl and continue after upgrading to 2.2.6-pl
This is long-winded I know but I am trying to provide as much info as possible – getting desperate.
The problems only exist with the Manager interface– the front end of the site operates as expected.
I have tried turning off all plugins with no change in behavior.
The site is hosted on a shared server and errors indicate that the problem is caused by a server configuration issue but I don't know where to look. Each browser I use reacts differently as below, but all browsers exhibit the same errors from time to time - this is typical but is not always the same for each browser:
Chromium: (Running on Kubuntu Linux)
Shows Dashboard but no left column with Resources/Elements/Files and Undefined at the top. Shows distorted Home page overlaid with Error at the top, Unexpected token <:
and an OK button at the bottom. Clicking OK closes the home page.
Click Security>Manage Users Page reloads and shows the dostorted Home page again. Close this. Menu and Submenus visible but cannot be activated.
Firefox: (Running on Kubuntu Linux)
Opens Dashboard. Overlaid with Error box:
syntax error:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Left column showing but no tree under resources. Clicking Elemnts Tab shows elements tree but same error box as above. Click Files tab and tree is shown OK with no error. Go back to Resources Tab – still empty
Click Security>Manage Users. Page reloads and shows error box as above. Left Menu shows and Resources are now displayed correctly. Clicking Elemnts Tab shows elements tree but same error box as above. Click Files tab and tree is shown OK with no error. Go back to Resources Tab and still displays correctly
Internet Explorer 10: (Running on Windows 7 in VM – similar results on separate box running WindowsXP/IE8)
Logs on correctly – Tabs in left column work OK.
Click Security>Manage Users Select a user, click Update User. Page loads distorted Home page with images missing. Click the OK button and correct editing page is shown but there is no menu at the top. Clicking Back in the browser bring up the Syntax Error window and usenames are not displayed.
ModX Error Log shows:
[2013-03-28 21:42:41] (ERROR in xPDOConnection::connect @ /home/qpgccom/public_html/core/xpdo/xpdo.class.php : 2999) SQLSTATE[HY000] [2013] Lost connection to MySQL server at 'sending authentication information', system error: 32
[2013-03-28 21:42:42] (ERROR @ /index.php) Error preparing statement for query: SELECT `modSession`.`id` AS `modSession_id`, `modSession`.`access` AS `modSession_access`, `modSession`.`data` AS `modSession_data` FROM `qpgc_session` AS `modSession` WHERE `modSession`.`id` = ? - Array
(
[0] => 00000
)
….............................................................
CPANEL shows the following:
Resource Usage Overview
Your site has been limited within the past 24 hours
CPU resources were limited for your site
Memory resources were limited for your site
Every time there is an error the 1Gb memory linit on the server is exceeded:
Server Error log:
Typical entries – often repeated many times:
[Fri Mar 29 08:41:17 2013] [error] [client 203.123.90.130] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/qpgccom/public_html/manager/min/index.php, referer:
http://www.qpgc.com.au/manager/?a=57
[Fri Mar 29 08:38:35 2013] [error] [client 203.123.90.130] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/qpgccom/public_html/index.php, referer:
http://www.qpgc.com.au/manager/?a=48