I'm also getting this error, but there's a lot more to my story.
I'm running apache on my debian 6 server at home, which is currently running multiple instances of modx revo (earlier versions) without issue. Today I downloaded 2.2.6 for a fresh install. During install I ran into a syntax error in my config.inc.php
this thread explains my situation exactly. (that thread is marked as resolved though... my issue isn't)
Briefly though, there's a few sections in my config.inc.php which looked like:
$config_options = {config_options};
and needed to be changed to:
$config_options = '{config_options}';
I made those changes, and then tried to "pick up where I left off" during the install, by trying to reload the url which originally showed the syntax error, something like /setup/index.php?action=summary (might be something else, can't remember) which throws an internal server error. If I then check /var/log/apache2/error.log, I can see the error benzika has reported above:
Fatal error: Class 'xPDODriver_' not found in G:\OpenServer\domains\rusagromaslo\public_html\core\xpdo\xpdo.class.php on line 1823
My google-fu turned up that it should be 'xPDODriver_mysql' and the fact that the 'mysql' bit is missing suggests that the installer didn't complete. ere go - I run into the syntax error mentioned above before installer completes.
If I restart over with the 'new install' option, a new config.inc.php is generated with the same problem as before.
If I try an 'upgrade' with the installer I run in to the xPDO error.
Not sure how to proceed.. posting here because it looks like the same issue to me.. just say if you think I should start a new thread.