We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 42341
    • 1 Posts
    Revo 2.2.6
    please help in the beginning of the installation, this error
    Fatal error: Class 'xPDODriver_' not found in G:\OpenServer\domains\rusagromaslo\public_html\core\xpdo\xpdo.class.php on line 1823
      • 17403 ☆ A M B ☆
      • 183 Posts
      Please check your PDO driver for MySQL in your PHP installation.

      If you have it, you have to make sure the PDO driver support your current MySQL database version. Seem some PDO driver for MySQL not stable. [ed. note: lokamaya last edited this post 13 years, 9 months ago.]
        zaenal.lokamaya
        • 18373 ☆ A M B ☆
        • 3,141 Posts
        In the cases I've seen that error, it doesn't know what driver to load. Try rerunning setup and verifying the $database_type is set in the config file in core/config/config.inc.php. It should look like this:
        $database_type = 'mysql';
          Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

          Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
          • 18373 ☆ A M B ☆
          • 3,141 Posts
          Sorry, just re-reading your post, you say you're getting that error when you start setup? Is there already a core/config/config.inc.php file in place, by any chance?
            Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

            Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
            • 20371
            • 58 Posts
            I'm also getting this error, but there's a lot more to my story.

            I'm running apache on my debian 6 server at home, which is currently running multiple instances of modx revo (earlier versions) without issue. Today I downloaded 2.2.6 for a fresh install. During install I ran into a syntax error in my config.inc.php this thread explains my situation exactly. (that thread is marked as resolved though... my issue isn't)

            Briefly though, there's a few sections in my config.inc.php which looked like:
            $config_options = {config_options};

            and needed to be changed to:
            $config_options = '{config_options}';


            I made those changes, and then tried to "pick up where I left off" during the install, by trying to reload the url which originally showed the syntax error, something like /setup/index.php?action=summary (might be something else, can't remember) which throws an internal server error. If I then check /var/log/apache2/error.log, I can see the error benzika has reported above:
            Fatal error: Class 'xPDODriver_' not found in G:\OpenServer\domains\rusagromaslo\public_html\core\xpdo\xpdo.class.php on line 1823


            My google-fu turned up that it should be 'xPDODriver_mysql' and the fact that the 'mysql' bit is missing suggests that the installer didn't complete. ere go - I run into the syntax error mentioned above before installer completes.

            If I restart over with the 'new install' option, a new config.inc.php is generated with the same problem as before.

            If I try an 'upgrade' with the installer I run in to the xPDO error.

            Not sure how to proceed.. posting here because it looks like the same issue to me.. just say if you think I should start a new thread.
              • 18373 ☆ A M B ☆
              • 3,141 Posts
              Try redownloading the package, and uploading it again, likely a corrupt upload.

              The config options line shouldd be replaced with an empty array during the install; not with '{config_options}' or whatever.
                Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.