We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 18367
    • 834 Posts
    I just installed Revo 2.2.1and straight after the successful install on a local wamp setup I go the this parse error


    Parse error: parse error in D:\wamp\www\Revolution\modx-2.2.1-pl\core\config\config.inc.php on line 13



    Line 12 reads


    $config_options = {config_options};



    Is that correct or does it need to be changed?

    Thanks

    php 5.3 Apache 2.2.11

    This question has been answered by bodhic. See the first response.

    [ed. note: markg last edited this post 14 years, 5 months ago.]
      Content Creator and Copywriter
      • 18367
      • 834 Posts
      Seems to be an issue with Revo 2.2.1

      I just installed 2.2.0.pl2 and it worked flawlessly.

        Content Creator and Copywriter
        • 18367
        • 834 Posts
        Anyone know how to fix this error?

        I can't move on until I get this resolved, as some of the key addons i want to use won;t work in the earlier versions.

        THanks
          Content Creator and Copywriter
        • discuss.answer
          • 36626
          • 51 Posts
          I had the same problem and this fix worked for me:

          Lines 13-16:
          $config_options = array (
          );
          $driver_options = array (
          );
          


          Lines 90-93:
          if (!defined('MODX_CACHE_DISABLED')) {
              $modx_cache_disabled= false;
              define('MODX_CACHE_DISABLED', $modx_cache_disabled);
          }
          


          Hopefully this will work for you.
            • 18367
            • 834 Posts
            Thanks Darryl,

            but in the end I didn't have to.

            I ripped out the install, re downloaded the zip file and started again.

            Hey presto, no problems.

            Ah well.
              Content Creator and Copywriter
              • 3403
              • 7 Posts
              Parse error: syntax error, unexpected '{' in /srv/http/public_html/core/config/config.inc.php on line 13 Call Stack: 0.0001 659784 1. {main}()

              Line 13, 14

              $config_options = {config_options};
              $driver_options = {driver_options};
              

              replace on
              $config_options = '{config_options}';
              $driver_options = '{driver_options}';



              Parse error: syntax error, unexpected '{' in /srv/http/public_html/core/config/config.inc.php on line 89 Call Stack: 0.0001 660360 1. {main}()

              Line 89

              $modx_cache_disabled= {cache_disabled};

              replace on
              $modx_cache_disabled= '{cache_disabled}';
                • 41871
                • 3 Posts
                This is very odd. I just loaded version 2.2.5 and during the install got the same errors. I made all of the above corrections, before I saw this thread, and then I got:

                Fatal error: Class 'xPDODriver_' not found in C:\xampp\htdocs\cms\modx\sitename\core\xpdo\xpdo.class.php on line 1823

                I'm using Windows 7, XAMPP local server, got all of the green check marks during installation. This is my first try with Modx, and I'm wondering why I need to debug code during installation. Or did I install the wrong version?
                  • 4955
                  • 32 Posts
                  installed 2.2.5 and got exactely that error. thanks for your hints! helped me installing modx revolution on the clients hoster.
                  apache2.0 php5.2.14 mysql5.0.67 [ed. note: charismeki last edited this post 13 years, 10 months ago.]