We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36047
    • 30 Posts
    Hello all!

    I have a problem. My site has two large sections: News and Information. They have a lot of resources, when I try to open them in the resource tree - it takes a long time. Thats why i decided to install a component for group editing (not in the tree) Batcher. I installed it via package manager with no problems and errors, cleaned cache, reset permissions, reload page again. In manager menu appears "components" item and Batcher item in it, BUT when i following Batcher item i can not see any resources. In component page all displayed well, but in the list there is absolutely no resources.

    Tried to install Group Edit - same problem. In the system settings of component I entered needed ID and title, but again nothing.

    In the website with Shopkeeper with the same version of Modx Revo 2.2.5 Group Edit also installed and working fine.

    Help please, who knows. I'll be glad to hear any thoughts on the matter.

    Modx Revo 2.2.5 version
    Batcher 1.1.1
    Group Edit 1.0

    Tried this components on the same site with the version Modx Revo 2.1.0, the same problem.

    P.S. Tried Doc Manager, after installing with errors i did not use it. [ed. note: spbox last edited this post 13 years, 10 months ago.]
      • 36047
      • 30 Posts
      Resolution was very simple: just set 755 permissions on "assets" folder and all subfolders!
      Good luck!
        • 47674
        • 2 Posts
        Hello!

        The problem seems to be appear again!

        I`ve MODX Revolution 2.2.14-pl (traditional)
        This packages:

        • Batcher-1.1.1-pl
        • Gallery-1.6.2-pl
        • Group_edit-1.2-pl (multiple resource editing, like a batcher)

        Not worked properly. The Batcher & Group edit show the empty resource grid in backend. In web inspector (safari plugin) I see the 500 Error while mods try to receive assets/components/.../connector.php

        The Gallery not working properly. When I try to create album, after clicking 'Save' progress bar goes to 100% and album not created (no entry in grid, no folder in hosting viewing by sFTP and SSH). In web inspector the same 500 internal server error assets/components/gallery/connector.php?action=mgr/album/getNodes&id=root

        I try to set 0777 and 0755 permissions to assets/components, core/components core/packages, but no results!

        sFTP (SSH) user and user group not matching the PHP web-sever group (user 'apache')

        modx system log about this problem is clear...
        [ed. note: slava_chunk last edited this post 12 years, 4 months ago.]
          • 47674
          • 2 Posts
          This is the same problem
          https://forums.modx.com/thread/74763/solved-problem-with-components-accessing-database-after-installation
          But the solving as set 0777 or 0755 permissions not working!